Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#234 closed defect (unknown)

ACPI, Intel 945GCNL

Reported by: blondeguy Owned by: pasha
Priority: major Milestone: Release version 3.08
Component: ACPI PSD Version: 3.08
Keywords: Cc:

Description

ACPI.PSD 3.08 3/28/2008
no APM
Intel 945GCNL

Computer gets trap at boot time right after boot logo. Without ACPI.PSD, computer boots normally, but sound loops for either of UNIAUD or C-MEDIA audio drivers. There are no switches used in psd=acpi.psd line in config.sys.

I removed os2logo, used debug version of ACPI.PSD, and computer stops after two logging lines. Digital photos of the screen with and without debug version included

This computer is mine and I will be available for more testing. Let me know how I can help.

Attachments (9)

trap.jpg (90.3 KB) - added by guest 10 years ago.
debug.jpg (58.2 KB) - added by guest 10 years ago.
acpi_with_uniaud.log (10.6 KB) - added by guest 10 years ago.
acpi-log-Model-of-your-PC.ziq (51.3 KB) - added by guest 10 years ago.
Hang 0.JPG (57.5 KB) - added by guest 10 years ago.
Hang 0
hang 1.JPG (57.7 KB) - added by guest 10 years ago.
Hang 2.JPG (53.2 KB) - added by guest 10 years ago.
Hang 3.JPG (40.0 KB) - added by guest 10 years ago.
APIC hang.jpg (53.8 KB) - added by guest 10 years ago.

Download all attachments as: .zip

Change History (42)

Changed 10 years ago by guest

Changed 10 years ago by guest

comment:1 Changed 10 years ago by guest

Bug reported by Neil Waldhauer, neil@…

comment:2 Changed 10 years ago by eco

e-co

disable unnecessary devices (audio adapter, ..)

check the documentation, do you follow the installation instructions?

comment:3 Changed 10 years ago by pasha

Try add /SAP:0x20 option

comment:4 Changed 10 years ago by guest

e-co, even the eCS 2.0 rc4 CD will not boot (no audio driver) I tried to follow installation instructions, but I am an imperfect user, so who really knows?

pasha, system boots fine with /SAP:0x20 (but if audio adapter present, it still has the looping sound)

comment:5 Changed 10 years ago by pasha

Need do copy acpica$ acpi.log and attach log here

comment:6 Changed 10 years ago by eco

The motherboard is equipped with HDAudio.

Please REM UNIUAD drivers.

Changed 10 years ago by guest

comment:7 Changed 10 years ago by guest

I have attached acpi.log. I tried with and without the UniAud? drivers and the only difference in the log is that without UniAud?, the last four lines of acpi.log are not there.

e-co, the motherboard has HD audio, so I started with a PCI sound card, but I have now removed that card to make testing as simple as possible.

comment:8 Changed 10 years ago by guest

With ACPI13042008.ZIP components ACPI.PSD and ACPI32.DLL, I can now boot this computer with no command line switches (PSD=ACPI.PSD)

comment:9 Changed 10 years ago by eco

  • Resolution set to fixed
  • Status changed from new to closed

OK, I added the MB to ACPI-Hardware.doc

btw, test with official 3.9 release

Changed 10 years ago by guest

comment:10 Changed 10 years ago by guest

  • Resolution fixed deleted
  • Status changed from closed to reopened

With ACPI 3.09 installed, computer boots OK.

Now I'm using this computer full time, and I see a number of oddities. None of this happens every time. If I reboot a few times, I'll get good performance that works all day until I turn the machine off.

  1. Slowness -- when the computer boots, there is a chance that it will act "slow." In this case, many actions such as starting Firefox, or rendering a web page will be very slow. Other times the computer boots and it appears to be fine. I used the log collector on a boot that was slow. The log file is attached. (for 3.09)
  1. X-Workplace sometimes can't shut down, but gets stuck with a message similar to "Ugh. waiting for exception..." (only with 13042008)
  1. Sometimes boot stops at logo. (only with 13042008)

comment:11 Changed 10 years ago by eco

e-co

1), 2) Pasha recommends to try Panorama VESA.

SMP + slow boot -> maybe caused by SNAP

3) do you have USB stick attached?

comment:12 Changed 10 years ago by eco

e-co

Pasha continues:

  • Better try boot to /APIC /SMP mode so no IRQ conflicts and you can use sound, USB.
  • do you use HT? disable it.
  • UNI: if USB controllers occupy one IRQ then goto BIOS setup, try assign different IRQs.

comment:13 Changed 10 years ago by stevenhl

  • Milestone set to Release version 3.10

comment:14 Changed 10 years ago by guest

Thanks for the suggestions.

I have set up another boot volume with Panorama, most drivers disabled, and /APIC /SMP mode in use. I can use sound and USB, but even with every driver disabled, it sometimes hangs on boot. (using Alt-F2, it seems to stop on any BASEDEV line, not the same one each time.)

No USB stick is in use, no HT device (real Core 2 Duo Pentium chip), HD audio disabled in BIOS and using C-Media sound card.

But the system still starts sporadically.

For my original boot volume with SNAP and plain eCS 2.0 rc 4, I checked IRQ and found that I had 3 lines of USB UHCD driver instead of 4 lines. After adding one more line, the system still hangs sometimes, but is more likely to start OK. (This is OK for me to use, but not quite enough for me to sell to a customer.)

Unfortunately, I have found no way to reassign IRQ in the BIOS. I remain available for test or log collection.

comment:15 Changed 10 years ago by guest

e-co:

let's continue the experiments,

try 1) boot without USB,

2) try disable USB 1,1 controllers,

3) USB 2.0 controllers.

comment:16 Changed 10 years ago by guest

OK, I have made version of config.sys with all USB statements disabled Booting with /SMP /APIC GenMac? is still enabled Works most times, but sometimes hangs at boot logo.

comment:17 Changed 10 years ago by eco

OK, we need the photo of the screen, here are the instructions how to get photo:

http://ecomstation.ru/projects/acpitools/?action=logs -> LOGS-1

make the photo of the screen when the computer hangs, attach the photo to the ticket.

Changed 10 years ago by guest

Hang 0

Changed 10 years ago by guest

Changed 10 years ago by guest

Changed 10 years ago by guest

comment:18 Changed 10 years ago by guest

Using ACPI 20080423 debug version

I placed a reboot icon in the startup folder. Started computer, rebooted many, many times without fault. Power off, then on, computer hangs (Hang 0.jpg) power off. Several hours later, power on again (Hang 1.jpg), pressed reset (Hang 2.jpg), pressed reset (Hang 1.jpg again), pressed reset, computer boots 5 times OK, then hangs again (Hang 3.jpg).

I hope this is helpful.

comment:19 Changed 10 years ago by eco

e-co:

Hang 2 jpg - a snooper is loaded..

Did you read the documentation, the snoop.lst should be emptied (read ACPI FAQ -> Q47: eComStation 2.0: is it necessary remove all snoopers from snoop.lst?)

Changed 10 years ago by guest

comment:20 Changed 10 years ago by guest

Thanks e-co, for note about snoop.lst. The attachment APIC hang.jpg now shows a hang with the following snoop.lst. While this computer still does hang, it appears to be less frequent with this reduced snoop.lst.

; alternative SNOOP.LST file for ACPI support IBMKBD.SNP PCIBUS.SNP

comment:21 Changed 10 years ago by guest

e-co:

please remove PCIBUS.SNP from snoop.lst

comment:22 Changed 10 years ago by Blonde Guy

I removed PCIBUS.SNP from the snoop.lst. This looks like it worked for partition with Panorama. I will try adding back device drivers and see if I can make a usable computer. Look for report in a few more days.

Thanks to Eugene for netlabs registration page!

comment:23 Changed 10 years ago by stevenhl

  • Milestone changed from Release version 3.10 to Release version 3.11

comment:24 Changed 10 years ago by eco

e-co:

OK, Intel motherboards are supported very well.

The ticket should be closed.

comment:25 Changed 10 years ago by eco

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:26 Changed 10 years ago by Blonde Guy

OK, now I have completed testing. With /APIC enabled, the computer can boot reliably, but it cannot support either USB or audio. Must use Panorama Video.

Without /APIC enabled, computer does not boot reliably, but when it does boot, then it supports fully accelerated SNAP video, USB and audio.

e-co, I disagree that Intel motherboards are supported well. I cannot offer this machine to customers at this time.

Are there any other command line options to try?

comment:27 Changed 10 years ago by eco

  • problems with USB => try /CD
  • do you test ACPI 3.10?
  • please always attach acpi logs

comment:28 Changed 10 years ago by eco

  • try different version of UNIAUD. it wass improved for APIC mode in this year.

comment:29 Changed 10 years ago by Blonde Guy

Please close this ticket.

I have abandoned the Intel motherboard. At Warpstock, I compared notes with Lewis Rosenthal, and we discovered that neither of us has had any joy with it.

I'll follow up on eCS.ru with a report that the motherboard does not work well with eCS.

Thanks for trying. I have switched out the motherboard for an Asus PL5-Mx motherboard, and I hope that works better. So far at least, it does.

I think you should not mark this bug as fixed. There must be a status for "Can't fix".

comment:30 Changed 10 years ago by stevenhl

  • Milestone changed from Release version 3.11 to eCS 2.x
  • Reporter changed from guest to blondeguy

There's really no such thing as can't fix. The term I prefer is can't (or won't fix) now. The future is hard to predict. I've moved to ticket to a future milestone so that the developers can ignore it for now.

comment:31 Changed 9 years ago by stevenhl

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:32 Changed 9 years ago by stevenhl

  • Resolution set to unknown
  • Status changed from reopened to closed

comment:33 Changed 9 years ago by stevenhl

  • Milestone changed from eCS 2.x to Release version 3.08
Note: See TracTickets for help on using tickets.