Opened 11 years ago

Closed 9 years ago

#220 closed defect (unknown)

Dell Optiplex GX620

Reported by: gyoung Owned by:
Priority: major Milestone: Release version 3.18
Component: ACPI PSD Version: 3.08
Keywords: Cc:

Description

From: Gregg Young

I have gotten this working in RC4 using the 2-28-08 ACPI.psd. It requires /FS /APIC /CD /SAP:0x20 /EIS to boot. Otherwise it stops at a line that says it is initializing devices/events/objects. APIC works providing high irqs and hypertreading works using 104a SMP Kernel. The problem at that point was very slow video performance using SNAP with with an ATI Radeon X600 Series card. I experimented further and determined that using SAP:0x25 fixed the video problem.

Attachments (2)

acpilog.zip (25.6 KB) - added by guest 11 years ago.
IMG_3127.png (91.5 KB) - added by gyoung 11 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 11 years ago by guest

1) Disable hypertreading, it is not stable

2) try boot without SAP switch.

Dell computer -> try use /FS + SMP kernel

IF no /SMP switch then /APIC is not needed

Changed 11 years ago by guest

comment:2 Changed 11 years ago by guest

I am attaching several log files created using different switches. No switches won't boot PSD=ACPI.PSD /FS /SMP /APIC /SAP:0X20 /CD /EIS (ACPI.log) PSD=ACPI.PSD /SMP /APIC /SAP:0X20 /CD (acpiapiccd.log) This one works the best performance wise. PSD=ACPI.PSD /SAP:0X20 (acpisiponly.log) PSD=ACPI.PSD /SMP /PIC /SAP:0X20 (acpismppic.log) PSD=ACPI.PSD /SMP /APIC /SAP:0X20 /CD /EIS (acpinofs.log)

The machine is single processor with hyperthreading.

comment:3 Changed 11 years ago by pasha

SNAP don't work right with SMP. I see your log. You don't need in /FS, you don't need in /EIS. Can you boot without /SAP:0x20 ?

comment:4 Changed 11 years ago by guest

An additional note shut down doesn't work properly. Using Xshutdown it will turn off the computer but it immediately comes back on. If I set it the use ACPI for power off the reboot caused by the restart fails (hangs with the logo showing) If I use APM the reboot caused by the power off works.

comment:5 Changed 11 years ago by pasha

If PowerOff?.exe work right - problem outside acpi

comment:6 Changed 11 years ago by guest

Poweroff does the same thing. The power goes off but comes back on 3-4 seconds later.

comment:7 Changed 11 years ago by mckinnis

Check your BIOS settings carefully. My ThinkCentre? has some very odd options that cause it to come back on after a power off.

comment:8 Changed 11 years ago by stevenhl

  • Milestone set to Feedback pending

comment:9 Changed 11 years ago by gyoung

Hi

Sorry for the long delay in responding. I can confirm that /FS and /EIS are not needed. However without /SAP:0x20 it hangs early in the boot sequence. I will try RC 5 this weekend and report back. I have hyper threading turned off. I only turned it on for testing. I don't know what is causing the problem with the restart. It doesn't restart if the power is cut (power outage) even if it is very brief.

comment:10 Changed 11 years ago by gyoung

I installed RC5 it works with the default settings /FS /PIC. It also works with the recommended settings (adds /SMP) and the SMP kernel if hyperthreading is off. It works with it on but is very slow. It does hang with /APIC when the uniaudio 1.1.4RC4 driver loads. I consider this issue resolved. Thanks

comment:11 Changed 11 years ago by eco

  • Resolution set to fixed
  • Status changed from new to closed

comment:12 Changed 11 years ago by gyoung

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:13 Changed 11 years ago by gyoung

Version (RC6a) 3.14 fails to boot from CD. The problem may not be the same the SAP:0x20 switch doesn't fix it. If ACPI 3.14 is installed to hard drive it will boot if No hardware detection is set either in the the hardware object or at boot time using ALT+F1 F6 (I think). The point of failure using the debug driver is shown in the attached picture. It fails silently.

Changed 11 years ago by gyoung

comment:14 Changed 11 years ago by eco

Pasha reminds:

it's necessary use /FS switch, do you use it?

comment:15 Changed 10 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI-APIC-BAT.ZIP

comment:16 Changed 10 years ago by stevenhl

  • Reporter changed from guest to gyoung

comment:17 Changed 10 years ago by pasha

  • Owner pasha deleted
  • Status changed from reopened to new

comment:18 Changed 9 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.18
  • Resolution set to unknown
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.