Opened 11 years ago

Closed 9 years ago

#193 closed defect (unknown)

ASUS M2N-E mobo won't boot when apic is set to /smp ... /apic

Reported by: Pete Owned by:
Priority: major Milestone: Feedback pending
Component: ACPI PSD Version: 3.14
Keywords: Cc:

Description

This may be duplicate: the first time I tried to open a ticket, I was informed, upon submission, that I didn't have high enough status.

I recently install eComStation 2.0 RC4 on a computer with an ASUS M2N-E mobo, with an AMD 64 X2 Dual-Core Processor (5600+). The install was smooth, in vga mode.

Currently I cannot take advantage of the dual core because I cannot get ACPI to work in SMP mode. The system runs reasonably well as long as I do not use the ACPI.PSD switch /APIC. My understanding is that this system, with its nVidia nForce 570 Ultra MCP chipset will operate in SMP mode with APIC turned on only.

When I use this switch the system stops booting after OS2ASPI.DMD is installed. As a further note, if I rem this driver out, the system stops booting when OS2SCSI.DMD is installed. If this driver is rem'd out as well the system stops booting when OS2LVM.DMD is installed. In all cases I can reboot with ctrl-alt-delete.

In addition to devices on the motherboard I have:

Adaptec 2940 UW. SoundBlaster? Live 5.1 (the resident Realtek AC97 is disabled). Saphire x1650 (ATI) PCI-E video card.

All drivers came with the install disk.

I have tried the following switches: /AFS /TMR. I have also tried several /DV:xx switches, but, there are many combinations and I have no idea of what to look for in determining the correct number(s) to use.

I have also tried the REMAP directive in the acpi.cfg file. If I understand the LINK_IRQ.doc file, the LINK directive will be of no help because there is no confusion of IRQ between PCI and PIC.

Attachments (1)

m2ne-acpilogs.zip (7.4 KB) - added by guest 11 years ago.
contains output of pci.exe and acpica$

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by guest

contains output of pci.exe and acpica$

comment:1 Changed 11 years ago by eco

1) Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

acpi31012008.zip

2) Check this document: http://ecomstation.ru/projects/acpitools/?action=acpi-scsi

comment:2 Changed 11 years ago by guest

I added the lines:

  • REMAP 17 TO 11
  • REMAP 18 TO 10

once again, to acpi.cfg (and I want to stress that I had these lines in the file before)

This time the system booted to almost the desktop, stopping at the USBRESMSG.SYS driver.

I had already installed the experimental build, acpi31012008 to the boot. I since removed it, it made no effect. At least I got that far.

comment:3 Changed 11 years ago by guest

I thought I would add my recent experience with a conflict between the SATA controller and a Adaptec 2940. I recently installed a Thinkcentre M50 with a SATA controller. I put in an Adaptec 2940 and TWAIN to support my HP scanner. Every time I touched TWAIN, the system trapped. I went into the BIOS and noticed that the SATA controller operation was set to "Automatic". I changed it to "Serial ATA", and the conflict disappeared.

Chuck McKinnis?

comment:4 Changed 11 years ago by guest

Thanks for the advice Chuck, but I don't have that SATA option in the BIOS. Although it would not surprise me if there were a conflict.

I have reinstalled eComStation 2.0 RC4. Updated the acpi files and include acpi.psd verion 3.06. I have also renamed OS2Logo. With the /SMP /APCI switches, and the REMAP directives stated above, the boot process now goes as far as the point at which I would expect the graphical interface to start.

The progress lines for the acpi components come and go faster than I can capture them. The last 3 lines before the boot process stops are: Dummy 2C IDT FFDBF370 Vector F3 Dummy 2F IDT FFDBF370 Vector F2 Dummy 2E IDT FFDBF370 Vector 2E

The IDE hard drive light remains on. I require the reset button to reboot.

In addition, contrary to the documentation for acpi, I am getting access to both of the dual processors. (Or so it seems.)

comment:5 Changed 11 years ago by pasha

you can try next:

LINK LNK2 5

LINK LNK3 7

REMAP 17 TO 5

REMAP 18 TO 7

comment:6 Changed 10 years ago by guest

Hi

Using acpi v3.08/v3.09 and test builds in between I find this is the minimum line required to get a booting system with everything sort of working:-

PSD=ACPI.PSD /SMP /TMR /APIC /CD /!NOD

You may not need /!NOD with v3.06 - I did not try that 1; v3.05 was Not nVidia nForce430/MCP615 friendly at all and simply refused to boot my system regardless of switches used.

I say "sort of working" above because it is impossible to attach more than 1 USB drive at a time and Shutdown, in any form, may or may not work... Yes, I did try the /R switch and found that made no difference to Shutdown working or not.

Hope the above is of help/use

Pete

comment:7 Changed 10 years ago by stevenhl

  • Milestone set to Feedback pending

comment:8 Changed 10 years ago by stevenhl

  • Reporter changed from guest to Pete

Pete,

Have current acpi.psd builds resolved this problem?

comment:9 Changed 10 years ago by pasha

  • Version changed from 3.06 to 3.14

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI-APIC-BAT.ZIP

comment:10 Changed 10 years ago by pasha

  • Owner pasha deleted

comment:11 Changed 9 years ago by stevenhl

  • Resolution set to unknown
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.