IBM Networks Primary Logon Client for Windows NT and Windows 2000 Professional ユーザーズ

IBM Networks Primary Logon Client for Windows NT and Windows 2000 Professional ユーザーズ・ガイド

IBM(R) Networks Primary Logon Client for Windows NT(R) および Windows 2000 Professional は、 OS/2 Warp(R) Server for e-business に接続する Windows NT 4.0 クライアントおよび Windows 2000 Professional クライアントの機能を拡張します。

本ユーザーズ・ガイドはhttp://techsupport.services.ibm.com/asd-bin/doc/ja_jp/winntcl2/f-lic.htmからダウンロードされるIBM(R) Networks Primary Logon Client for Windows NT(R) および Windows 2000 Professional付属のHelpFile（英語版）を日本語に翻訳したものです。

本ユーザーズ・ガイドでは、ヘルプ トピックの一覧がテーマごとに分類されて表示されます。それぞれのテーマに含まれるトピックを表示するには、本のアイコンをダブルクリックします。トピックを表示するには、トピックのアイコンをクリックし、[表示] をクリックします。
本を閉じるには、本のアイコンをダブルクリックします。


新しいページ 1

『探索』を構成して別名またはネット名を表示

『探索』を構成すると、別名もしくはネット名を使って定義された共有リソース用のドメインを探索することができます。

『探索』を構成してネット名でリソースを表示する
    １．x:\WINNTディレクトリーにあるSYSTEM.INIファイルを編集します。(注：ｘはWindows NTもしくはWindows2000O 格納ディレクトリーです)[Network]セクションに以下の行を追加します。
      browsealias=no

    ２．SYSTEM.INIの変更を保存します。次回、『検索』ボタンを押して共有のディレクトリーやプリンターを検索すると、そのドメインのネット名とサーバーが表示されます。

『探索』を構成して別名でリソースを表示する
    １．x:\WINNTディレクトリーにあるSYSTEM.INIファイルを編集します。(注：ｘはWindowsNTもしくはWindows2000OS格納ディレクトリーです)[Network]セクションに以下の行を追加します。
browsealias=yes

    ２．SYSTEM.INIの変更を保存します。次回、『検索』ボタンを押して共有のディレクトリーやプリンターを検索すると、そのドメイン上の別名が表示されます。

INIファイルの編集に関する詳しい情報は、『DOS LAN Services』と『Windows Users Guide』をご参照ください。


２次認証の構成 IBM Networks Clientを使って

２次認証の構成

IBM Networks Clientを使って、OS/2 Warp Serverドメイン以外のロケーションにもログオンすることができます。１次認証にてOS/2 Warp Serverドメイン以外のログオン・ロケーションを選択した場合には、同時に２次認証にて、OS/2 Warp Serverドメインを設定することが可能になります。

２次認証を構成するには
    1 　『スタート』ボタンをクリックして『設定』を選択し、次に『コントロールパネル』をクリックします。『コントロールパネル』が表示されます。
    2　 『ネットワーク』（Windows2000の場合は『ネットワークとダイヤルアップ接続』）をダブルクリックします。
        『ネットワーク』ノートブックが表示されます。(Windows2000の場合は有効な『ローカルエリア接続』のプロパティーを開いてください。)
    3　 『ネットワークの設定』タブ（Windows2000の場合は『全般』タブ）をクリックします。
    4　 『現在のネットワーク構成』のリストで，IBM Networks Client を選択して『プロパティ』をクリックします。
    5　 『SMB ドライバ』タブをクリックします。
    6　 『２次認証が可能です。』チェックボックスをチェックします。
    7　 『Warp Serverドメイン』欄に有効なドメイン名を入力します。
    8　 以下のいずれかを行ってください。
        ・ユーザー・アカウントを有効にするサーバーをドメインに判別させるのであれば、
          a 『ログオンを認証するサーバーをドメインに判別させます。』をクリックします。
          b Microsoft Windows NT ワークステーションがドメイン・サーバーにログオンする際の試行回数を設定するには、『ログオン・ブロードキャストの試み』のリストの下矢印をクリックして表示された選択肢の中から１つ選びます。
          c Windows NT ワークステーションがドメイン・サーバーからの応答を待つ時間を短くしたり長くしたりするには、『ログオン・ブロードキャストの待機』のリストの下矢印をクリックして表示された選択肢の中から１つ選びます。

        ・そのドメインにてユーザー・アカウントを有効にするサーバーを指定するのであれば、
          a 『ログオンを認証するログオン サーバー名を指定します。』をチェックします。
          b 『ログオン サーバー名』欄に有効なサーバー名を入力します。
    9　 『OK』をクリックします。
    10 以下の手順を行って、ユーザー・アカウントとパスワードの整合性が確実に取れているようしてください。
        ・Windows NTのユーザー・IDとパスワードがOS/2 Warp Serverのものと一致していない場合は、Windows NTのユーザー・IDとパスワードを変更します。
        ・Windows NTのユーザー・アカウントがない場合は、Windows NT(またはWindows2000)のユーザー管理機能を使って、ユーザー・アカウントとユーザーIDを作成します。


GUI のカスタマイズ
■■■Windows95版　W95net.hlpを編集及び転載■■■

ネットワーク管理者として，グラフィカル・ユーザー・インターフェース(GUI)の外観をカスタマイズしたり，メニュー・バー項目のユーザー・アクセスを制限することができ，また，特定のユーザーだけがログオンおよびログオフできるようにGUI を隠すことができます。ユーザーのログオン時割当てまたはログオン時接続が修正できないときに，ユーザーがジョブを実行できるように調整されている標準ワークステーション構成を提供したいときには，これを使用すると便利です。

GUI をカスタマイズするには

    1 エディタを使用して，WDLS.INI ファイル(d:\WINNT\SYSTEM32 ディレクトリ)を作成します。

    2 WDLS.INI ファイルに，変更するセクションヘッダーとエントリだけを組み込みます。図1 に，すべての見出しとエントリを含むWDLS.INI ファイルのサンプルを示します。
    3 任意で，ATTRIB コマンドを使用してWDLS.INI ファイルを隠します。こうすることで，ユーザーによってこのファイルが変更されないようにします。

図1 -WDLS.INI ファイルのサンプル(すべてのヘッダーとエントリがあります)

[MenuBar]
User=1
UserComment=1
Applications=1
Drives=1
DriveAssignments=1
Printers=1
PrinterAssignments=1
Messages=1
Help=1

[MainWindow]
HideMainWindow=0
ShowNormalAtStartup=1
Toolbar=1

WDLS.INI ファイルでは，0 は項目を使用不可にし1 は項目を使用可能にします。デフォルトは1 です。[MenuBar]セクションは，メインウィンドウのメニューバー項目をコントロールします。[MainWindow]セクションには，
以下のコントロールがあります。

HideMainWindow

メインウィンドウを完全に隠します。これにより，適切なコマンド ラインパラメータでWDLS.EXE ファイルを呼び出すプログラムアイコンを作成することにより，ログオンおよびログオフ機能だけを提供することができます。

ShowNormalAtStartup

ユーザーがWindows NT(Windows2000) を起動したときに，メインウィンドウがどのように動作するのかをコントロールします。デフォルトの動作(=1)を設定すると，メインウィンドウはデスクトップの中央に表示されます。(=0)を設定すると，メインウィンドウはユーザーがアイコンを選択するまで，最小化されたアイコンとして表示されます。アイコンを選択すると，メインウィンドウはデスクトップの中央に表示されます。

ShowNormalAtLogon

ユーザーがログオンしたときに，メインウィンドウがどのように動作するのかをコントロールします。デフォルトの動作(=1)では，メインウィンドウはデスクトップの中央に表示されます。(=0)設定では，メインウィンドウはユーザーがアイコンを選択するまで，最小化されたアイコンとして表示されます。このアイコンを選択すると，メインウィンドウはデスクトップの中央に表示されます。

Toolbar

メインウィンドウのツールバーをコントロールします。(=0)を設定すると，ツールバーは表示されません。

たとえば，『ログオン時ドライブ割当て』ウィンドウと『ログオン時プリンタ割当て』ウィンドウを使用不可にするには，WDLS.INI ファイルに以下のエントリがなければなりません。

[MenuBar]
DriveAssignments=0
PrinterAssignments=0


IBM Networks Client の動作の変更

SYSTEM.INI ファイル(x:\WINNTディレクトリ)の[Network]セクションにある以下のパラメータで，IBM Network Client の動作を変更することができます。

パラメータ 　　値 　　　説明

browsealias= Yes|No Windows でブラウズ オプションを使用しているときに，ネット名または別名を表示するかどうかを指示します。デフォルト値はyesです。


IBM Networks Client のバージョンの判別

Windows NT ネットワーク ノートブックを使用してバージョンを判別するには

    1　 『スタート』ボタンをクリックして『設定』を選択し、次に『コントロールパネル』をクリックします。『コントロールパネル』が表示されます。

    2　 『ネットワーク』（Windows2000の場合は『ネットワークとダイヤルアップ接続』）をダブルクリックします。
        『ネットワーク』ノートブックが表示されます。(Windows2000の場合は有効な『ローカルエリア接続』のプロパティーを開いてください。)

    3　 『サービス』タブ（Windows2000の場合は『全般』タブ）を選びます。

    4　 『現在のネットワーク構成』のリストで、IBM Networks Primary Logon Clientを選びます。

    5　 『プロパティー』ボタンをクリックします。

    6　 『一般』または『拡張』タブで，LAN システムアイコンを指して右マウス ボタンをクリックします。

    7　 『製品情報』をクリックします。バージョン情報が表示されます。

IBM Networks Client を使用してバージョンを判別するには

    1　 『スタート』ボタンをクリックして『プログラム』を選択し，次にIBM NetWorks Client をクリックします。

    2　 『ヘルプ』メニューで『バージョン情報』をクリックします。バージョン情報が表示されます。


IBM Networks Client をデスクトップから削除

IBM Networks Client をデスクトップから削除するには

    1　 ネットワーク管理者権限を持つユーザー名でシステムにログオンします。

    2　 『スタート』ボタンをクリックして『設定』を選択し、次に『コントロールパネル』をクリックします。『コントロールパネル』が表示されます。
    3　 『ネットワーク』（Windows2000の場合は『ネットワークとダイヤルアップ接続』）をダブルクリックします。
        『ネットワーク』ノートブックが表示されます。(Windows2000の場合は有効な『ローカルエリア接続』のプロパティーを開いてください。)
    4　 『サービス』タブ（Windows2000の場合は『全般』タブ）を選びます。
    5　 『現在のネットワーク構成』のリストで、IBM Networks Primary Logon Clientを選びます。
    6　 『削除』をクリックします。
    7　 『OK』をクリックします。
    8　 コンピュータを再起動します。
    9　 CTRL+ALT+DELでログオンします。『ログオン情報』ウィンドウが表示されます。
    10 レジストリーの更新とIBM Networks Primary Logon Clientファイルの削除を完了するには、ネットワーク管理者権限を持つユーザー名でログオンしてください。


IBMGinaユーザー

IBMGinaユーザー・アカウントとサービスの使用

IBM Networks Primary Logon Clientは、Windows NTの『サービス』を独自のユーザー・アカウントと一緒に使います。『サービス』とユーザー・アカウントは導入時に作成されます。ユーザー操作もネットワーク管理者による操作も必要ありません。


OS

OS/2 Warp ServerにWindows NTシステム・ポリシーを格納する

OS/2 Warp Serverにシステム・ポリシーを格納するには

    1　 Windows NTワークステーションにネットワーク管理者権限を持つユーザーでログオンします。

    2　 システム・ポリシー・エディターを起動します。『システム・ポリシー・エディター』ウィンドウが表示されます。(ローカル・ワークステーションでシステム・ポリシー・エディターのPOLEDIT.EXEを実行する必要があります)

    3　 『ファイル』メニューから『レジストリを開く』(Open Registry)をクリックします。『ローカル・コンピューター』アイコンと『ローカル・ユーザー』アイコンが表示されます。

    4　 『ローカル・コンピューター』をダブルクリックします。『ローカル・コンピューター・プロパティ』ページが表示されます。

    5　 『Network』ブランチを広げます。『System Policies Update』ブランチが表示されます。

    6　 『System Policies Update』ブランチを広げます。『リモート・アップデート』(Remote Update)チェックボックスが表示されます。

    7　 『リモート・アップデート』(Remote Update)チェックボックスを選択します。『Remote Updateの設定』が表示されます。

    8　 『アップデート・モード』(Update Mode)ドロップ・リストから、『手動』(Manual)をクリックします。

    9　 『手動アップデートのパス』(Path for Manual Update)欄にUNCパスとファイル名を入力します。
        例：
          \\WarpServer\Netlogon\NTConfig.pol

        詳細：
          WarpServer　サーバー名。
          Netlogon 　　NETLOGON共有ディレクトリー。
          NTConfig.pol　 ログオン中にロードするシステム・ポリシー名。

    10 『OK』をクリックします。

    11 『ファイル』メニューから『保管』(Save)をクリックします。

    12 『システム・ポリシー・エディター』ウィンドウを終了します。

注：ログオン・サーバーを複数使用する場合には、それぞれのサーバーにシステム・ポリシー・ファイルが必要になります。


OS

OS/2 Warp ServerにWindows NTのユーザー・プロファイルを格納する

OS/2 Warp Serverへログオン
IBM Networks Primary Logon Clientは、Microsoft Windows NTのユーザー・プロファイルを、現在使用中のOS/2 Warp Server 用に定義された\PROFILESサブディレクトリー下のホーム・ディレクトリーにロード及び保管します。ホーム・ディレクトリーが定義されていない、もしくは、ホーム・ディレクトリーにアクセスができない場合には、ユーザー・プロファイルはローカル・ワークステーションにロード及び保管されます。

\PROFILESサブディレクトリーやデフォルトのローカル・ワークステーション以外のパスを定義する必要がある場合には、Windows NTの『ユーザー管理』ツールを使用して、任意のパスを定義することができます。そうすることで、、そのワークステーション上のローミングやローカル・プロファイルをオーバーライドします。

メモ：ユーザー・プロファイルはFATパーティションではサポートされていません。

Windows NTへログオン
    1 　ネットワーク管理者権限を持っているユーザーとしてWindows NTやドメイン・サーバーにログオンします。

    2　 ログオン先によってユーザー管理もしくはドメインのユーザー管理のいずれかを起動します。

    3　 プロファイル・ロケーションを変更したいユーザーをダブルクリックします。そのユーザーの『プロパティ』ページが表示されます。

    4　 『プロファイル』をクリックします。『ユーザー環境プロファイル』ウィンドウが起動します。
    5　 『プロファイル パス』欄にUNCパスとファイル名を入力します。
      例：
        \\WarpServer\ShareName\ProfileDir

      詳細：
        WarpServer サーバー名。
        ShareName 共有名。
        ProfileDir ログオン中にロードし、ログオフ時に保管するユーザー・プロファイルのロケーション。

    6　 『OK』をクリック。
    7　 『ユーザー・プロファイル』ページにて『OK』をクリック。
    8　 ユーザー管理プログラムを終了する。


OS

OS/2 Warp Server以外のSMBベース・サーバーの使用

IBM Networks Logon Clientを利用すると、OS/2 Warp Server、IBM LANサーバー、及び、ほぼすべてのSMBベースのサーバー・ドメインに対して１次認証を行うことができます。OS/2 Warp用のオンライン文書内の全リファレンスはSMBサーバー製品でも使用することができます。


WDLS コマンド ラインパラメータ

以下のコマンド ラインパラメータで，グラフィカルユーザーインターフェース (GUI)を表示する方法を制御します。たとえば，IBM Networks Client GUI が開始されたときに，すぐに『ドライブ接続』ウィンドウが表示されるようにするには，コマンド ラインで以下を入力してください。

WDLS 5

パラメータ 機能

    3　：　 『共用アプリケーション』ウィンドウを表示します。
    4　：　 『ユーザーコメントの変更』ウィンドウを表示します。
    5　：　 ドライブ接続を管理します。
    6　：　 プリンタ接続を管理します。
    9　：　 『メッセージの送信』ウィンドウを表示します。


Windows NTユーザー

Windows NTユーザー・プロファイルのロード

IBM Networks Primary Logon Clientは、Microsoft Windows NTのユーザー・プロファイルを、現在使用中のOS/2 Warp Server 用に定義された\PROFILESサブディレクトリー下のホーム・ディレクトリーにロード及び保管します。ホーム・ディレクトリーが定義されていない、もしくは、ホーム・ディレクトリーにアクセスができない場合には、ユーザー・プロファイルはローカル・ワークステーションにロード及び保管されます。

\PROFILESサブディレクトリーやデフォルトのローカル・ワークステーション以外のパスを定義する必要がある場合には、Windows NTの『ユーザー管理』ツールを使用して、任意のパスを定義することができます。そうすることで、、そのワークステーション上のローミングやローカル・プロファイルをオーバーライドします。

メモ：ユーザー・プロファイルはFATパーティションではサポートされていません。


Windows プログラムグループへの共用アプリケーションの追加

Warp Serverドメインにログオンしている場合は，共用アプリケーションをワークステーションのWindows プログラムグループに追加できます。

Warp Server アプリケーションをWindows プログラムグループに追加するには

    1　 メニューバーで『アプリケーション』をクリックしてから，『共用アプリケーション』をクリックします。『共用アプリケーションのインストール』ウィンドウが表示されます。
    2　 『LAN アプリケーション』リストから，追加したいアプリケーションを選択します。(複数選択も可能です。)

    3　 以下のいずれかを行います。

      プログラムグループがリストされている場合は，アプリケーションを追加したいプログラムグループを選択してください。

      プログラムグループがリストされていない場合は，次のようにします。

        a 『作成』をクリックします。『プログラムグループ特性』ウィンドウが表示されます。
        b 『説明』ボックスに，作成したいグループのタイトルをタイプします。
        c 『OK』をクリックします。

        注:LAN アプリケーションをプログラムグループに追加するときは，1 回に1 つのプログラムしか選択できません。LAN アプリケーションを複数のプログラムグループに追加するには，それぞれのプログラムグループに個別に追加する必要があります。

    4　 『共用アプリケーションのインストール』ウィンドウで『追加』をクリックします。

    5　 『閉じる』をクリックしてこのウィンドウを終了します。

共用アプリケーションを追加すると，それぞれのアプリケーションについてアプリケーションアイコンが作成され，選択したプログラムグループにそのアイコンが追加されます。

共用アプリケーションの実行に問題がある場合は，
ネットワーク管理者に連絡してください。


エラー時のゲスト

エラー時のゲスト・アカウント・ログの修正

OS/2 Warp Server のゲスト・アカウントへのログオン時にパスワードが必要であれば、IBM Networks Primary Logon Client を導入した各Microsoft Windows NTクライアント機にて以下の設定を行う必要があります。

エラー時のゲスト・アカウント・ログの修正するには、

    1　 Windows NTコンピューターのREGEDT32ツールを使ってPassword change interval key を0に変更します。
        (PasswordChangeIntervalは、HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\SERVICES\IBMNETNT\PARAMETERS\PASSWORDCHANGEINTERVALで設定できます)
        この値を0にすると、IBMGINAサービスが定期的にパスワードを無作為化しなくなります。

    2　 『スタート』ボタンをクリックして『設定』を選択し、次に『コントロールパネル』をクリックします。『コントロールパネル』が表示されます。

    3　 『サービス』（Windows2000の場合は『管理ツール』から『サービス』）をダブルクリックします。

    4　 サービス・リストからIBM Networks Primary Logon Clientを選択し『スタートアップ』をクリックします。『サービス』ウィンドウが表示されます。(Windows2000の場合はIBM Networks Primary Logon Clientを選択して『操作』の『プロパティー』をクリックするとIBM Networks Primary Logon Clientのプロパティー・ノートブックが表示されます。ここでログオン・タブをクリックしてください。)

    5　 『パスワード』と『パスワードの確認入力』欄にゲスト・アカウントが使用する任意のパスワードを入力し、『OK』をクリックします。

    6　 『サービス』と『コントロールパネル』ウィンドウを閉じます。

    7　 『スタート』ボタンをクリックして『プログラム』を選び、『管理ツール』の『ユーザー管理』をクリックします。『ユーザー管理』ウィンドウが表示されます。(Windows2000の場合は、『コントロールパネル』の『ユーザーとパスワード』をクリックしてください『ユーザーとパスワード』ウィンドウが表示されます。)

    8　 ユーザー名のリスト上の『IBMGina』をダブルクリックしてください。『ユーザー・プロパティー』ウィンドウが表示されます。(Windows2000の場合は『IBMGina』を選択して『パスワードの設定』ボタンをクリックしてください。)

    9　 『新しいパスワード』と『新しいパスワードの確認入力』欄にステップ4の『サービス』ウィンドウにて入力したパスワードをタイプして、『OK』をクリックしてください。『サービス』ウィンドウが表示されます。(Windows2000では表示されません。ステップ2,3,4の手順で『サービス』ウィンドウを起動します)

    10 『停止』をクリックし、「サービスを停止しますか」というメッセージに対して『OK』をクリックします。『サービス』ウィンドウが表示されます。

    11 『開始』をクリックします。『ユーザー管理』ウィンドウが表示されます。
    12 『ユーザー管理』ウィンドウを閉じます。


コマンド ラインインターフェース

IBM Networks ClientコマンドはMicrosoft NET コマンドを補います。以下のNET コマンドは，IBM Networks Client コマンド ラインインターフェースを使用してサポートされます。

コマンド 　　　説明

NET ADMIN 　　ワークステーションから，サーバー上でコマンドを実行するかまたはコマンド プロセッサを開始します。このコマンドを使用するには，サーバーの管理権限が必要です。
NET ALIAS 　　指定されたドメインの別名リスト，または特定の別名の情報を表示します。
NET DASD　　　リモート HPFS386 論理ドライブで使用可能な最大ディスク スペースのディレクトリ制限を表示します。
NET HELP　　　コマンドおよびエラーメッセージに関する情報を提供します。
NET SEND　　　メッセージをローカルエリア ネットワークの別のコンピュータ，または別のユーザーに送信します。
NET USE　　　共用リソースへの接続または共用リソースからの切断を行うか，または接続に関する情報を表示します。
NET WHO　　　ドメインまたはサーバーにログオンしているユーザー名をリストし，個々のユーザーに関する情報を表示します。

注：
    1　 IBM Networks Client導入プログラムは、Microsoft社のNET.EXEの名前をNETNT.EXEに変換しますが、NETコマンドを発行する手順は変わりません。
    2　 Windows NTは著しく長いコマンドを正常に実行できません。例えば、以下のように長いストリングのコマンドを入力しても、正常に実行されません。

          net admin \\deptsrv /c net app myapp /appdir:pubapps\appsdir /appdrive:* /command:app.exe /remark:"My App・/type:dos /wrkdir:pubapps\appsdir /wrkdrive:* /add

        コマンドを正常に実行するには、これを２つのコマンドに再構成する必要があります。１つ目のコマンドが、定義名を作成し，ロケーションを指定し、アプリケーションにドライブ名を割り当てて、実行可能なアプリケーションをその定義に関連付け、割り当てに注釈を加えて、プログラムの種類を定義してから割り当てを追加します。

          net admin \\deptsrv /c net myapp /appdir:pubapps\appsdir /appdrive:* /com:app.exe /rem:"My App" /t:dos /add

        ２つ目のコマンドは、作業ディレクトリーとその作業ディレクトリーに対するドライブ名を割り当てます。


ディレクトリ制限のチェック

ディレクトリのディレクトリ制限は，ディレクトリに接続している場合にのみ表示することができます。ネットワーク管理者にはディレクトリ制限を設定する責任があります。

ディレクトリ制限をチェックするには

    1　 メニューバーの『ドライブ』(Drives)をクリックして，次に『ディレクトリ制限』(Directory limits)をクリックします。 (このメニューはログオンしているときだけ使用できます。)『ディレクトリ制限のチェック』ウィンドウが表示されます。
    2　 以下のいずれかを行います。

      ・ネットワーク ディレクトリのパスを，『ネットワーク ディレクトリパス』欄に入力します。
      ・『ネットワーク ドライブとディレクトリ』リストで，ネットワーク ドライブとディレクトリを選択します。

    3　 『制限のチェック』をクリックします。『ディレクトリ制限情報』ウィンドウが表示されます。
    4　 情報を表示します。
    5　 『閉じる』をクリックします。


デフォルト ログオン ドメインの変更

デフォルト ログオン ドメインを変更するには

    1　 『スタート』ボタンをクリックして『設定』を選択し，次に『コントロールパネル』をクリックします。『コントロールパネル』が表示されます。
    2　 『ネットワーク』（Windows2000の場合は『ネットワークとダイヤルアップ接続』）をダブルクリックします。
        『ネットワーク』ノートブックが表示されます。(Windows2000の場合は有効な『ローカルエリア接続』のプロパティーを開いてください。)
    3　 『サービス』タブ（Windows2000の場合は『全般』タブ）を選びます。

    4　 『現在のネットワーク構成』のリストで，IBM Networks Client をクリックして，次に『プロパティ』をクリックします。『IBM Network Client のプロパティ』ウィンドウが表示されます。

    5　 『General』タブをクリックします。
    6　 『Domain/Cell name』欄にて以下のいずれかを行います。
      ・下矢印をクリックしてドメインのリストを表示し、該当するドメイン名を１つ選択します。
      ・デフォルト ログオン ドメイン名をタイプします。例：OS/2 Warp Server名、DCEセル名、Windows NTドメイン名など。
    7　 『OK』をクリックします。
    8　 『ネットワーク』ノートブックの『OK』をクリックします。


どのIBM Networks Clientが導入されているか判別 どのIBM Networks Clientが導入されているかを確認するには

どのIBM Networks Clientが導入されているか判別

どのIBM Networks Clientが導入されているかを確認するには、
    1　 『スタート』ボタンをクリックして『設定』を選択し、次に『コントロールパネル』をクリックします。『コントロールパネル』が表示されます。
    2　 『ネットワーク』（Windows2000の場合は『ネットワークとダイヤルアップ接続』）をダブルクリックします。
        『ネットワーク』ノートブックが表示されます。(Windows2000の場合は有効な『ローカルエリア接続』のプロパティーを開いてください。)
    3　 『サービス』タブ（Windows2000の場合は『全般』タブ）を選びます。
    4　 『現在のネットワーク構成』のリスト上に、最近導入されたネットワーク・サービスが表示されます。


ドメイン

ドメイン・リスト省略エラーの回避

ネットワーク上にたくさんのドメインやワークグループがある場合、ドメイン・リストが途切れて表示されてしまうことがあります。レジストリーでのパフォーマンスの障害を発生させないために、IBM Networks Primary Logon Clientはドメイン・リスト上に格納するデータ量を制限しています。デフォルトのキャッシュの上限は1000文字ですが、この値をカスタマイズすることも可能です。

ドメイン・キャッシュ上限のカスタマイズ
    1　 Windows NT上のREGEDT32ツールを使います。(キャッシュの制限は、
        HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\SERVICES\IBMNETNT\PARAMETERS\DCACHELIMITで設定できます)
    2　 システムに格納したい文字数の上限値をレジストリに書き込みます。
    3　 変更を保管し、REGEDT32ツールを終了します。
    4　 システムを再起動します。


ネットワーク上におけるOS

ネットワーク上におけるOS/2 Warp Serverのドメインの検索

Windows NTワークステーションでは、有効なドメインのリストをブラウザーで判別できます。OS/2 Warp Serverドメインは以下のいずれかの状況で検出されます。

  ・ドメイン上のIBM Warp Serverが、インターネット(http://www.software.ibm.com/os/warp-server)からダウンロードしたIBM Neighborhood Browser Enabler for OS/2 Warp Serverを実行している。

  ・ドメイン名と同名のワークグループにて、Windows NTワークステーションが実行中である。

  ・ドメイン名と同名のワークグループにて、Windows 95コンピューターが実行中で、ブラウズ・マスターとして構成されている。

リスト上にOS/2 Warp Serverのドメインが検出されない場合は、ドメイン名を直接入力してください。


メッセージの送信

メッセージを送信するには

    1　 メニューバーで『メッセージ』(Messages)をクリックしてから，『メッセージの送信』(Send message)をクリックします。
    2　 『宛先』ボックスで，以下のいずれかを行います。

ユーザーID

ユーザーIDまたはマシンIDがわかっている場合は，『ユーザーID』をクリックして，『ユーザーID』欄にユーザーID とマシンID をタイプします。
ユーザーID またはワークステーションがわからない場合は，『探索』をクリックします。『ログオンユーザーのリスト』ウィンドウが表示されます。

  a メッセージを送りたい人のユーザーID を選択します。

  b 『メッセージの送信』をクリックします。『メッセージの送信』ウィンドウが表示されます。

ドメイン

メッセージを，ドメインにあるすべてのワークステーションに送信したい場合は，『ドメイン』をクリックします。次に下矢印をクリックしてドメインのリストを表示し，そのうちの1 つを選択します。

    3　 『メッセージ』欄にメッセージをタイプします。
    4　 『送信』をクリックします。
    5　 『キャンセル』をクリックして，メインウィンドウに戻ります。


ユーザー

ユーザー・パスワードの変更

ユーザー・パスワードを変更するには
    1　 Microsoft Windows NT(Windows2000)ワークステーションにログオンしているのであれば、CTRL+ALT+DELを押します。『Windows NTセキュリティー』ウインドウが表示されます。
    2　 『パスワードの変更』ボタンをクリックします。『パスワードの変更』ウインドウが表示されます。
    3　 『古いパスワード』欄に現在のパスワードをタイプします。
    4　 『新しいパスワード』欄に新しいパスワードをタイプします。
    5　 『新しいパスワードの確認』欄に新しいパスワードをもう一度タイプします。
    6　 『OK』をクリックします。パスワードが変更されたことを確認するメッセージが表示されます。

注：『パスワードの変更』ウインドウから、そのドメイン上の他ユーザーのパスワードと他のドメイン上のユーザーのパスワードを変更することもできます。そのドメイン上の他ユーザーのパスワードを変えるには、ユーザー名をタイプしてください。他のドメイン上のユーザーのパスワードを変えるには、ドメイン名をリストから選択してください。


ユーザーコメントの変更

ユーザーコメントはドメイン上のユーザーIDに関連する記述です。ユーザーID のユーザー記述は，いくつかのネットワーク機能で表示されます。

ユーザー記述を変更するには

    1　 メニューバーで『ユーザー』(Users)をクリックしてから，『ユーザーコメントの変更』(Change user comments)をクリックします。
        『ユーザーコメントの変更』ウィンドウが表示されます。
    2　 『説明』ボックスに新しいユーザー記述をタイプします。

    3　 『OK』をクリックします。


ユーザーのニーズに応じたIBM Networks Clientsの判別 IBM Networksがコーディネートするログオン

ユーザーのニーズに応じたIBM Networks Clientsの判別

IBM Networksがコーディネートするログオン・クライアントはOS/2 Warp Server用のWindows NTネットワーク・プロバイダーです。ネットワーク・プロバイダーはユーザーが各自のWindows NTアカウントにログオンした後で、２次認証を行います。これにより、ユーザーはWarp Serverホーム・ディレクトリーの使用、ログオン割り当て、ネットワーク・アプリケーション、及び、ログオン・スクリプトの実行を行うことができるようになります。コーディネートされたログオン・クライアントはWindows NTとOS/2 Warp Serverのユーザー・アカウント間のパスワードを保守します。

IBM Networksログオン・クライアントはWarpServerのようなWindows NT以外のロケーションへの１次認証を可能にします。従って、WarpServerとその他の認証でのプロバイダーのユーザー・アカウントを分けて使うことにより、２つのユーザー・アカウントを別々に保守する必要がなくなります。


ログオン

ログオンすることで，ユーザーはローカルエリア ネットワークに対して識別され，ワークステーションのユーザーとして確立します。IBM Networks Logon Clientを利用すると、
  ・ネットワークのログオン可能なサーバーを検出できます。
  ・ローカル・ワークステーションにログオンできます。
  ・特定のドメインにログオンできます。

ログオンするには
    1　 Microsoft Windows NT起動画面で、CTRL+ALT+DELを押します。『ログオン情報』ウィンドウが表示されます。
    2　 『ユーザー名』欄に，ログオンに使用したいユーザーID をタイプします。

    3　 『パスワード』欄に，ネットワーク・パスワードをタイプします。

    4　 『ドメイン』欄で，以下のいずれかを行います。

  ・下矢印を選択してドメインのリストを表示してから，そのうちの1 つを選択します。リストが空の場合、もしくは該当するドメイン名がリスト上にない場合には、『探索』ボタンをクリックしてネットワーク上の有効なドメインを検出してください。リストが更新され、検出したすべてのWindows NT及びOS/2 Warp Serverドメインが表示されます。

  ・ログオンしたいドメインの名前をタイプしてください。

    5　 『OK』をクリックすると、IBM Networks Clientログオンの検証作業が開始されます。


ログオン

ログオン・ウィンドウのカスタマイズ

ネットワーク管理者は、以下の手順に従いログオン･ウィンドウのカスタマイズを行うことができます。

  ・ユーザーに見せたいドメインだけを、ドメイン／セル・ネーム・ボックスが表示するように調整します。
  ・ドメイン／セル・ネーム・ボックスにユーザーが情報を直接タイプできるようにします。
  ・ネットワークがユーザーのログオンできるサーバーを検索できるようにします。

ログオン・ウィンドウのカスタマイズ方法
    1　 『スタート』ボタンをクリックして『設定』を選択し、次に『コントロールパネル』をクリックします。『コントロールパネル』が表示されます。
    2　 『ネットワーク』（Windows2000の場合は『ネットワークとダイヤルアップ接続』）をダブルクリックします。
        『ネットワーク』ノートブックが表示されます。(Windows2000の場合は有効な『ローカルエリア接続』のプロパティーを開いてください。)
    3　 『サービス』タブ（Windows2000の場合は『全般』タブ）を選びます。
    4　 『現在のネットワーク構成』のリストで、IBM Networks Primary Logon Clientを選んで、『プロパティー』ボタンをクリックします。
        『IBM Networks Clientのプロパティー』ウィンドウが表示されます。
    5　 『Advanced』タブを選びます。『Advanced』ページが開き、ネットワーク上のすべてのドメインの一覧が表示されます。
    6　 『Domain/Cell name』ボックスにて、次のいずれかを行います。
   ・スクロールしてドメイン名のリストからドメインを選択する。
   ・直接ドメイン名をタイプする。
    7　 ユーザー・ログオン時にドメイン／セル・ネーム・リスト上で特定のドメインを非表示にするには、
        『Display at logon』リスト上からそのドメイン名を選んで『Remove』ボタンを押します。
    8　 ユーザー・ログオン時に『検索』ボタンを使用不可にするには、『Enable domain name searching check box in the Logon window』チェックボックスのチェックを外します。
    9　 ユーザー・ログオン時にドメイン名を直接タイプできなくするには、『Enable domain name entry check box in the Logon window』チェックボックスのチェックを外します。
    10 『OK』ボタンをクリックします。


ログオンユーザーの確認

ネットワークに誰がログオンしているかを確かめることができます。これを行う1 つの理由は，メッセージの送信前にユーザーがログオンしているかどうかを確認するためです。
ログオンユーザーを確認するには

    1　 メニューバーで『ユーザー』をクリックしてから，『ログオンユーザーのリスト』をクリックします。『ログオンユーザーのリスト』ウィンドウが表示されます。

    2　 ログオンユーザーのリストを表示します。
    3　 『閉じる』をクリックします。


ログオン時ドライブ割当ての変更

ログオン時ドライブ割当てを追加するには

    1　 メニューバーの『ドライブ』(Drives)をクリックして，次に『ログオン時割当て』(Logon assignments)をクリックします。『ログオン時ドライブ割当ての変更』ウィンドウが表示されます。

    2　 『ドライブ』リストのデバイスをクリックします。ログオン時割当てに使用できるドライブのすべてがリストされます。すでに使用されているドライブはリストされません。次の使用可能なドライブを割り当てるには，アスタリスク (*)を選択します。
    3　 別名をリストから選択します。そのドメインで使用できるすべてのディレクトリの別名がリストされます。別名がリストされていない場合は，以下が原因と考えられます。

          アクセス権がない。
          今は使用できない。
          ドメインが異なっている。
          DOS Peer リソースである。

        使用できない理由については，ディレクトリの所有者に問い合わせてください。

    4　 『追加』をクリックします。
    5　 『OK』をクリックします。

ログオン時ドライブ割当てを削除するには

    1　 メニューバーの『ドライブ』(Drives)をクリックして，次に『ログオン時割当て』(Logon assignments)をクリックします。『ログオン時ドライブ割当ての変更』ウィンドウが表示されます。
    2　 『このユーザーID のログオン時ドライブ割当て』リストで，削除するログオン時ドライブ割当てをクリックします。

    3　 『削除』をクリックします。

    4　 『OK』をクリックします。


ログオン時プリンタ割当ての変更

ログオン時プリンタ割当てを追加するには

    1　 メニューバーの『プリンタ』(Printers)をクリックして，次に『ログオン時割当て』(Logon assignments)をクリックします。『ログオン時プリンタ割当ての変更』ウィンドウが表示されます。
    2　 『デバイス』リストのデバイスをクリックします。ログオン時割当てに使用できるデバイス (プリンタポート)のすべてがリストされます。現在使用されているデバイスはリストされません。
    3　 『別名』リストの別名をクリックします。ドメインで使用できる，プリンタ別名のすべてがリストされます。別名がリストされていない場合は，以下が原因と考えられます。

          アクセス権がない。
          今は使用できない。
          ドメインが異なっている。
          DOS Peer リソースである。

        使用できない理由については，プリンタの所有者に問い合わせてください。

    4　 『追加』をクリックします。
    5　 『OK』をクリックします。

ログオン時プリンタ割当てを削除するには

    1　 メニューバーの『プリンタ』(Printers)をクリックして，次に『ログオン時割当て』(Logon Assignments)をクリックします。『ログオン時プリンタ割当ての変更』ウィンドウが表示されます。
    2　 『このユーザーID のログオン時プリンタ割当て』リストで，削除するログオン時プリンタ割当てをクリックします。

    3　 『削除』をクリックします。

    4　 『OK』をクリックします。


共用アプリケーションの実行

Warp Serverドメインで定義された共用アプリケーションを実行する方法は2つあります。

IBM Networks Client から共用アプリケーションを実行するには

    1　 メニューバーで『アプリケーション』(Applications)をクリックしてから，『共用アプリケーション』(Shared applications)をクリックします。(このオプションは，現在ログオンしている場合にのみ使用できます。)『共用アプリケーションのインストール』ウィンドウが表示されます。
    2　 『LAN アプリケーション』リストで，実行したいアプリケーションをダブルクリックします。

Windows NT から共用アプリケーションを実行するには

    1　 『スタート』ボタンをクリックし，『プログラム』を選択してから，共用アプリケーションを含む『プログラムグループ』をクリックします。
    2　 共用アプリケーションの名前をクリックします。


共用ディレクトリからの切断

共用ディレクトリから切断するには

    1　 メニューバーで『ドライブ』(Drives)をクリックしてから，『接続』(Connections)をクリックします。 (このメニューは，ログオンしている場合にのみ使用できます。)『ドライブ接続』ウィンドウが表示されます。

    2　 『このユーザーID のドライブ接続』リストで，切断したいドライブ接続をクリックします。

    3　 『切断』をクリックします。

共用ディレクトリの詳細については，『DOS LAN Services and Windows Users Guide』および
『Microsoft Windows NT Users Guide』(または『Microsoft Windows 2000 Users Guide』)を参照してください。


共用ディレクトリへの接続

共用ディレクトリに接続するには

    1　 メニューバーで『ドライブ』(Drives)をクリックしてから，『接続』(Connections)をクリックします。(このメニューは，ログオンしている場合にのみ使用できます。)『ドライブ接続』ウィンドウが表示されます。
    2　 『ドライブ』欄で，下矢印をクリックして使用可能なドライブのリストを表示してから，そのうちの1 つを選択します。デフォルト ドライブは，次に使用可能な論理ドライブです。
    3　 『ネットワーク パス』欄に，接続したいディレクトリの別名またはネットワーク パスをタイプします。ディレクトリの別名またはネットワーク パスがわからない場合は，ステップ 4 から6 を行ってください。別名またはネットワーク パスがわかっている場合は，ステップ 9 にスキップしてください。

    4　 『探索』をクリックします。『共用ディレクトリ』(Shared Directory )ウィンドウが表示され，使用可能なサーバーおよび共用ディレクトリがリストされます。
    5　 以下のいずれかの方法を使用して，接続したい共用ディレクトリを指定します。『探索』オプションを構成して，別名またはネット名を表示できます。

      方法1:『探索』オプションを使用する

        a 『探索』をクリックします。『共用ディレクトリ』ウィンドウが表示され，使用可能なサーバーおよび別名がリストされます。

        b 適用可能であれば，ネットワーク サーバーリストから使用したいサーバーをクリックします。

        c 『使用可能なリソース リスト』で，使用したい共用ディレクトリをクリックします。
        d ステップ 6 に進みます。

      方法2:別名を使用する

        a 『ネットワーク パス』欄に，共用ディレクトリの別名をタイプします。
        b ステップ 6 に進みます。

      方法3:ネットワーク パスを使用する
        ディレクトリが，IBM Networks Client を実行するワークステーションで共用される場合は，この方法を使用します。

        a 『ネットワーク パス』欄に，ディレクトリのネットワーク パス (\\servername\netname)をタイプします。ネット名は共用ディレクトリの管理者によって割り当てられます。

        b ステップ 6 に進みます。

      注: 一度に複数のディレクトリに接続できます。

    6　 『OK』をクリックします。

    7　 選択したディレクトリに接続するためにパスワードが必要な場合は，『パスワード』欄にタイプします。

    8　 『接続』をクリックします。選択したディレクトリが，『このユーザーID のドライブ接続』リストに追加されます。

    9　 『閉じる』をクリックします。


共用プリンタからの切断

通常は，印刷ジョブの送信後にプリンタからの切断を行う必要はありません。切断してもプリンタ待ち行列で待機中のジョブは取り消されません。

共用プリンタから切断するには

    1　 メニューバーで『プリンタ』(Printers)をクリックしてから，『接続』(Connections)をクリックします。『プリンタ接続』ウィンドウが表示されます。
    2　 『このユーザーID のプリンタ接続』リストで，切断したいプリンタをクリックします。

    3　 『切断』をクリックします。プリンタがリストから除去されます。

    4　 『閉じる』をクリックします。

共用プリンタの詳細については，『DOS LAN Services and Windows Users Guide』および『Microsoft Windows NT Users Guide』または『Microsoft Windows 2000 Users Guide』を参照してください。


共用プリンタへの接続

共用プリンタに接続するには

    1　 メニューバーで『プリンタ』(Printers)をクリックしてから，『接続』(Connections)をクリックします。『プリンタ接続』ウィンドウが表示されます。
    2　 『デバイス』欄で，下矢印をクリックして使用可能なポートのリストを表示し，そのうちの1 つを選択します。デフォルトは次に使用可能なポートです。3 以下のいずれかの方法を使用して，接続したい共用プリンタを指定します。『探索』オプションを構成して，別名またはネット名を表示できます。

      方法1:『探索』オプションを使用する

        a 『探索』をクリックします。『共用プリンタ』ウィンドウが表示され，使用可能なサーバーおよび共用プリンタがリストされます。
        b 適用可能な場合は，ネットワーク サーバーリストから使用したいサーバーをクリックします。
        c 『使用可能なリソース』(Available Resources)リストで，使用したい共用プリンタをクリックします。
        d 『OK』をクリックします。
        e ステップ 4 に進みます。

      方法2:別名を使用する

        a 『ネットワーク パス』欄に，共用プリンタの別名をタイプします。
        b ステップ 4 に進みます。

      方法3:ネットワーク パスを使用する
        プリンタが，IBM Networks Client を実行するワークステーションから共用される場合は，この方法を使用します。

        a 『ネットワーク パス』欄に，プリンタのネットワーク パス (
          \\servername\netname)をタイプします。ネット名は共用プリンタの管理者によって割り当てられます。

        b ステップ 4 に進みます。

    4　 『パスワード』欄にパスワードをタイプして，プリンタにアクセスします(必要な場合)。

    5　 『接続』をクリックします。選択したプリンタが，『このユーザーID のプリンタ接続』リストに追加されます。

    6　 『閉じる』をクリックします。

注:
共用プリンタへの接続に問題がある場合は，ネットワーク管理者に援助を依頼してください。

共用プリンタの詳細については，『DOS LAN Services and Windows Users Guide 』および『Microsoft Windows NT Users Guide 』(または『Microsoft Windows 2000 Users Guide』)を参照してください。


共用リソースへの接続

ネットワークがどのように構成されているかによって，
共用リソースへの接続時に別のパスワードを指定する必要があるかもしれません。たとえば，別のドメイン上のサーバーにある共用リソースへの接続を試みていて，新しいドメイン上のユーザーID のパスワードが現在ログオンしているパスワードとは異なっている場合は，そのパスワードを指定する必要があります。

他のドメインのサーバー上の共用リソースおよびピア ワークステーションへの接続に関する詳細については，ネットワーク管理者に連絡してください。


新しいプログラムグループの作成

新しいプログラムグループを作成するには

    1　 メニューバーで『アプリケーション』(Applications)をクリックしてから，『共用アプリケーション』(Shared applications)をクリックします。(このオプションは，現在ログオンしている場合にのみ使用できます。)『共用アプリケーションのインストール』ウィンドウが表示されます。

    2　 『作成』をクリックします。『プログラムグループ特性』ウィンドウが表示されます。

    3　 『説明』欄に，新たに作成したいプログラムグループのタイトルをタイプします。

    4　 『OK』をクリックします。


動的ローカル

動的ローカル・アカウントの管理

動的ローカル・アカウントとは、ユーザーがWindows NT以外のロケーションにログオンした時に、ローカルのWindows NTワークステーションに作成されるユーザー・アカウントです。ローカル・アカウントは、そのユーザーがリモート・ログオン・サーバーにて正常に認証されてから作成されます。このアカウントは、そのユーザーにローカル・ワークステーションにおける有効なセキュリティの証明を与えます。

ログオフ・ポリシーを利用することにより、IBM Networks Primary Logon Clientが提供する以下の３つの手段のいずれかを使って動的に作成されたローカル・アカウントを管理できるようになります。

  ・ユーザーがログオフした時にアカウントを削除する方法。この方法は最も安全ですが、グループのメンバーシップに対応したローカルのリソースにしかアクセスが許されません。これは導入後にデフォルトで選択されています。
  ・ユーザーがログオフした時にアカウントを無効にする方法。ログオンがより速く行え、ローカル・リソースへのすべてのアクセス制御が可能になります。このアカウントではネットワーク　・ログオンしかできません。
  ・ユーザーがログオフした後もアカウントを保持する方法。最も速くログオンできる方法です。上記の機能に加え、ローカル・ログオンも可能になります。

ログオフ・ポリシーの設定
    1　 Windows NTコンピューターのREGEDT32ツールを使うとログオフ・ポリシーの設定を行うことができます。(ログオフ・ポリシーは、HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\SERVICES\IBMNETNT\LOGOFFPOLICY\DELETEUSERで設定できます)

    2　 以下の値のいずれかを設定してください。

        0　：　 アカウントを保持する
        1　：　 アカウントを削除する
        2　：　 アカウントを無効にする
        3　：　 変更を保存し、REGEDT32ツールを終了します。


別名またはネットワーク パスを使用する共用リソースへの接続

IBM Networks Clientを使用すると，ローカルエリア ネットワークにある共用ディレクトリと共用プリンタを使用できます。これらの共用ディレクトリおよび共用プリンタは，共用リソースと呼ばれます。
ネットワーク管理者は，別名およびネット名を作成します。サーバー名とネット名の組合せはネットワーク パスと呼ばれます。以下は，別名またはネット名を持つ共用リソースへの接続方法の例です。

別名を使用して接続するには

    1　 ネットワーク管理者が，サーバーAPPSERVにあるC:\NETWORK\APPSディレクトリを参照するためにAPPSDIRという別名を作成します。

    2　 C:\NETWORK\APPSディレクトリを使用したいときは，

APPSDIR と指定することができます。

注:別名は，ドメインコントローラが停止および再始動された後もドメインに定義されたままです。別名を使用して接続するときは，サーバー名を指定する必要はありません。

ネットワーク パスを使用して接続するには

    1　 ネットワーク管理者が，サーバーACCOUNTINGにあるC:\ACCOUNT\RECEIPTディレクトリのネット名RECEIPTSを作成します。

    2　 C:\ACCOUNT\RECEIPTディレクトリを使用したいときは，
          \\ACCOUNTING\RECEIPTS と指定して参照できます。

        ここでは，ACCOUNTINGがサーバーの名前でRECEIPTSがネット名です。

注:別名とは異なり，サーバーが停止および再始動されるとネット名の定義は残りません。ネット名を使用して接続するときは，つねにサーバー名を指定しなければなりません。


IBM Networks Client Windows NT及びWindows2000 ユーザーによるネットワーク上の共用ネットワーク リソースへのアクセスを可能にするソフトウェア コンポーネント

Help単語帳

IBM Networks Client
Windows NT及びWindows2000 ユーザーによるネットワーク上の共用ネットワーク リソースへのアクセスを可能にするソフトウェア コンポーネント

OS/2 Warp Server
OS/2 Warp Server，OS/2 LAN リクエスター，DOS リクエスター，およびWindows リクエスターのコンポーネントを含むプログラム。
これを使用すれば，リソースをネットワーク上の他のコンピュータと共用できます。

WDLS コマンド ラインパラメータ
以下のコマンド ラインパラメータで，グラフィカルユーザーインターフェース (GUI)を表示する方法を制御します。たとえば，IBM Networks Client GUI が開始されたときに，すぐに『ドライブ接続』ウィンドウが表示されるようにするには，コマンド ラインで以下を入力してください。

  WDLS 5
  パラメータ 機能

    3 　『共用アプリケーション』ウィンドウを表示します。
    4 　『ユーザーコメントの変更』ウィンドウを表示します。
    5 　ドライブ接続を管理します。
    6　 プリンタ接続を管理します。
    9　 『メッセージの送信』ウィンドウを表示します。

キーボードを使用した複数選択
複数のアプリケーションをプログラムグループに追加するには
    1 Shift+F8 を押します。
    2 選択したいそれぞれのアプリケーションについて，
    上または下矢印キーを使用してアプリケーション上にカーソルを置きます。
    3 スペースバーを押して選択します。

サーバー(Server)

ローカルエリア ネットワーク上の，それらのディレクトリ，プリンタ，およびシリアルデバイスを使用可能にするワークステーション。ユーザーはこれら共用リソースにLAN 上のリクエスタからアクセスできます。サーバーは通常，2 つの円記号から始まるサーバー名(\\ADVSERVER など)と同じものとして扱われます。

セッション(Session)
リクエスタとサーバーの間のソフトウェア リンク。セッションは，共用リソースへの1 つ以上の接続で構成されます。『接続(Connection)』も参照してください。

ドメイン(Domain)
管理者が管理およびセキュリティの目的でグループ化した，ローカルエリア ネットワーク上のサーバー。リクエスタのユーザーはアクセス権を持つドメインにログオンできます。

ドメインコントローラ(Domain controller)
ドメインの管理，つまりサーバーとリクエスタの間の通信の調整，およびユーザーID や別名などのネットワーク リソースの管理を行うために設計された，ドメイン内のサーバー。ドメインコントローラは，ユーザーがドメインにログオンしてリソースを使用する前に実行されていなければなりません。

ネットワーク パス (Network path)
\\ADVSERVER\APPLICATIONS または\\PRINTSRV\LASER などの，リソースを明確に識別するサーバー名とネット名の組合せ。これはサーバーがADVSERVER とPRINTSRV の場合の例です。ネットワーク パスを指定するときは，サーバー名の前に2 つの円記号を入れる必要があります。この例のネット名はAPPLICATIONS とLASER です。ネットワーク パスを指定するときは，ネット名の前に1 つの円記号を入れてください。
  例:
    PRN_SERVER というサーバー上で，あるプリンタにHPLASER というネット名が付けられています。このプリンタを使用したいときは，\\PRN_SERVER\HPLASER と指定します。

ネットワーク管理者(Network administrator)
ネットワークの設計，計画，導入，構成，制御，管理，および保守を行う責任のある人。

ネット名(Netname)
ネットワーク上の共用リソースを識別するためにサーバー名とともに使用される名前。ネット名は12 文字までの長さにできます。ネット名にはよく，リソースのネットワーク パスの一部が使用されます。たとえば，PRINTSRV というサーバーにプリンタLASER が存在し，このプリンタのネット名がLASER だとします。このプリンタを使用するには，\\PRINTSRV\LASER と指定して接続します。

パスワード (Password)
共用リソースへの接続時またはワークステーションへのログオン時にユーザーが指定する文字ストリング (ログオンパスワード)。共用リソースへの接続に使用される場合，パスワードは8 文字まで使用できます。ログオン時は14 文字まで使用可能です。『ログオンパスワード (Logon Password)』も参照してください。

プリンタポート (Printer port)
プリンタを接続できる，LPT1 などの印刷デバイス。プリンタポートはネットワーク上の共用プリンタに接続できます。

プリンタ待ち行列(Printer queue)
ワークステーション上のサブミットされた印刷ジョブの番号付きリスト。スプーラはその印刷ジョブをプリンタまたはプロッタなどの，ワークステーションに接続された1 つ以上の出力デバイスに経路指定します。プリンタ待ち行列は，ネットワーク上のユーザーによって送信された印刷ジョブを管理するために，管理者またはピア ワークステーションに接続されたプリンタの所有者が共用プリンタ用に作成することができます。

マシンID (Machine ID)
ローカルエリア ネットワーク上のワークステーションの名前。マシンID はネットワーク上で固有でなければならず，15 文字までにすることができます。

ユーザーID (User ID)
ローカルエリア ネットワークのドメインに対してユーザーを固有に識別する名前。Warp Server ドメインでは，ユーザーID は8 文字より長くすることができます。

ログオンパスワード (Logon password)
リクエスタまたはサーバーへのログオン時に指定されるパスワード。ログオンパスワードには，管理者が設定した最小文字数が含まれている必要があり，14 文字まで使用できます。『パスワード (Password)』も参照してください。

ワークステーション(Workstation)
IBM Networks Client やOS/2 LAN リクエスターなどの，ユーザーがソフトウェアを通じて他のユーザーと通信できるローカルエリア ネットワーク上のコンピュータ。『リクエスタ(Requester)』も参照してください。

管理者(Administrator)
ローカルエリア ネットワークを管理する責任のある人。管理者は一般的に，ネットワークのセットアップやネットワークの共用リソースおよびセキュリティ システムの管理を助け，ユーザーアカウントを作成し，ネットワークの問題を持つユーザーを支援します。『ネットワーク管理者(Network administrator)』も参照してください。

共用アプリケーション(Shared applications)
必要なアクセス許可を持つ，このドメインにログオンしたネットワーク ユーザーが共用または使用できることをドメインで定義されたアプリケーション。ドメインで使用可能な共用アプリケーションは，LAN アプリケーションリストにリストされます。

共用ディレクトリ(Shared directory)
ローカルエリア ネットワークの管理者またはピア ワークステーションの所有者によって，他のユーザーに対して使用可能にされたディレクトリ。共用ディレクトリは，ワークステーションのディスク ドライブまたはディレクトリと同じ方法で使用されますが，実際には他のワークステーションに格納されます。共用ディレクトリに接続してドライブ名を付けると，ワークステーションでその共用ディレクトリのファイルとアプリケーションプログラムを，あたかもそれがハード ディスクに格納されているかのように使用することができます。

共用ディレクトリを使用するときは，そのリソースへのセッションまたは接続を確立します。共用ディレクトリは，別名またはネットワーク パスのどちらかによって識別されます。

共用プリンタ(Shared printer)
ローカルエリア ネットワークの管理者またはピア ワークステーションの所有者によって，他のユーザーに対して使用可能にされたプリンタ。共用プリンタは，ワークステーションに物理的に接続されたプリンタと同じ方法で使用できます。印刷ジョブはワークステーションのアプリケーションからサーバーのプリンタ待ち行列に送信できます。プリンタ待ち行列に送信されたジョブは，通常，その待ち行列が受け取った順序で1 つずつ印刷されます。

共用プリンタは，別名またはネットワーク パスのどちらかによって識別されます。

共用リソース (Shared resource)
ローカルエリア ネットワークで使用可能なディレクトリ，プリンタ，またはシリアルデバイス。リソースを共用する人は，ネット名または別名のどちらかのフォームで名前を付けます。ユーザーはリソースを使用したいときにそのネット名または別名で共用リソースを参照します。

接続(Connection)
リクエスタと共用リソースの間のソフトフェア リンク。リクエスタのローカルデバイス名をサーバーの共用リソースに割り当てることによって，接続を確立できます。たとえば，サーバー上のディレクトリにあるファイルを使用したい場合は，N:などのドライブをサーバー上のディレクトリに割り当てれば，そのドライブを使用できます。これはディレクトリ接続またはドライブ接続です。サーバーに位置付けられたプリンタを使用したい場合は，LPT5 などのプリンタポートをそのプリンタに割り当てます。『セッション(Session)』も参照してください。

別名(Alias)
ネットワーク管理者によってセットアップされた，ディレクトリ，プリンタ，またはシリアルデバイスのニックネーム。ドメインコントローラが停止し再始動されても，別名はドメインに定義されたままです。別名はOS/2 Warp Server ドメインのみでサポートされます。