1 | # Makefile.in generated by automake 1.11 from Makefile.am.
|
---|
2 | # @configure_input@
|
---|
3 |
|
---|
4 | # Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
|
---|
5 | # 2003, 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation,
|
---|
6 | # Inc.
|
---|
7 | # This Makefile.in is free software; the Free Software Foundation
|
---|
8 | # gives unlimited permission to copy and/or distribute it,
|
---|
9 | # with or without modifications, as long as this notice is preserved.
|
---|
10 |
|
---|
11 | # This program is distributed in the hope that it will be useful,
|
---|
12 | # but WITHOUT ANY WARRANTY, to the extent permitted by law; without
|
---|
13 | # even the implied warranty of MERCHANTABILITY or FITNESS FOR A
|
---|
14 | # PARTICULAR PURPOSE.
|
---|
15 |
|
---|
16 | @SET_MAKE@
|
---|
17 | VPATH = @srcdir@
|
---|
18 | pkgdatadir = $(datadir)/@PACKAGE@
|
---|
19 | pkgincludedir = $(includedir)/@PACKAGE@
|
---|
20 | pkglibdir = $(libdir)/@PACKAGE@
|
---|
21 | pkglibexecdir = $(libexecdir)/@PACKAGE@
|
---|
22 | am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
|
---|
23 | install_sh_DATA = $(install_sh) -c -m 644
|
---|
24 | install_sh_PROGRAM = $(install_sh) -c
|
---|
25 | install_sh_SCRIPT = $(install_sh) -c
|
---|
26 | INSTALL_HEADER = $(INSTALL_DATA)
|
---|
27 | transform = $(program_transform_name)
|
---|
28 | NORMAL_INSTALL = :
|
---|
29 | PRE_INSTALL = :
|
---|
30 | POST_INSTALL = :
|
---|
31 | NORMAL_UNINSTALL = :
|
---|
32 | PRE_UNINSTALL = :
|
---|
33 | POST_UNINSTALL = :
|
---|
34 | build_triplet = @build@
|
---|
35 | host_triplet = @host@
|
---|
36 | subdir = tests/reports
|
---|
37 | DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
|
---|
38 | ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
---|
39 | am__aclocal_m4_deps = $(top_srcdir)/configure.in
|
---|
40 | am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
|
---|
41 | $(ACLOCAL_M4)
|
---|
42 | mkinstalldirs = $(install_sh) -d
|
---|
43 | CONFIG_HEADER = $(top_builddir)/config.h
|
---|
44 | CONFIG_CLEAN_FILES =
|
---|
45 | CONFIG_CLEAN_VPATH_FILES =
|
---|
46 | SOURCES =
|
---|
47 | DIST_SOURCES =
|
---|
48 | DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
---|
49 | ACLOCAL = @ACLOCAL@
|
---|
50 | AMTAR = @AMTAR@
|
---|
51 | AR = @AR@
|
---|
52 | AS = @AS@
|
---|
53 | AUTOCONF = @AUTOCONF@
|
---|
54 | AUTOHEADER = @AUTOHEADER@
|
---|
55 | AUTOMAKE = @AUTOMAKE@
|
---|
56 | AWK = @AWK@
|
---|
57 | CC = @CC@
|
---|
58 | CCDEPMODE = @CCDEPMODE@
|
---|
59 | CFLAGS = @CFLAGS@
|
---|
60 | CPP = @CPP@
|
---|
61 | CPPFLAGS = @CPPFLAGS@
|
---|
62 | CYGPATH_W = @CYGPATH_W@
|
---|
63 | DEFS = @DEFS@
|
---|
64 | DEPDIR = @DEPDIR@
|
---|
65 | DLLTOOL = @DLLTOOL@
|
---|
66 | DSYMUTIL = @DSYMUTIL@
|
---|
67 | DUMPBIN = @DUMPBIN@
|
---|
68 | ECHO_C = @ECHO_C@
|
---|
69 | ECHO_N = @ECHO_N@
|
---|
70 | ECHO_T = @ECHO_T@
|
---|
71 | EGREP = @EGREP@
|
---|
72 | EXEEXT = @EXEEXT@
|
---|
73 | EXSLT_INCLUDEDIR = @EXSLT_INCLUDEDIR@
|
---|
74 | EXSLT_LIBDIR = @EXSLT_LIBDIR@
|
---|
75 | EXSLT_LIBS = @EXSLT_LIBS@
|
---|
76 | EXTRA_LIBS = @EXTRA_LIBS@
|
---|
77 | FGREP = @FGREP@
|
---|
78 | GREP = @GREP@
|
---|
79 | HTML_DIR = @HTML_DIR@
|
---|
80 | INSTALL = @INSTALL@
|
---|
81 | INSTALL_DATA = @INSTALL_DATA@
|
---|
82 | INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
---|
83 | INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
---|
84 | INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
|
---|
85 | LD = @LD@
|
---|
86 | LDFLAGS = @LDFLAGS@
|
---|
87 | LIBEXSLT_MAJOR_VERSION = @LIBEXSLT_MAJOR_VERSION@
|
---|
88 | LIBEXSLT_MICRO_VERSION = @LIBEXSLT_MICRO_VERSION@
|
---|
89 | LIBEXSLT_MINOR_VERSION = @LIBEXSLT_MINOR_VERSION@
|
---|
90 | LIBEXSLT_VERSION = @LIBEXSLT_VERSION@
|
---|
91 | LIBEXSLT_VERSION_EXTRA = @LIBEXSLT_VERSION_EXTRA@
|
---|
92 | LIBEXSLT_VERSION_INFO = @LIBEXSLT_VERSION_INFO@
|
---|
93 | LIBEXSLT_VERSION_NUMBER = @LIBEXSLT_VERSION_NUMBER@
|
---|
94 | LIBGCRYPT_CFLAGS = @LIBGCRYPT_CFLAGS@
|
---|
95 | LIBGCRYPT_CONFIG = @LIBGCRYPT_CONFIG@
|
---|
96 | LIBGCRYPT_LIBS = @LIBGCRYPT_LIBS@
|
---|
97 | LIBOBJS = @LIBOBJS@
|
---|
98 | LIBS = @LIBS@
|
---|
99 | LIBTOOL = @LIBTOOL@
|
---|
100 | LIBXML_CFLAGS = @LIBXML_CFLAGS@
|
---|
101 | LIBXML_LIBS = @LIBXML_LIBS@
|
---|
102 | LIBXML_REQUIRED_VERSION = @LIBXML_REQUIRED_VERSION@
|
---|
103 | LIBXML_SRC = @LIBXML_SRC@
|
---|
104 | LIBXSLT_DEFAULT_PLUGINS_PATH = @LIBXSLT_DEFAULT_PLUGINS_PATH@
|
---|
105 | LIBXSLT_MAJOR_MINOR_VERSION = @LIBXSLT_MAJOR_MINOR_VERSION@
|
---|
106 | LIBXSLT_MAJOR_VERSION = @LIBXSLT_MAJOR_VERSION@
|
---|
107 | LIBXSLT_MICRO_VERSION = @LIBXSLT_MICRO_VERSION@
|
---|
108 | LIBXSLT_MINOR_VERSION = @LIBXSLT_MINOR_VERSION@
|
---|
109 | LIBXSLT_VERSION = @LIBXSLT_VERSION@
|
---|
110 | LIBXSLT_VERSION_EXTRA = @LIBXSLT_VERSION_EXTRA@
|
---|
111 | LIBXSLT_VERSION_INFO = @LIBXSLT_VERSION_INFO@
|
---|
112 | LIBXSLT_VERSION_NUMBER = @LIBXSLT_VERSION_NUMBER@
|
---|
113 | LIPO = @LIPO@
|
---|
114 | LN_S = @LN_S@
|
---|
115 | LTLIBOBJS = @LTLIBOBJS@
|
---|
116 | MAKEINFO = @MAKEINFO@
|
---|
117 | MKDIR_P = @MKDIR_P@
|
---|
118 | MV = @MV@
|
---|
119 | M_LIBS = @M_LIBS@
|
---|
120 | NM = @NM@
|
---|
121 | NMEDIT = @NMEDIT@
|
---|
122 | OBJDUMP = @OBJDUMP@
|
---|
123 | OBJEXT = @OBJEXT@
|
---|
124 | OTOOL = @OTOOL@
|
---|
125 | OTOOL64 = @OTOOL64@
|
---|
126 | PACKAGE = @PACKAGE@
|
---|
127 | PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
|
---|
128 | PACKAGE_NAME = @PACKAGE_NAME@
|
---|
129 | PACKAGE_STRING = @PACKAGE_STRING@
|
---|
130 | PACKAGE_TARNAME = @PACKAGE_TARNAME@
|
---|
131 | PACKAGE_VERSION = @PACKAGE_VERSION@
|
---|
132 | PATH_SEPARATOR = @PATH_SEPARATOR@
|
---|
133 | PERL = @PERL@
|
---|
134 | PYTHON = @PYTHON@
|
---|
135 | PYTHONSODV = @PYTHONSODV@
|
---|
136 | PYTHON_INCLUDES = @PYTHON_INCLUDES@
|
---|
137 | PYTHON_SITE_PACKAGES = @PYTHON_SITE_PACKAGES@
|
---|
138 | PYTHON_SUBDIR = @PYTHON_SUBDIR@
|
---|
139 | PYTHON_VERSION = @PYTHON_VERSION@
|
---|
140 | RANLIB = @RANLIB@
|
---|
141 | RELDATE = @RELDATE@
|
---|
142 | RM = @RM@
|
---|
143 | SED = @SED@
|
---|
144 | SET_MAKE = @SET_MAKE@
|
---|
145 | SHELL = @SHELL@
|
---|
146 | STATIC_BINARIES = @STATIC_BINARIES@
|
---|
147 | STRIP = @STRIP@
|
---|
148 | TAR = @TAR@
|
---|
149 | THREAD_LIBS = @THREAD_LIBS@
|
---|
150 | VERSION = @VERSION@
|
---|
151 | VERSION_SCRIPT_FLAGS = @VERSION_SCRIPT_FLAGS@
|
---|
152 | WIN32_EXTRA_LDFLAGS = @WIN32_EXTRA_LDFLAGS@
|
---|
153 | WIN32_EXTRA_LIBADD = @WIN32_EXTRA_LIBADD@
|
---|
154 | WITH_CRYPTO = @WITH_CRYPTO@
|
---|
155 | WITH_DEBUGGER = @WITH_DEBUGGER@
|
---|
156 | WITH_MEM_DEBUG = @WITH_MEM_DEBUG@
|
---|
157 | WITH_MODULES = @WITH_MODULES@
|
---|
158 | WITH_TRIO = @WITH_TRIO@
|
---|
159 | WITH_XSLT_DEBUG = @WITH_XSLT_DEBUG@
|
---|
160 | XMLLINT = @XMLLINT@
|
---|
161 | XML_CONFIG = @XML_CONFIG@
|
---|
162 | XSLTPROC = @XSLTPROC@
|
---|
163 | XSLTPROCDV = @XSLTPROCDV@
|
---|
164 | XSLT_INCLUDEDIR = @XSLT_INCLUDEDIR@
|
---|
165 | XSLT_LIBDIR = @XSLT_LIBDIR@
|
---|
166 | XSLT_LIBS = @XSLT_LIBS@
|
---|
167 | XSLT_LOCALE_WINAPI = @XSLT_LOCALE_WINAPI@
|
---|
168 | XSLT_LOCALE_XLOCALE = @XSLT_LOCALE_XLOCALE@
|
---|
169 | abs_builddir = @abs_builddir@
|
---|
170 | abs_srcdir = @abs_srcdir@
|
---|
171 | abs_top_builddir = @abs_top_builddir@
|
---|
172 | abs_top_srcdir = @abs_top_srcdir@
|
---|
173 | ac_ct_CC = @ac_ct_CC@
|
---|
174 | ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
|
---|
175 | am__include = @am__include@
|
---|
176 | am__leading_dot = @am__leading_dot@
|
---|
177 | am__quote = @am__quote@
|
---|
178 | am__tar = @am__tar@
|
---|
179 | am__untar = @am__untar@
|
---|
180 | bindir = @bindir@
|
---|
181 | build = @build@
|
---|
182 | build_alias = @build_alias@
|
---|
183 | build_cpu = @build_cpu@
|
---|
184 | build_os = @build_os@
|
---|
185 | build_vendor = @build_vendor@
|
---|
186 | builddir = @builddir@
|
---|
187 | datadir = @datadir@
|
---|
188 | datarootdir = @datarootdir@
|
---|
189 | docdir = @docdir@
|
---|
190 | dvidir = @dvidir@
|
---|
191 | exec_prefix = @exec_prefix@
|
---|
192 | host = @host@
|
---|
193 | host_alias = @host_alias@
|
---|
194 | host_cpu = @host_cpu@
|
---|
195 | host_os = @host_os@
|
---|
196 | host_vendor = @host_vendor@
|
---|
197 | htmldir = @htmldir@
|
---|
198 | includedir = @includedir@
|
---|
199 | infodir = @infodir@
|
---|
200 | install_sh = @install_sh@
|
---|
201 | libdir = @libdir@
|
---|
202 | libexecdir = @libexecdir@
|
---|
203 | localedir = @localedir@
|
---|
204 | localstatedir = @localstatedir@
|
---|
205 | lt_ECHO = @lt_ECHO@
|
---|
206 | mandir = @mandir@
|
---|
207 | mkdir_p = @mkdir_p@
|
---|
208 | oldincludedir = @oldincludedir@
|
---|
209 | pdfdir = @pdfdir@
|
---|
210 | prefix = @prefix@
|
---|
211 | program_transform_name = @program_transform_name@
|
---|
212 | psdir = @psdir@
|
---|
213 | pythondir = @pythondir@
|
---|
214 | sbindir = @sbindir@
|
---|
215 | sharedstatedir = @sharedstatedir@
|
---|
216 | srcdir = @srcdir@
|
---|
217 | sysconfdir = @sysconfdir@
|
---|
218 | target_alias = @target_alias@
|
---|
219 | top_build_prefix = @top_build_prefix@
|
---|
220 | top_builddir = @top_builddir@
|
---|
221 | top_srcdir = @top_srcdir@
|
---|
222 | EXTRA_DIST = \
|
---|
223 | cmdlineparams.xml cmdlineparams.xsl cmdlineparams.out \
|
---|
224 | tst-1.xml tst-1.xsl tst-1.out tst-1.err \
|
---|
225 | tst-2.xml tst-2.xsl tst-2.out tst-2.err \
|
---|
226 | undefvar.xml undefvar.xsl undefvar.out undefvar.err \
|
---|
227 | recglobparam.xsl recglobvar.xsl reclocparam.xsl reclocvar.xsl \
|
---|
228 | recglobparam.xml recglobvar.xml reclocparam.xml reclocvar.xml
|
---|
229 |
|
---|
230 | all: all-am
|
---|
231 |
|
---|
232 | .SUFFIXES:
|
---|
233 | $(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
|
---|
234 | @for dep in $?; do \
|
---|
235 | case '$(am__configure_deps)' in \
|
---|
236 | *$$dep*) \
|
---|
237 | ( cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh ) \
|
---|
238 | && { if test -f $@; then exit 0; else break; fi; }; \
|
---|
239 | exit 1;; \
|
---|
240 | esac; \
|
---|
241 | done; \
|
---|
242 | echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu tests/reports/Makefile'; \
|
---|
243 | $(am__cd) $(top_srcdir) && \
|
---|
244 | $(AUTOMAKE) --gnu tests/reports/Makefile
|
---|
245 | .PRECIOUS: Makefile
|
---|
246 | Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
---|
247 | @case '$?' in \
|
---|
248 | *config.status*) \
|
---|
249 | cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh;; \
|
---|
250 | *) \
|
---|
251 | echo ' cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)'; \
|
---|
252 | cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe);; \
|
---|
253 | esac;
|
---|
254 |
|
---|
255 | $(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
|
---|
256 | cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
|
---|
257 |
|
---|
258 | $(top_srcdir)/configure: $(am__configure_deps)
|
---|
259 | cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
|
---|
260 | $(ACLOCAL_M4): $(am__aclocal_m4_deps)
|
---|
261 | cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
|
---|
262 | $(am__aclocal_m4_deps):
|
---|
263 |
|
---|
264 | mostlyclean-libtool:
|
---|
265 | -rm -f *.lo
|
---|
266 |
|
---|
267 | clean-libtool:
|
---|
268 | -rm -rf .libs _libs
|
---|
269 | tags: TAGS
|
---|
270 | TAGS:
|
---|
271 |
|
---|
272 | ctags: CTAGS
|
---|
273 | CTAGS:
|
---|
274 |
|
---|
275 |
|
---|
276 | distdir: $(DISTFILES)
|
---|
277 | @srcdirstrip=`echo "$(srcdir)" | sed 's/[].[^$$\\*]/\\\\&/g'`; \
|
---|
278 | topsrcdirstrip=`echo "$(top_srcdir)" | sed 's/[].[^$$\\*]/\\\\&/g'`; \
|
---|
279 | list='$(DISTFILES)'; \
|
---|
280 | dist_files=`for file in $$list; do echo $$file; done | \
|
---|
281 | sed -e "s|^$$srcdirstrip/||;t" \
|
---|
282 | -e "s|^$$topsrcdirstrip/|$(top_builddir)/|;t"`; \
|
---|
283 | case $$dist_files in \
|
---|
284 | */*) $(MKDIR_P) `echo "$$dist_files" | \
|
---|
285 | sed '/\//!d;s|^|$(distdir)/|;s,/[^/]*$$,,' | \
|
---|
286 | sort -u` ;; \
|
---|
287 | esac; \
|
---|
288 | for file in $$dist_files; do \
|
---|
289 | if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
|
---|
290 | if test -d $$d/$$file; then \
|
---|
291 | dir=`echo "/$$file" | sed -e 's,/[^/]*$$,,'`; \
|
---|
292 | if test -d "$(distdir)/$$file"; then \
|
---|
293 | find "$(distdir)/$$file" -type d ! -perm -700 -exec chmod u+rwx {} \;; \
|
---|
294 | fi; \
|
---|
295 | if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
|
---|
296 | cp -fpR $(srcdir)/$$file "$(distdir)$$dir" || exit 1; \
|
---|
297 | find "$(distdir)/$$file" -type d ! -perm -700 -exec chmod u+rwx {} \;; \
|
---|
298 | fi; \
|
---|
299 | cp -fpR $$d/$$file "$(distdir)$$dir" || exit 1; \
|
---|
300 | else \
|
---|
301 | test -f "$(distdir)/$$file" \
|
---|
302 | || cp -p $$d/$$file "$(distdir)/$$file" \
|
---|
303 | || exit 1; \
|
---|
304 | fi; \
|
---|
305 | done
|
---|
306 | check-am: all-am
|
---|
307 | check: check-am
|
---|
308 | all-am: Makefile
|
---|
309 | installdirs:
|
---|
310 | install: install-am
|
---|
311 | install-exec: install-exec-am
|
---|
312 | install-data: install-data-am
|
---|
313 | uninstall: uninstall-am
|
---|
314 |
|
---|
315 | install-am: all-am
|
---|
316 | @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
|
---|
317 |
|
---|
318 | installcheck: installcheck-am
|
---|
319 | install-strip:
|
---|
320 | $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
|
---|
321 | install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
|
---|
322 | `test -z '$(STRIP)' || \
|
---|
323 | echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
|
---|
324 | mostlyclean-generic:
|
---|
325 |
|
---|
326 | clean-generic:
|
---|
327 |
|
---|
328 | distclean-generic:
|
---|
329 | -test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
|
---|
330 | -test . = "$(srcdir)" || test -z "$(CONFIG_CLEAN_VPATH_FILES)" || rm -f $(CONFIG_CLEAN_VPATH_FILES)
|
---|
331 |
|
---|
332 | maintainer-clean-generic:
|
---|
333 | @echo "This command is intended for maintainers to use"
|
---|
334 | @echo "it deletes files that may require special tools to rebuild."
|
---|
335 | clean: clean-am
|
---|
336 |
|
---|
337 | clean-am: clean-generic clean-libtool mostlyclean-am
|
---|
338 |
|
---|
339 | distclean: distclean-am
|
---|
340 | -rm -f Makefile
|
---|
341 | distclean-am: clean-am distclean-generic
|
---|
342 |
|
---|
343 | dvi: dvi-am
|
---|
344 |
|
---|
345 | dvi-am:
|
---|
346 |
|
---|
347 | html: html-am
|
---|
348 |
|
---|
349 | html-am:
|
---|
350 |
|
---|
351 | info: info-am
|
---|
352 |
|
---|
353 | info-am:
|
---|
354 |
|
---|
355 | install-data-am:
|
---|
356 |
|
---|
357 | install-dvi: install-dvi-am
|
---|
358 |
|
---|
359 | install-dvi-am:
|
---|
360 |
|
---|
361 | install-exec-am:
|
---|
362 |
|
---|
363 | install-html: install-html-am
|
---|
364 |
|
---|
365 | install-html-am:
|
---|
366 |
|
---|
367 | install-info: install-info-am
|
---|
368 |
|
---|
369 | install-info-am:
|
---|
370 |
|
---|
371 | install-man:
|
---|
372 |
|
---|
373 | install-pdf: install-pdf-am
|
---|
374 |
|
---|
375 | install-pdf-am:
|
---|
376 |
|
---|
377 | install-ps: install-ps-am
|
---|
378 |
|
---|
379 | install-ps-am:
|
---|
380 |
|
---|
381 | installcheck-am:
|
---|
382 |
|
---|
383 | maintainer-clean: maintainer-clean-am
|
---|
384 | -rm -f Makefile
|
---|
385 | maintainer-clean-am: distclean-am maintainer-clean-generic
|
---|
386 |
|
---|
387 | mostlyclean: mostlyclean-am
|
---|
388 |
|
---|
389 | mostlyclean-am: mostlyclean-generic mostlyclean-libtool
|
---|
390 |
|
---|
391 | pdf: pdf-am
|
---|
392 |
|
---|
393 | pdf-am:
|
---|
394 |
|
---|
395 | ps: ps-am
|
---|
396 |
|
---|
397 | ps-am:
|
---|
398 |
|
---|
399 | uninstall-am:
|
---|
400 |
|
---|
401 | .MAKE: install-am install-strip
|
---|
402 |
|
---|
403 | .PHONY: all all-am check check-am clean clean-generic clean-libtool \
|
---|
404 | distclean distclean-generic distclean-libtool distdir dvi \
|
---|
405 | dvi-am html html-am info info-am install install-am \
|
---|
406 | install-data install-data-am install-dvi install-dvi-am \
|
---|
407 | install-exec install-exec-am install-html install-html-am \
|
---|
408 | install-info install-info-am install-man install-pdf \
|
---|
409 | install-pdf-am install-ps install-ps-am install-strip \
|
---|
410 | installcheck installcheck-am installdirs maintainer-clean \
|
---|
411 | maintainer-clean-generic mostlyclean mostlyclean-generic \
|
---|
412 | mostlyclean-libtool pdf pdf-am ps ps-am uninstall uninstall-am
|
---|
413 |
|
---|
414 |
|
---|
415 | $(top_builddir)/xsltproc/xsltproc:
|
---|
416 | @(cd ../../xsltproc ; $(MAKE) xsltproc)
|
---|
417 |
|
---|
418 | all:
|
---|
419 |
|
---|
420 | valgrind:
|
---|
421 | @echo '## Running the regression tests under Valgrind'
|
---|
422 | $(MAKE) CHECKER='valgrind -q' tests
|
---|
423 |
|
---|
424 | test tests: $(top_builddir)/xsltproc/xsltproc
|
---|
425 | @echo '## Running reports tests'
|
---|
426 | @(echo > .memdump)
|
---|
427 | -@(for i in $(srcdir)/../docs/*.xml ; do \
|
---|
428 | if [ -d $$i ] ; then continue ; fi ; \
|
---|
429 | doc=`basename $$i .xml` ; \
|
---|
430 | for j in $(srcdir)/$$doc*.xsl ; do \
|
---|
431 | if [ ! -f $$j ] ; then continue ; fi ; \
|
---|
432 | if [ -d $$j ] ; then continue ; fi ; \
|
---|
433 | name=`basename $$j .xsl`; \
|
---|
434 | out=$(srcdir)/"$$name".out; \
|
---|
435 | err=$(srcdir)/"$$name".err; \
|
---|
436 | log=`$(CHECKER) $(top_builddir)/xsltproc/xsltproc \
|
---|
437 | --stringparam test passed_value \
|
---|
438 | --stringparam test2 passed_value2 \
|
---|
439 | $$j $$i > result.$$name \
|
---|
440 | 2> err.$$name ; \
|
---|
441 | if [ ! -f $$out ] ; then \
|
---|
442 | cp result.$$name $$out ; \
|
---|
443 | if [ -s err.$$name ] ; then \
|
---|
444 | cp err.$$name $$err ; \
|
---|
445 | fi ; \
|
---|
446 | else \
|
---|
447 | diff $$out result.$$name; \
|
---|
448 | if [ -s $$err ] ; then \
|
---|
449 | diff $$err err.$$name; \
|
---|
450 | else \
|
---|
451 | diff /dev/null err.$$name; \
|
---|
452 | fi ; \
|
---|
453 | fi ; \
|
---|
454 | grep "MORY ALLO" .memdump | grep -v "MEMORY ALLOCATED : 0" || true`;\
|
---|
455 | if [ -n "$$log" ] ; then \
|
---|
456 | echo $$name result ; \
|
---|
457 | echo $$log ; \
|
---|
458 | fi ; \
|
---|
459 | rm -f result.$$name err.$$name; \
|
---|
460 | done ; done)
|
---|
461 |
|
---|
462 | # Tell versions [3.59,3.63) of GNU make to not export all variables.
|
---|
463 | # Otherwise a system limit (for SysV at least) may be exceeded.
|
---|
464 | .NOEXPORT:
|
---|