source: xslt/vendor/current/tests/plugins/Makefile.am@ 372

Last change on this file since 372 was 372, checked in by Yuri Dario, 13 years ago

xslt: initial vendor import of xslt 1.1.26.

File size: 1.2 KB
Line 
1## Process this file with automake to produce Makefile.in
2
3$(top_builddir)/xsltproc/xsltproc:
4 @(cd ../../../xsltproc ; $(MAKE) xsltproc)
5
6EXTRA_DIST = plugin.out plugin.xml plugin.xsl
7
8INCLUDES = -I$(top_srcdir) -I../../libxslt $(LIBXML_CFLAGS) $(LIBXSLT_CFLAGS)
9
10EXTRA_LTLIBRARIES = xmlsoft_org_xslt_testplugin.la
11
12# our rpath is a rather unorthodox location as we
13# don't want to pollute $(DESTDIR) with the test plugin
14
15plugindir=$(shell pwd)/.libs/
16
17xmlsoft_org_xslt_testplugin_la_CFLAGS = -DMODULE_COMPILE $(LIBXML_CFLAGS) $(LIBXSLT_CFLAGS)
18xmlsoft_org_xslt_testplugin_la_SOURCES = testplugin.c
19xmlsoft_org_xslt_testplugin_la_LIBADD = $(top_builddir)/libxslt/libxslt.la $(EXTRA_LIBS)
20xmlsoft_org_xslt_testplugin_la_LDFLAGS = -module -avoid-version -rpath $(plugindir)
21
22all:
23
24if WITH_MODULES
25
26test-logall:
27 @echo '## Running plugin tests'
28
29test tests: $(top_builddir)/xsltproc/xsltproc test-logall $(EXTRA_LTLIBRARIES)
30 @LD_LIBRARY_PATH=$(plugindir):$(top_builddir)/libxslt/.libs:$(LD_LIBRARY_PATH) \
31 LIBXSLT_PLUGINS_PATH=$(plugindir) \
32 $(top_builddir)/xsltproc/xsltproc plugin.xsl plugin.xml > plugin.res
33 @diff plugin.out plugin.res
34 @rm plugin.res
35
36else
37
38test tests:
39 @echo Skipping the plugin tests.
40
41endif
42
Note: See TracBrowser for help on using the repository browser.