source: xslt/vendor/current/tests/exslt/dynamic/Makefile.am@ 372

Last change on this file since 372 was 372, checked in by Yuri Dario, 13 years ago

xslt: initial vendor import of xslt 1.1.26.

File size: 1.3 KB
Line 
1## Process this file with automake to produce Makefile.in
2
3$(top_builddir)/xsltproc/xsltproc:
4 @(cd ../../../xsltproc ; $(MAKE) xsltproc)
5
6EXTRA_DIST = \
7 dynmap.out dynmap.xml dynmap.xsl
8
9all:
10
11valgrind:
12 @echo '## Running the regression tests under Valgrind'
13 $(MAKE) CHECKER='valgrind -q' tests
14
15test tests: $(top_builddir)/xsltproc/xsltproc
16 @echo '## Running exslt sets tests'
17 @(echo > .memdump)
18 @(for i in $(srcdir)/*.xsl ; do \
19 name=`basename $$i .xsl` ; \
20 if [ ! -f $(srcdir)/$$name.xml ] ; then continue ; fi ; \
21 log=`$(CHECKER) $(top_builddir)/xsltproc/xsltproc \
22 $(srcdir)/$$name.xsl $(srcdir)/$$name.xml > $$name.res 2>$$name.bad;\
23 if [ ! -f $(srcdir)/$$name.out ] ; then \
24 cp $$name.res $(srcdir)/$$name.out ; \
25 if [ -s $$name.bad ] ; then \
26 mv $$name.bad $(srcdir)/$$name.err ; \
27 fi ; \
28 else \
29 if [ ! -s $$name.res ] ; then \
30 echo "Fatal error, no $$name.res\n" ; \
31 else \
32 diff $(srcdir)/$$name.out $$name.res ; \
33 if [ -s $(srcdir)/$$name.err ] ; then \
34 diff $(srcdir)/$$name.err $$name.bad; \
35 else \
36 diff /dev/null $$name.bad; \
37 fi ; \
38 fi ; \
39 fi; \
40 grep "MORY ALLO" .memdump | grep -v "MEMORY ALLOCATED : 0" || true`;\
41 if [ -n "$$log" ] ; then \
42 echo $$name result ; \
43 echo $$log ; \
44 fi ; \
45 rm -f $$name.res $$name.bad ; \
46 done)
Note: See TracBrowser for help on using the repository browser.