source: xslt/vendor/current/tests/REC1/Makefile.am@ 372

Last change on this file since 372 was 372, checked in by Yuri Dario, 13 years ago

xslt: initial vendor import of xslt 1.1.26.

File size: 697 bytes
Line 
1## Process this file with automake to produce Makefile.in
2
3$(top_builddir)/xsltproc/xsltproc:
4 @(cd ../../xsltproc ; $(MAKE) xsltproc)
5
6EXTRA_DIST = doc.xsl doc.xml doc.dtd result.xml
7
8all:
9
10valgrind:
11 @echo '## Running the regression tests under Valgrind'
12 $(MAKE) CHECKER='valgrind -q' tests
13
14# No special stuff here, just a single test that either works or doesn't!
15test tests: $(top_builddir)/xsltproc/xsltproc
16 @echo '## Running REC1 tests'
17 @(echo > .memdump)
18 @($(CHECKER) $(top_builddir)/xsltproc/xsltproc \
19 $(srcdir)/doc.xsl $(srcdir)/doc.xml > doc.res ; \
20 diff $(srcdir)/result.xml doc.res ; \
21 grep "MORY ALLO" .memdump | grep -v "MEMORY ALLOCATED : 0" || true; \
22 rm -f doc.res)
23
Note: See TracBrowser for help on using the repository browser.