source: spf2/vendor/current/src/include/Makefile.in@ 302

Last change on this file since 302 was 302, checked in by Yuri Dario, 14 years ago

spf2: initial vendor import of spf2 1.2.9.

File size: 14.9 KB
Line 
1# Makefile.in generated by automake 1.8.5 from Makefile.am.
2# @configure_input@
3
4# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
5# 2003, 2004 Free Software Foundation, Inc.
6# This Makefile.in is free software; the Free Software Foundation
7# gives unlimited permission to copy and/or distribute it,
8# with or without modifications, as long as this notice is preserved.
9
10# This program is distributed in the hope that it will be useful,
11# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
12# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
13# PARTICULAR PURPOSE.
14
15@SET_MAKE@
16
17# Makefile prototype
18
19srcdir = @srcdir@
20top_srcdir = @top_srcdir@
21VPATH = @srcdir@
22pkgdatadir = $(datadir)/@PACKAGE@
23pkglibdir = $(libdir)/@PACKAGE@
24pkgincludedir = $(includedir)/@PACKAGE@
25top_builddir = ../..
26am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
27INSTALL = @INSTALL@
28install_sh_DATA = $(install_sh) -c -m 644
29install_sh_PROGRAM = $(install_sh) -c
30install_sh_SCRIPT = $(install_sh) -c
31INSTALL_HEADER = $(INSTALL_DATA)
32transform = $(program_transform_name)
33NORMAL_INSTALL = :
34PRE_INSTALL = :
35POST_INSTALL = :
36NORMAL_UNINSTALL = :
37PRE_UNINSTALL = :
38POST_UNINSTALL = :
39host_triplet = @host@
40subdir = src/include
41DIST_COMMON = $(include_HEADERS) $(noinst_HEADERS) \
42 $(srcdir)/Makefile.am $(srcdir)/Makefile.in
43ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
44am__aclocal_m4_deps = $(top_srcdir)/configure.ac
45am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
46 $(ACLOCAL_M4)
47mkinstalldirs = $(mkdir_p)
48CONFIG_HEADER = $(top_builddir)/config.h
49CONFIG_CLEAN_FILES =
50SOURCES =
51DIST_SOURCES =
52RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
53 html-recursive info-recursive install-data-recursive \
54 install-exec-recursive install-info-recursive \
55 install-recursive installcheck-recursive installdirs-recursive \
56 pdf-recursive ps-recursive uninstall-info-recursive \
57 uninstall-recursive
58am__installdirs = "$(DESTDIR)$(includedir)"
59includeHEADERS_INSTALL = $(INSTALL_HEADER)
60HEADERS = $(include_HEADERS) $(noinst_HEADERS)
61ETAGS = etags
62CTAGS = ctags
63DIST_SUBDIRS = $(SUBDIRS)
64DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
65ACLOCAL = @ACLOCAL@
66AMDEP_FALSE = @AMDEP_FALSE@
67AMDEP_TRUE = @AMDEP_TRUE@
68AMTAR = @AMTAR@
69AR = @AR@
70AUTOCONF = @AUTOCONF@
71AUTOHEADER = @AUTOHEADER@
72AUTOMAKE = @AUTOMAKE@
73AWK = @AWK@
74CC = @CC@
75CCDEPMODE = @CCDEPMODE@
76CFLAGS = @CFLAGS@
77CPP = @CPP@
78CPPFLAGS = @CPPFLAGS@
79CXX = @CXX@
80CXXCPP = @CXXCPP@
81CXXDEPMODE = @CXXDEPMODE@
82CXXFLAGS = @CXXFLAGS@
83CYGPATH_W = @CYGPATH_W@
84DEFS = @DEFS@
85DEPDIR = @DEPDIR@
86DSYMUTIL = @DSYMUTIL@
87ECHO = @ECHO@
88ECHO_C = @ECHO_C@
89ECHO_N = @ECHO_N@
90ECHO_T = @ECHO_T@
91EGREP = @EGREP@
92EXEEXT = @EXEEXT@
93F77 = @F77@
94FFLAGS = @FFLAGS@
95GREP = @GREP@
96INSTALL_DATA = @INSTALL_DATA@
97INSTALL_PROGRAM = @INSTALL_PROGRAM@
98INSTALL_SCRIPT = @INSTALL_SCRIPT@
99INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
100KV_MAJOR = @KV_MAJOR@
101KV_MINOR = @KV_MINOR@
102KV_PATCH = @KV_PATCH@
103LDFLAGS = @LDFLAGS@
104LIBOBJS = @LIBOBJS@
105LIBPROGS = @LIBPROGS@
106LIBS = @LIBS@
107LIBTOOL = @LIBTOOL@
108LN_S = @LN_S@
109LTLIBOBJS = @LTLIBOBJS@
110MAKEINFO = @MAKEINFO@
111NMEDIT = @NMEDIT@
112OBJEXT = @OBJEXT@
113PACKAGE = @PACKAGE@
114PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
115PACKAGE_NAME = @PACKAGE_NAME@
116PACKAGE_STRING = @PACKAGE_STRING@
117PACKAGE_TARNAME = @PACKAGE_TARNAME@
118PACKAGE_VERSION = @PACKAGE_VERSION@
119PATH_SEPARATOR = @PATH_SEPARATOR@
120PERL = @PERL@
121PERL_SUBDIRS = @PERL_SUBDIRS@
122RANLIB = @RANLIB@
123SED = @SED@
124SET_MAKE = @SET_MAKE@
125SHELL = @SHELL@
126STRIP = @STRIP@
127SUBDIRS = @SUBDIRS@
128VERSION = @VERSION@
129ac_ct_CC = @ac_ct_CC@
130ac_ct_CXX = @ac_ct_CXX@
131ac_ct_F77 = @ac_ct_F77@
132am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
133am__fastdepCC_TRUE = @am__fastdepCC_TRUE@
134am__fastdepCXX_FALSE = @am__fastdepCXX_FALSE@
135am__fastdepCXX_TRUE = @am__fastdepCXX_TRUE@
136am__include = @am__include@
137am__leading_dot = @am__leading_dot@
138am__quote = @am__quote@
139bindir = @bindir@
140build = @build@
141build_alias = @build_alias@
142build_cpu = @build_cpu@
143build_os = @build_os@
144build_vendor = @build_vendor@
145datadir = @datadir@
146datarootdir = @datarootdir@
147docdir = @docdir@
148dvidir = @dvidir@
149exec_prefix = @exec_prefix@
150host = @host@
151host_alias = @host_alias@
152host_cpu = @host_cpu@
153host_os = @host_os@
154host_vendor = @host_vendor@
155htmldir = @htmldir@
156includedir = ${prefix}/include/spf2
157infodir = @infodir@
158install_sh = @install_sh@
159libdir = @libdir@
160libexecdir = @libexecdir@
161localedir = @localedir@
162localstatedir = @localstatedir@
163mandir = @mandir@
164mkdir_p = @mkdir_p@
165oldincludedir = @oldincludedir@
166pdfdir = @pdfdir@
167prefix = @prefix@
168program_transform_name = @program_transform_name@
169psdir = @psdir@
170sbindir = @sbindir@
171sharedstatedir = @sharedstatedir@
172sysconfdir = @sysconfdir@
173target_alias = @target_alias@
174AUTOMAKE_OPTIONS = foreign
175include_HEADERS = \
176 spf.h \
177 spf_dns.h \
178 spf_dns_cache.h \
179 spf_dns_null.h \
180 spf_dns_resolv.h \
181 spf_dns_rr.h \
182 spf_dns_test.h \
183 spf_dns_zone.h \
184 spf_lib_version.h \
185 spf_log.h \
186 spf_record.h \
187 spf_request.h \
188 spf_response.h \
189 spf_server.h
190
191noinst_HEADERS = spf_internal.h spf_dns_internal.h spf_sys_config.h \
192 spf_win32_internal.h spf_win32.h spf_dns_windns.h
193
194all: all-recursive
195
196.SUFFIXES:
197$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
198 @for dep in $?; do \
199 case '$(am__configure_deps)' in \
200 *$$dep*) \
201 cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh \
202 && exit 0; \
203 exit 1;; \
204 esac; \
205 done; \
206 echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign src/include/Makefile'; \
207 cd $(top_srcdir) && \
208 $(AUTOMAKE) --foreign src/include/Makefile
209.PRECIOUS: Makefile
210Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
211 @case '$?' in \
212 *config.status*) \
213 cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh;; \
214 *) \
215 echo ' cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)'; \
216 cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe);; \
217 esac;
218
219$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
220 cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
221
222$(top_srcdir)/configure: $(am__configure_deps)
223 cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
224$(ACLOCAL_M4): $(am__aclocal_m4_deps)
225 cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
226
227mostlyclean-libtool:
228 -rm -f *.lo
229
230clean-libtool:
231 -rm -rf .libs _libs
232
233distclean-libtool:
234 -rm -f libtool
235uninstall-info-am:
236install-includeHEADERS: $(include_HEADERS)
237 @$(NORMAL_INSTALL)
238 test -z "$(includedir)" || $(mkdir_p) "$(DESTDIR)$(includedir)"
239 @list='$(include_HEADERS)'; for p in $$list; do \
240 if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
241 f="`echo $$p | sed -e 's|^.*/||'`"; \
242 echo " $(includeHEADERS_INSTALL) '$$d$$p' '$(DESTDIR)$(includedir)/$$f'"; \
243 $(includeHEADERS_INSTALL) "$$d$$p" "$(DESTDIR)$(includedir)/$$f"; \
244 done
245
246uninstall-includeHEADERS:
247 @$(NORMAL_UNINSTALL)
248 @list='$(include_HEADERS)'; for p in $$list; do \
249 f="`echo $$p | sed -e 's|^.*/||'`"; \
250 echo " rm -f '$(DESTDIR)$(includedir)/$$f'"; \
251 rm -f "$(DESTDIR)$(includedir)/$$f"; \
252 done
253
254# This directory's subdirectories are mostly independent; you can cd
255# into them and run `make' without going through this Makefile.
256# To change the values of `make' variables: instead of editing Makefiles,
257# (1) if the variable is set in `config.status', edit `config.status'
258# (which will cause the Makefiles to be regenerated when you run `make');
259# (2) otherwise, pass the desired values on the `make' command line.
260$(RECURSIVE_TARGETS):
261 @set fnord $$MAKEFLAGS; amf=$$2; \
262 dot_seen=no; \
263 target=`echo $@ | sed s/-recursive//`; \
264 list='$(SUBDIRS)'; for subdir in $$list; do \
265 echo "Making $$target in $$subdir"; \
266 if test "$$subdir" = "."; then \
267 dot_seen=yes; \
268 local_target="$$target-am"; \
269 else \
270 local_target="$$target"; \
271 fi; \
272 (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
273 || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
274 done; \
275 if test "$$dot_seen" = "no"; then \
276 $(MAKE) $(AM_MAKEFLAGS) "$$target-am" || exit 1; \
277 fi; test -z "$$fail"
278
279mostlyclean-recursive clean-recursive distclean-recursive \
280maintainer-clean-recursive:
281 @set fnord $$MAKEFLAGS; amf=$$2; \
282 dot_seen=no; \
283 case "$@" in \
284 distclean-* | maintainer-clean-*) list='$(DIST_SUBDIRS)' ;; \
285 *) list='$(SUBDIRS)' ;; \
286 esac; \
287 rev=''; for subdir in $$list; do \
288 if test "$$subdir" = "."; then :; else \
289 rev="$$subdir $$rev"; \
290 fi; \
291 done; \
292 rev="$$rev ."; \
293 target=`echo $@ | sed s/-recursive//`; \
294 for subdir in $$rev; do \
295 echo "Making $$target in $$subdir"; \
296 if test "$$subdir" = "."; then \
297 local_target="$$target-am"; \
298 else \
299 local_target="$$target"; \
300 fi; \
301 (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
302 || case "$$amf" in *=*) exit 1;; *k*) fail=yes;; *) exit 1;; esac; \
303 done && test -z "$$fail"
304tags-recursive:
305 list='$(SUBDIRS)'; for subdir in $$list; do \
306 test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) tags); \
307 done
308ctags-recursive:
309 list='$(SUBDIRS)'; for subdir in $$list; do \
310 test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) ctags); \
311 done
312
313ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
314 list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
315 unique=`for i in $$list; do \
316 if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
317 done | \
318 $(AWK) ' { files[$$0] = 1; } \
319 END { for (i in files) print i; }'`; \
320 mkid -fID $$unique
321tags: TAGS
322
323TAGS: tags-recursive $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
324 $(TAGS_FILES) $(LISP)
325 tags=; \
326 here=`pwd`; \
327 if ($(ETAGS) --etags-include --version) >/dev/null 2>&1; then \
328 include_option=--etags-include; \
329 empty_fix=.; \
330 else \
331 include_option=--include; \
332 empty_fix=; \
333 fi; \
334 list='$(SUBDIRS)'; for subdir in $$list; do \
335 if test "$$subdir" = .; then :; else \
336 test ! -f $$subdir/TAGS || \
337 tags="$$tags $$include_option=$$here/$$subdir/TAGS"; \
338 fi; \
339 done; \
340 list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
341 unique=`for i in $$list; do \
342 if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
343 done | \
344 $(AWK) ' { files[$$0] = 1; } \
345 END { for (i in files) print i; }'`; \
346 if test -z "$(ETAGS_ARGS)$$tags$$unique"; then :; else \
347 test -n "$$unique" || unique=$$empty_fix; \
348 $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
349 $$tags $$unique; \
350 fi
351ctags: CTAGS
352CTAGS: ctags-recursive $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
353 $(TAGS_FILES) $(LISP)
354 tags=; \
355 here=`pwd`; \
356 list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
357 unique=`for i in $$list; do \
358 if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
359 done | \
360 $(AWK) ' { files[$$0] = 1; } \
361 END { for (i in files) print i; }'`; \
362 test -z "$(CTAGS_ARGS)$$tags$$unique" \
363 || $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
364 $$tags $$unique
365
366GTAGS:
367 here=`$(am__cd) $(top_builddir) && pwd` \
368 && cd $(top_srcdir) \
369 && gtags -i $(GTAGS_ARGS) $$here
370
371distclean-tags:
372 -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
373
374distdir: $(DISTFILES)
375 @srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
376 topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \
377 list='$(DISTFILES)'; for file in $$list; do \
378 case $$file in \
379 $(srcdir)/*) file=`echo "$$file" | sed "s|^$$srcdirstrip/||"`;; \
380 $(top_srcdir)/*) file=`echo "$$file" | sed "s|^$$topsrcdirstrip/|$(top_builddir)/|"`;; \
381 esac; \
382 if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
383 dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
384 if test "$$dir" != "$$file" && test "$$dir" != "."; then \
385 dir="/$$dir"; \
386 $(mkdir_p) "$(distdir)$$dir"; \
387 else \
388 dir=''; \
389 fi; \
390 if test -d $$d/$$file; then \
391 if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
392 cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \
393 fi; \
394 cp -pR $$d/$$file $(distdir)$$dir || exit 1; \
395 else \
396 test -f $(distdir)/$$file \
397 || cp -p $$d/$$file $(distdir)/$$file \
398 || exit 1; \
399 fi; \
400 done
401 list='$(SUBDIRS)'; for subdir in $$list; do \
402 if test "$$subdir" = .; then :; else \
403 test -d "$(distdir)/$$subdir" \
404 || mkdir "$(distdir)/$$subdir" \
405 || exit 1; \
406 (cd $$subdir && \
407 $(MAKE) $(AM_MAKEFLAGS) \
408 top_distdir="../$(top_distdir)" \
409 distdir="../$(distdir)/$$subdir" \
410 distdir) \
411 || exit 1; \
412 fi; \
413 done
414check-am: all-am
415check: check-recursive
416all-am: Makefile $(HEADERS)
417installdirs: installdirs-recursive
418installdirs-am:
419 for dir in "$(DESTDIR)$(includedir)"; do \
420 test -z "$$dir" || $(mkdir_p) "$$dir"; \
421 done
422install: install-recursive
423install-exec: install-exec-recursive
424install-data: install-data-recursive
425uninstall: uninstall-recursive
426
427install-am: all-am
428 @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
429
430installcheck: installcheck-recursive
431install-strip:
432 $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
433 install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
434 `test -z '$(STRIP)' || \
435 echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
436mostlyclean-generic:
437
438clean-generic:
439
440distclean-generic:
441 -rm -f $(CONFIG_CLEAN_FILES)
442
443maintainer-clean-generic:
444 @echo "This command is intended for maintainers to use"
445 @echo "it deletes files that may require special tools to rebuild."
446clean: clean-recursive
447
448clean-am: clean-generic clean-libtool mostlyclean-am
449
450distclean: distclean-recursive
451 -rm -f Makefile
452distclean-am: clean-am distclean-generic distclean-libtool \
453 distclean-tags
454
455dvi: dvi-recursive
456
457dvi-am:
458
459html: html-recursive
460
461info: info-recursive
462
463info-am:
464
465install-data-am: install-includeHEADERS
466
467install-exec-am:
468
469install-info: install-info-recursive
470
471install-man:
472
473installcheck-am:
474
475maintainer-clean: maintainer-clean-recursive
476 -rm -f Makefile
477maintainer-clean-am: distclean-am maintainer-clean-generic
478
479mostlyclean: mostlyclean-recursive
480
481mostlyclean-am: mostlyclean-generic mostlyclean-libtool
482
483pdf: pdf-recursive
484
485pdf-am:
486
487ps: ps-recursive
488
489ps-am:
490
491uninstall-am: uninstall-includeHEADERS uninstall-info-am
492
493uninstall-info: uninstall-info-recursive
494
495.PHONY: $(RECURSIVE_TARGETS) CTAGS GTAGS all all-am check check-am \
496 clean clean-generic clean-libtool clean-recursive ctags \
497 ctags-recursive distclean distclean-generic distclean-libtool \
498 distclean-recursive distclean-tags distdir dvi dvi-am html \
499 html-am info info-am install install-am install-data \
500 install-data-am install-exec install-exec-am \
501 install-includeHEADERS install-info install-info-am \
502 install-man install-strip installcheck installcheck-am \
503 installdirs installdirs-am maintainer-clean \
504 maintainer-clean-generic maintainer-clean-recursive \
505 mostlyclean mostlyclean-generic mostlyclean-libtool \
506 mostlyclean-recursive pdf pdf-am ps ps-am tags tags-recursive \
507 uninstall uninstall-am uninstall-includeHEADERS \
508 uninstall-info-am
509
510# Tell versions [3.59,3.63) of GNU make to not export all variables.
511# Otherwise a system limit (for SysV at least) may be exceeded.
512.NOEXPORT:
Note: See TracBrowser for help on using the repository browser.