Line | |
---|
1 | #! gmake
|
---|
2 | #
|
---|
3 | # This Source Code Form is subject to the terms of the Mozilla Public
|
---|
4 | # License, v. 2.0. If a copy of the MPL was not distributed with this
|
---|
5 | # file, You can obtain one at http://mozilla.org/MPL/2.0/.
|
---|
6 |
|
---|
7 | CORE_DEPTH = ..
|
---|
8 | DEPTH = ..
|
---|
9 |
|
---|
10 | include manifest.mn
|
---|
11 | include $(CORE_DEPTH)/coreconf/config.mk
|
---|
12 |
|
---|
13 | ifdef BUILD_LIBPKIX_TESTS
|
---|
14 | DIRS += libpkix
|
---|
15 | endif
|
---|
16 |
|
---|
17 | ifeq ($(NSS_BUILD_WITHOUT_SOFTOKEN),1)
|
---|
18 | BLTEST_SRCDIR =
|
---|
19 | FIPSTEST_SRCDIR =
|
---|
20 | SHLIBSIGN_SRCDIR =
|
---|
21 | else
|
---|
22 | BLTEST_SRCDIR = bltest
|
---|
23 | FIPSTEST_SRCDIR = fipstest
|
---|
24 | SHLIBSIGN_SRCDIR = shlibsign
|
---|
25 | endif
|
---|
26 |
|
---|
27 | LOWHASHTEST_SRCDIR=
|
---|
28 | ifeq ($(FREEBL_LOWHASH),1)
|
---|
29 | LOWHASHTEST_SRCDIR = lowhashtest # Add the lowhashtest directory to DIRS.
|
---|
30 | endif
|
---|
31 |
|
---|
32 | INCLUDES += \
|
---|
33 | -I$(DIST)/../public/security \
|
---|
34 | -I./include \
|
---|
35 | $(NULL)
|
---|
36 |
|
---|
37 | include $(CORE_DEPTH)/coreconf/rules.mk
|
---|
38 |
|
---|
39 | symbols::
|
---|
40 | @echo "TARGETS = $(TARGETS)"
|
---|
Note:
See
TracBrowser
for help on using the repository browser.