source: nss/vendor/current/cmd/Makefile@ 1513

Last change on this file since 1513 was 1513, checked in by dmik, 9 years ago

nss: Import version 3.23 from vendor.

Source URL: https://hg.mozilla.org/projects/nss/rev/NSS_3_23_RTM

File size: 815 bytes
Line 
1#! gmake
2#
3# This Source Code Form is subject to the terms of the Mozilla Public
4# License, v. 2.0. If a copy of the MPL was not distributed with this
5# file, You can obtain one at http://mozilla.org/MPL/2.0/.
6
7CORE_DEPTH = ..
8DEPTH = ..
9
10include manifest.mn
11include $(CORE_DEPTH)/coreconf/config.mk
12
13ifdef BUILD_LIBPKIX_TESTS
14DIRS += libpkix
15endif
16
17ifeq ($(NSS_BUILD_WITHOUT_SOFTOKEN),1)
18BLTEST_SRCDIR =
19FIPSTEST_SRCDIR =
20SHLIBSIGN_SRCDIR =
21else
22BLTEST_SRCDIR = bltest
23FIPSTEST_SRCDIR = fipstest
24SHLIBSIGN_SRCDIR = shlibsign
25endif
26
27LOWHASHTEST_SRCDIR=
28ifeq ($(FREEBL_LOWHASH),1)
29LOWHASHTEST_SRCDIR = lowhashtest # Add the lowhashtest directory to DIRS.
30endif
31
32INCLUDES += \
33 -I$(DIST)/../public/security \
34 -I./include \
35 $(NULL)
36
37include $(CORE_DEPTH)/coreconf/rules.mk
38
39symbols::
40 @echo "TARGETS = $(TARGETS)"
Note: See TracBrowser for help on using the repository browser.