source: icu/vendor/current/source/i18n/Makefile.in@ 1367

Last change on this file since 1367 was 1367, checked in by dmik, 9 years ago

icu: Import version 56.1 from vendor.

Source URL: http://source.icu-project.org/repos/icu/icu/tags/release-56-1

File size: 7.0 KB
Line 
1#******************************************************************************
2#
3# Copyright (C) 1998-2015, International Business Machines
4# Corporation and others. All Rights Reserved.
5#
6#******************************************************************************
7## Makefile.in for ICU - icui18n.so
8## Stephen F. Booth
9
10## Source directory information
11srcdir = @srcdir@
12top_srcdir = @top_srcdir@
13
14top_builddir = ..
15
16## All the flags and other definitions are included here.
17include $(top_builddir)/icudefs.mk
18
19## Build directory information
20subdir = i18n
21
22## Extra files to remove for 'make clean'
23CLEANFILES = *~ $(DEPS) $(IMPORT_LIB) $(MIDDLE_IMPORT_LIB) $(FINAL_IMPORT_LIB)
24
25## Target information
26
27TARGET_STUBNAME=$(I18N_STUBNAME)
28
29ifneq ($(ENABLE_STATIC),)
30TARGET = $(LIBDIR)/$(LIBSICU)$(TARGET_STUBNAME)$(ICULIBSUFFIX).$(A)
31endif
32
33ifneq ($(ENABLE_SHARED),)
34SO_TARGET = $(LIBDIR)/$(LIBICU)$(TARGET_STUBNAME)$(ICULIBSUFFIX).$(SO)
35ALL_SO_TARGETS = $(SO_TARGET) $(MIDDLE_SO_TARGET) $(FINAL_SO_TARGET) $(SHARED_OBJECT)
36
37ifeq ($(ENABLE_SO_VERSION_DATA),1)
38SO_VERSION_DATA = i18n.res
39endif
40
41ifeq ($(OS390BATCH),1)
42BATCH_TARGET = $(BATCH_I18N_TARGET)
43BATCH_LIBS = $(BATCH_LIBICUUC) -lm
44endif # OS390BATCH
45
46endif # ENABLE_SHARED
47
48ALL_TARGETS = $(TARGET) $(ALL_SO_TARGETS) $(BATCH_TARGET)
49
50DYNAMICCPPFLAGS = $(SHAREDLIBCPPFLAGS)
51DYNAMICCFLAGS = $(SHAREDLIBCFLAGS)
52DYNAMICCXXFLAGS = $(SHAREDLIBCXXFLAGS)
53CFLAGS += $(LIBCFLAGS)
54CXXFLAGS += $(LIBCXXFLAGS)
55ifeq ($(OS390BATCH),1)
56CFLAGS += -WI
57CXXFLAGS += -WI
58endif
59
60CPPFLAGS += -I$(srcdir) -I$(top_srcdir)/common $(LIBCPPFLAGS) $(CPPFLAGSICUI18N)
61DEFS += -DU_I18N_IMPLEMENTATION
62LDFLAGS += $(LDFLAGSICUI18N)
63LIBS = $(LIBICUUC) $(DEFAULT_LIBS)
64
65OBJECTS = ucln_in.o \
66fmtable.o format.o msgfmt.o umsg.o numfmt.o unum.o decimfmt.o decimalformatpattern.o dcfmtsym.o \
67ucurr.o digitlst.o fmtable_cnv.o \
68choicfmt.o datefmt.o smpdtfmt.o reldtfmt.o dtfmtsym.o udat.o dtptngen.o udatpg.o \
69nfrs.o nfrule.o nfsubs.o rbnf.o numsys.o unumsys.o ucsdet.o \
70ucal.o calendar.o gregocal.o timezone.o simpletz.o olsontz.o \
71astro.o taiwncal.o buddhcal.o persncal.o islamcal.o japancal.o gregoimp.o hebrwcal.o \
72indiancal.o chnsecal.o cecal.o coptccal.o dangical.o ethpccal.o \
73coleitr.o coll.o sortkey.o bocsu.o ucoleitr.o \
74ucol.o ucol_res.o ucol_sit.o \
75collation.o collationsettings.o collationdata.o collationtailoring.o \
76collationdatareader.o collationdatawriter.o collationfcd.o \
77collationiterator.o utf16collationiterator.o utf8collationiterator.o uitercollationiterator.o \
78collationsets.o \
79collationcompare.o collationfastlatin.o collationkeys.o rulebasedcollator.o collationroot.o \
80collationrootelements.o collationdatabuilder.o \
81collationweights.o collationruleparser.o collationbuilder.o collationfastlatinbuilder.o \
82strmatch.o usearch.o search.o stsearch.o \
83translit.o utrans.o esctrn.o unesctrn.o funcrepl.o strrepl.o tridpars.o \
84cpdtrans.o rbt.o rbt_data.o rbt_pars.o rbt_rule.o rbt_set.o \
85nultrans.o remtrans.o casetrn.o titletrn.o tolowtrn.o toupptrn.o anytrans.o \
86name2uni.o uni2name.o nortrans.o quant.o transreg.o brktrans.o \
87regexcmp.o rematch.o repattrn.o regexst.o regextxt.o regeximp.o uregex.o uregexc.o \
88ulocdata.o measfmt.o currfmt.o curramt.o currunit.o measure.o utmscale.o \
89csdetect.o csmatch.o csr2022.o csrecog.o csrmbcs.o csrsbcs.o csrucode.o csrutf8.o inputext.o \
90wintzimpl.o windtfmt.o winnmfmt.o basictz.o dtrule.o rbtz.o tzrule.o tztrans.o vtzone.o zonemeta.o \
91upluralrules.o plurrule.o plurfmt.o selfmt.o dtitvfmt.o dtitvinf.o udateintervalformat.o \
92tmunit.o tmutamt.o tmutfmt.o currpinf.o \
93uspoof.o uspoof_impl.o uspoof_build.o uspoof_conf.o uspoof_wsconf.o decfmtst.o smpdtfst.o \
94ztrans.o zrule.o vzone.o fphdlimp.o fpositer.o ufieldpositer.o locdspnm.o \
95decNumber.o decContext.o alphaindex.o tznames.o tznames_impl.o tzgnames.o \
96tzfmt.o compactdecimalformat.o gender.o region.o scriptset.o identifier_info.o \
97uregion.o reldatefmt.o quantityformatter.o measunit.o \
98sharedbreakiterator.o scientificnumberformatter.o digitgrouping.o \
99digitinterval.o digitformatter.o digitaffix.o valueformatter.o \
100digitaffixesandpadding.o pluralaffix.o precision.o \
101affixpatternparser.o smallintformatter.o decimfmtimpl.o \
102visibledigits.o
103
104## Header files to install
105HEADERS = $(srcdir)/unicode/*.h
106
107STATIC_OBJECTS = $(OBJECTS:.o=.$(STATIC_O))
108
109DEPS = $(OBJECTS:.o=.d)
110
111-include Makefile.local
112
113## List of phony targets
114.PHONY : all all-local install install-local clean clean-local \
115distclean distclean-local install-library install-headers dist \
116dist-local check check-local check-exhaustive
117
118## Clear suffix list
119.SUFFIXES :
120
121## List of standard targets
122all: all-local
123install: install-local
124clean: clean-local
125distclean : distclean-local
126dist: dist-local
127check: all check-local
128
129check-exhaustive: check
130
131all-local: $(ALL_TARGETS)
132
133install-local: install-headers install-library
134
135install-library: all-local
136 $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
137ifneq ($(ENABLE_STATIC),)
138 $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
139endif
140ifneq ($(ENABLE_SHARED),)
141 $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
142ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
143 cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
144ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
145 cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
146endif
147endif
148ifneq ($(IMPORT_LIB_EXT),)
149 $(INSTALL-L) $(FINAL_IMPORT_LIB) $(DESTDIR)$(libdir)
150ifneq ($(IMPORT_LIB),$(FINAL_IMPORT_LIB))
151 cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(IMPORT_LIB))
152endif
153ifneq ($(MIDDLE_IMPORT_LIB),$(FINAL_IMPORT_LIB))
154 cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(MIDDLE_IMPORT_LIB))
155endif
156endif
157endif
158
159install-headers:
160 $(MKINSTALLDIRS) $(DESTDIR)$(includedir)/unicode
161 @for file in $(HEADERS); do \
162 echo "$(INSTALL_DATA) $$file $(DESTDIR)$(includedir)/unicode"; \
163 $(INSTALL_DATA) $$file $(DESTDIR)$(includedir)/unicode || exit; \
164 done
165
166dist-local:
167
168clean-local:
169 test -z "$(CLEANFILES)" || $(RMV) $(CLEANFILES)
170 $(RMV) $(OBJECTS) $(STATIC_OBJECTS) $(ALL_TARGETS) $(SO_VERSION_DATA)
171
172distclean-local: clean-local
173 $(RMV) Makefile
174
175check-local:
176
177Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
178 cd $(top_builddir) \
179 && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
180
181ifneq ($(ENABLE_STATIC),)
182$(TARGET): $(STATIC_OBJECTS)
183 $(AR) $(ARFLAGS) $(AR_OUTOPT)$@ $^
184 $(RANLIB) $@
185endif
186
187ifneq ($(ENABLE_SHARED),)
188$(SHARED_OBJECT): $(OBJECTS) $(SO_VERSION_DATA)
189 $(SHLIB.cc) $(LD_SONAME) $(OUTOPT)$@ $^ $(LIBS)
190ifeq ($(ENABLE_RPATH),YES)
191ifneq ($(wildcard $(libdir)/$(MIDDLE_SO_TARGET)),)
192 $(warning RPATH warning: --enable-rpath means test programs may use existing $(libdir)/$(MIDDLE_SO_TARGET))
193endif
194endif
195
196ifeq ($(OS390BATCH),1)
197$(BATCH_TARGET):$(OBJECTS)
198 $(SHLIB.cc) $(LD_SONAME) $(OUTOPT)$@ $^ $(BATCH_LIBS)
199endif # OS390BATCH
200endif # ENABLE_SHARED
201
202ifeq (,$(MAKECMDGOALS))
203-include $(DEPS)
204else
205ifneq ($(patsubst %clean,,$(MAKECMDGOALS)),)
206-include $(DEPS)
207endif
208endif
Note: See TracBrowser for help on using the repository browser.