1 | #******************************************************************************
|
---|
2 | #
|
---|
3 | # Copyright (C) 1998-2015, International Business Machines
|
---|
4 | # Corporation and others. All Rights Reserved.
|
---|
5 | #
|
---|
6 | #******************************************************************************
|
---|
7 | ## Makefile.in for ICU - icui18n.so
|
---|
8 | ## Stephen F. Booth
|
---|
9 |
|
---|
10 | ## Source directory information
|
---|
11 | srcdir = @srcdir@
|
---|
12 | top_srcdir = @top_srcdir@
|
---|
13 |
|
---|
14 | top_builddir = ..
|
---|
15 |
|
---|
16 | ## All the flags and other definitions are included here.
|
---|
17 | include $(top_builddir)/icudefs.mk
|
---|
18 |
|
---|
19 | ## Build directory information
|
---|
20 | subdir = i18n
|
---|
21 |
|
---|
22 | ## Extra files to remove for 'make clean'
|
---|
23 | CLEANFILES = *~ $(DEPS) $(IMPORT_LIB) $(MIDDLE_IMPORT_LIB) $(FINAL_IMPORT_LIB)
|
---|
24 |
|
---|
25 | ## Target information
|
---|
26 |
|
---|
27 | TARGET_STUBNAME=$(I18N_STUBNAME)
|
---|
28 |
|
---|
29 | ifneq ($(ENABLE_STATIC),)
|
---|
30 | TARGET = $(LIBDIR)/$(LIBSICU)$(TARGET_STUBNAME)$(ICULIBSUFFIX).$(A)
|
---|
31 | endif
|
---|
32 |
|
---|
33 | ifneq ($(ENABLE_SHARED),)
|
---|
34 | SO_TARGET = $(LIBDIR)/$(LIBICU)$(TARGET_STUBNAME)$(ICULIBSUFFIX).$(SO)
|
---|
35 | ALL_SO_TARGETS = $(SO_TARGET) $(MIDDLE_SO_TARGET) $(FINAL_SO_TARGET) $(SHARED_OBJECT)
|
---|
36 |
|
---|
37 | ifeq ($(ENABLE_SO_VERSION_DATA),1)
|
---|
38 | SO_VERSION_DATA = i18n.res
|
---|
39 | endif
|
---|
40 |
|
---|
41 | ifeq ($(OS390BATCH),1)
|
---|
42 | BATCH_TARGET = $(BATCH_I18N_TARGET)
|
---|
43 | BATCH_LIBS = $(BATCH_LIBICUUC) -lm
|
---|
44 | endif # OS390BATCH
|
---|
45 |
|
---|
46 | endif # ENABLE_SHARED
|
---|
47 |
|
---|
48 | ALL_TARGETS = $(TARGET) $(ALL_SO_TARGETS) $(BATCH_TARGET)
|
---|
49 |
|
---|
50 | DYNAMICCPPFLAGS = $(SHAREDLIBCPPFLAGS)
|
---|
51 | DYNAMICCFLAGS = $(SHAREDLIBCFLAGS)
|
---|
52 | DYNAMICCXXFLAGS = $(SHAREDLIBCXXFLAGS)
|
---|
53 | CFLAGS += $(LIBCFLAGS)
|
---|
54 | CXXFLAGS += $(LIBCXXFLAGS)
|
---|
55 | ifeq ($(OS390BATCH),1)
|
---|
56 | CFLAGS += -WI
|
---|
57 | CXXFLAGS += -WI
|
---|
58 | endif
|
---|
59 |
|
---|
60 | CPPFLAGS += -I$(srcdir) -I$(top_srcdir)/common $(LIBCPPFLAGS) $(CPPFLAGSICUI18N)
|
---|
61 | DEFS += -DU_I18N_IMPLEMENTATION
|
---|
62 | LDFLAGS += $(LDFLAGSICUI18N)
|
---|
63 | LIBS = $(LIBICUUC) $(DEFAULT_LIBS)
|
---|
64 |
|
---|
65 | OBJECTS = ucln_in.o \
|
---|
66 | fmtable.o format.o msgfmt.o umsg.o numfmt.o unum.o decimfmt.o decimalformatpattern.o dcfmtsym.o \
|
---|
67 | ucurr.o digitlst.o fmtable_cnv.o \
|
---|
68 | choicfmt.o datefmt.o smpdtfmt.o reldtfmt.o dtfmtsym.o udat.o dtptngen.o udatpg.o \
|
---|
69 | nfrs.o nfrule.o nfsubs.o rbnf.o numsys.o unumsys.o ucsdet.o \
|
---|
70 | ucal.o calendar.o gregocal.o timezone.o simpletz.o olsontz.o \
|
---|
71 | astro.o taiwncal.o buddhcal.o persncal.o islamcal.o japancal.o gregoimp.o hebrwcal.o \
|
---|
72 | indiancal.o chnsecal.o cecal.o coptccal.o dangical.o ethpccal.o \
|
---|
73 | coleitr.o coll.o sortkey.o bocsu.o ucoleitr.o \
|
---|
74 | ucol.o ucol_res.o ucol_sit.o \
|
---|
75 | collation.o collationsettings.o collationdata.o collationtailoring.o \
|
---|
76 | collationdatareader.o collationdatawriter.o collationfcd.o \
|
---|
77 | collationiterator.o utf16collationiterator.o utf8collationiterator.o uitercollationiterator.o \
|
---|
78 | collationsets.o \
|
---|
79 | collationcompare.o collationfastlatin.o collationkeys.o rulebasedcollator.o collationroot.o \
|
---|
80 | collationrootelements.o collationdatabuilder.o \
|
---|
81 | collationweights.o collationruleparser.o collationbuilder.o collationfastlatinbuilder.o \
|
---|
82 | strmatch.o usearch.o search.o stsearch.o \
|
---|
83 | translit.o utrans.o esctrn.o unesctrn.o funcrepl.o strrepl.o tridpars.o \
|
---|
84 | cpdtrans.o rbt.o rbt_data.o rbt_pars.o rbt_rule.o rbt_set.o \
|
---|
85 | nultrans.o remtrans.o casetrn.o titletrn.o tolowtrn.o toupptrn.o anytrans.o \
|
---|
86 | name2uni.o uni2name.o nortrans.o quant.o transreg.o brktrans.o \
|
---|
87 | regexcmp.o rematch.o repattrn.o regexst.o regextxt.o regeximp.o uregex.o uregexc.o \
|
---|
88 | ulocdata.o measfmt.o currfmt.o curramt.o currunit.o measure.o utmscale.o \
|
---|
89 | csdetect.o csmatch.o csr2022.o csrecog.o csrmbcs.o csrsbcs.o csrucode.o csrutf8.o inputext.o \
|
---|
90 | wintzimpl.o windtfmt.o winnmfmt.o basictz.o dtrule.o rbtz.o tzrule.o tztrans.o vtzone.o zonemeta.o \
|
---|
91 | upluralrules.o plurrule.o plurfmt.o selfmt.o dtitvfmt.o dtitvinf.o udateintervalformat.o \
|
---|
92 | tmunit.o tmutamt.o tmutfmt.o currpinf.o \
|
---|
93 | uspoof.o uspoof_impl.o uspoof_build.o uspoof_conf.o uspoof_wsconf.o decfmtst.o smpdtfst.o \
|
---|
94 | ztrans.o zrule.o vzone.o fphdlimp.o fpositer.o ufieldpositer.o locdspnm.o \
|
---|
95 | decNumber.o decContext.o alphaindex.o tznames.o tznames_impl.o tzgnames.o \
|
---|
96 | tzfmt.o compactdecimalformat.o gender.o region.o scriptset.o identifier_info.o \
|
---|
97 | uregion.o reldatefmt.o quantityformatter.o measunit.o \
|
---|
98 | sharedbreakiterator.o scientificnumberformatter.o digitgrouping.o \
|
---|
99 | digitinterval.o digitformatter.o digitaffix.o valueformatter.o \
|
---|
100 | digitaffixesandpadding.o pluralaffix.o precision.o \
|
---|
101 | affixpatternparser.o smallintformatter.o decimfmtimpl.o \
|
---|
102 | visibledigits.o
|
---|
103 |
|
---|
104 | ## Header files to install
|
---|
105 | HEADERS = $(srcdir)/unicode/*.h
|
---|
106 |
|
---|
107 | STATIC_OBJECTS = $(OBJECTS:.o=.$(STATIC_O))
|
---|
108 |
|
---|
109 | DEPS = $(OBJECTS:.o=.d)
|
---|
110 |
|
---|
111 | -include Makefile.local
|
---|
112 |
|
---|
113 | ## List of phony targets
|
---|
114 | .PHONY : all all-local install install-local clean clean-local \
|
---|
115 | distclean distclean-local install-library install-headers dist \
|
---|
116 | dist-local check check-local check-exhaustive
|
---|
117 |
|
---|
118 | ## Clear suffix list
|
---|
119 | .SUFFIXES :
|
---|
120 |
|
---|
121 | ## List of standard targets
|
---|
122 | all: all-local
|
---|
123 | install: install-local
|
---|
124 | clean: clean-local
|
---|
125 | distclean : distclean-local
|
---|
126 | dist: dist-local
|
---|
127 | check: all check-local
|
---|
128 |
|
---|
129 | check-exhaustive: check
|
---|
130 |
|
---|
131 | all-local: $(ALL_TARGETS)
|
---|
132 |
|
---|
133 | install-local: install-headers install-library
|
---|
134 |
|
---|
135 | install-library: all-local
|
---|
136 | $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
|
---|
137 | ifneq ($(ENABLE_STATIC),)
|
---|
138 | $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
|
---|
139 | endif
|
---|
140 | ifneq ($(ENABLE_SHARED),)
|
---|
141 | $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
|
---|
142 | ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
|
---|
143 | cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
|
---|
144 | ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
|
---|
145 | cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
|
---|
146 | endif
|
---|
147 | endif
|
---|
148 | ifneq ($(IMPORT_LIB_EXT),)
|
---|
149 | $(INSTALL-L) $(FINAL_IMPORT_LIB) $(DESTDIR)$(libdir)
|
---|
150 | ifneq ($(IMPORT_LIB),$(FINAL_IMPORT_LIB))
|
---|
151 | cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(IMPORT_LIB))
|
---|
152 | endif
|
---|
153 | ifneq ($(MIDDLE_IMPORT_LIB),$(FINAL_IMPORT_LIB))
|
---|
154 | cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(MIDDLE_IMPORT_LIB))
|
---|
155 | endif
|
---|
156 | endif
|
---|
157 | endif
|
---|
158 |
|
---|
159 | install-headers:
|
---|
160 | $(MKINSTALLDIRS) $(DESTDIR)$(includedir)/unicode
|
---|
161 | @for file in $(HEADERS); do \
|
---|
162 | echo "$(INSTALL_DATA) $$file $(DESTDIR)$(includedir)/unicode"; \
|
---|
163 | $(INSTALL_DATA) $$file $(DESTDIR)$(includedir)/unicode || exit; \
|
---|
164 | done
|
---|
165 |
|
---|
166 | dist-local:
|
---|
167 |
|
---|
168 | clean-local:
|
---|
169 | test -z "$(CLEANFILES)" || $(RMV) $(CLEANFILES)
|
---|
170 | $(RMV) $(OBJECTS) $(STATIC_OBJECTS) $(ALL_TARGETS) $(SO_VERSION_DATA)
|
---|
171 |
|
---|
172 | distclean-local: clean-local
|
---|
173 | $(RMV) Makefile
|
---|
174 |
|
---|
175 | check-local:
|
---|
176 |
|
---|
177 | Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
---|
178 | cd $(top_builddir) \
|
---|
179 | && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
|
---|
180 |
|
---|
181 | ifneq ($(ENABLE_STATIC),)
|
---|
182 | $(TARGET): $(STATIC_OBJECTS)
|
---|
183 | $(AR) $(ARFLAGS) $(AR_OUTOPT)$@ $^
|
---|
184 | $(RANLIB) $@
|
---|
185 | endif
|
---|
186 |
|
---|
187 | ifneq ($(ENABLE_SHARED),)
|
---|
188 | $(SHARED_OBJECT): $(OBJECTS) $(SO_VERSION_DATA)
|
---|
189 | $(SHLIB.cc) $(LD_SONAME) $(OUTOPT)$@ $^ $(LIBS)
|
---|
190 | ifeq ($(ENABLE_RPATH),YES)
|
---|
191 | ifneq ($(wildcard $(libdir)/$(MIDDLE_SO_TARGET)),)
|
---|
192 | $(warning RPATH warning: --enable-rpath means test programs may use existing $(libdir)/$(MIDDLE_SO_TARGET))
|
---|
193 | endif
|
---|
194 | endif
|
---|
195 |
|
---|
196 | ifeq ($(OS390BATCH),1)
|
---|
197 | $(BATCH_TARGET):$(OBJECTS)
|
---|
198 | $(SHLIB.cc) $(LD_SONAME) $(OUTOPT)$@ $^ $(BATCH_LIBS)
|
---|
199 | endif # OS390BATCH
|
---|
200 | endif # ENABLE_SHARED
|
---|
201 |
|
---|
202 | ifeq (,$(MAKECMDGOALS))
|
---|
203 | -include $(DEPS)
|
---|
204 | else
|
---|
205 | ifneq ($(patsubst %clean,,$(MAKECMDGOALS)),)
|
---|
206 | -include $(DEPS)
|
---|
207 | endif
|
---|
208 | endif
|
---|