1 | # -*- coding: utf-8 -*-
|
---|
2 | # gnupg -- gnu privacy guard
|
---|
3 | # This is a template. The dist target uses it to create the real file.
|
---|
4 | #
|
---|
5 | %define version 1.4.9
|
---|
6 | %define name gnupg
|
---|
7 | Summary: GNU Utility for data encryption and digital signatures
|
---|
8 | Summary(it): Utility GNU per la sicurezza nelle comunicazioni e nell'archiviazione dei dati.
|
---|
9 | Summary(cs): GNU nástroj pro ¹ifrovanou komunikaci a bezpeÚné ukládánà dat
|
---|
10 | Summary(fr): Utilitaire GNU de chiffrement et d'authentification des communications et des données
|
---|
11 | Summary(pl): Narzêdzie GNU do szyfrowania i podpisywania danych
|
---|
12 | Vendor: GNU Privacy Guard Project
|
---|
13 | Name: %{name}
|
---|
14 | Version: %{version}
|
---|
15 | Release: 1
|
---|
16 | Copyright: GPL
|
---|
17 | Group: Applications/Cryptography
|
---|
18 | Group(cs): Aplikace/©ifrovánÃ
|
---|
19 | Group(fr): Applications/Cryptographie
|
---|
20 | Group(it): Applicazioni/Crittografia
|
---|
21 | Source: ftp://ftp.gnupg.org/gcrypt/gnupg/%{name}-%{version}.tar.gz
|
---|
22 | URL: http://www.gnupg.org/
|
---|
23 | Provides: gpg openpgp
|
---|
24 | Requires(post,preun): /sbin/install-info
|
---|
25 | BuildRoot: %{_tmppath}/rpmbuild_%{name}-%{version}
|
---|
26 |
|
---|
27 | %changelog
|
---|
28 | * Sun Aug 21 2005 David Shaw <dshaw@jabberwocky.com>
|
---|
29 | - Distribute gpg-zip.
|
---|
30 |
|
---|
31 | * Fri Apr 22 2005 David Shaw <dshaw@jabberwocky.com>
|
---|
32 | - No longer any need to override libexecdir. The makefiles now
|
---|
33 | calculate this correctly internally.
|
---|
34 |
|
---|
35 | * Wed Feb 16 2005 David Shaw <dshaw@jabberwocky.com>
|
---|
36 | - Fix problem with storing the gpgkeys helpers in libexec, but calling
|
---|
37 | them in libexec/gnupg.
|
---|
38 |
|
---|
39 | * Wed Jul 30 2003 David Shaw <dshaw@jabberwocky.com>
|
---|
40 | - Rework much of the spec to use %-macros throughout.
|
---|
41 | - Fix to work properly with RPM 4.1 (all files in buildroot must be packaged)
|
---|
42 | - Package and install info files.
|
---|
43 | - Tweak the English description.
|
---|
44 | - There is no need to install gpgv and gpgsplit setuid root.
|
---|
45 |
|
---|
46 | * Sat Nov 30 2002 David Shaw <dshaw@jabberwocky.com>
|
---|
47 | - Add convert-from-106 script
|
---|
48 |
|
---|
49 | * Sat Oct 26 2002 David Shaw <dshaw@jabberwocky.com>
|
---|
50 | - Use new path for keyserver helpers.
|
---|
51 | - /usr/lib is no longer used for cipher/hash plugins.
|
---|
52 | - Include gpgv, gpgsplit, and the new gnupg.7 man page.
|
---|
53 |
|
---|
54 | * Fri Apr 19 2002 David Shaw <dshaw@jabberwocky.com>
|
---|
55 | - Removed OPTIONS and pubring.asc - no longer used
|
---|
56 | - Added doc/samplekeys.asc
|
---|
57 |
|
---|
58 | * Sun Mar 31 2002 David Shaw <dshaw@jabberwocky.com>
|
---|
59 | - Added the gpgkeys_xxx keyserver helpers.
|
---|
60 | - Added a * to catch variations on the basic gpg man page (gpg, gpgv).
|
---|
61 | - Mark options.skel as a config file.
|
---|
62 | - Do not include the FAQ/faq.html twice (in /doc/ and /share/).
|
---|
63 |
|
---|
64 | * Wed Sep 06 2000 Fabio Coatti <cova@ferrara.linux.it>
|
---|
65 | - Added Polish description and summary (Kindly provided by
|
---|
66 | Lukasz Stelmach <stelmacl@ee.pw.edu.pl>)
|
---|
67 |
|
---|
68 | * Thu Jul 13 2000 Fabio Coatti <cova@ferrara.linux.it>
|
---|
69 | - Added a * to catch all formats for man pages (plain, gz, bz2...)
|
---|
70 |
|
---|
71 | * Mon May 01 2000 Fabio Coatti <cova@ferrara.linux.it>
|
---|
72 | - Some corrections in French description, thanks to Gaël Quéri
|
---|
73 | <gqueri@mail.dotcom.fr>; Some corrections to Italian descriptions.
|
---|
74 |
|
---|
75 | * Tue Apr 25 2000 Fabio Coatti <cova@ferrara.linux.it>
|
---|
76 | - Removed the no longer needed patch for man page by Keith Owens
|
---|
77 |
|
---|
78 | * Wed Mar 1 2000 Petr Kri¹tof <Petr@Kristof.CZ>
|
---|
79 | - Czech descriptions added; some fixes and updates.
|
---|
80 |
|
---|
81 | * Sat Jan 15 2000 Keith Owens <kaos@ocs.com.au>
|
---|
82 | - Add missing man page as separate patch instead of updating the tar file.
|
---|
83 |
|
---|
84 | * Mon Dec 27 1999 Fabio Coatti <cova@ferrara.linux.it>
|
---|
85 | - Upgraded for 1.0.1 (added missing gpg.1 man page)
|
---|
86 |
|
---|
87 | * Sat May 29 1999 Fabio Coatti <cova@ferrara.linux.it>
|
---|
88 | - Some corrections in French description, thanks to Gaël Quéri <gqueri@mail.dotcom.fr>
|
---|
89 |
|
---|
90 | * Mon May 17 1999 Fabio Coatti <cova@felix.unife.it>
|
---|
91 | - Added French description, provided by
|
---|
92 | Christophe Labouisse <labouiss@cybercable.fr>
|
---|
93 |
|
---|
94 | * Thu May 06 1999 Fabio Coatti <cova@felix.unife.it>
|
---|
95 | - Upgraded for 0.9.6 (removed gpgm)
|
---|
96 |
|
---|
97 | * Tue Jan 12 1999 Fabio Coatti <cova@felix.unife.it>
|
---|
98 | - LINGUAS variable is now unset in configure to ensure that all languages will be built. (Thanks to Luca Olivetti <luca@luca.ddns.org>)
|
---|
99 |
|
---|
100 | * Sat Jan 02 1999 Fabio Coatti <cova@felix.unife.it>
|
---|
101 | - Added pl language file.
|
---|
102 | - Included g10/pubring.asc in documentation files.
|
---|
103 |
|
---|
104 | * Sat Dec 19 1998 Fabio Coatti <cova@felix.unife.it>
|
---|
105 | - Modified the spec file provided by Caskey L. Dickson <caskey-at-technocage.com>
|
---|
106 | - Now it can be built also by non-root. Installation has to be done as
|
---|
107 | root, gpg is suid.
|
---|
108 | - Added some changes by Ross Golder <rossigee@bigfoot.com>
|
---|
109 | - Updates for version 0.4.5 of GnuPG (.mo files)
|
---|
110 |
|
---|
111 | %description
|
---|
112 |
|
---|
113 | GnuPG (GNU Privacy Guard) is a GNU utility for encrypting data and
|
---|
114 | creating digital signatures. GnuPG has advanced key management
|
---|
115 | capabilities and is compliant with the proposed OpenPGP Internet
|
---|
116 | standard described in RFC-2440. Since GnuPG doesn't use any patented
|
---|
117 | algorithms, it is not compatible with some versions of PGP 2 which use
|
---|
118 | only the patented IDEA algorithm. See
|
---|
119 | http://www.gnupg.org/why-not-idea.html for information on using IDEA
|
---|
120 | if the patent does not apply to you and you need to be compatible with
|
---|
121 | these versions of PGP 2.
|
---|
122 |
|
---|
123 | %description -l it
|
---|
124 | GnuPG (GNU Privacy Guard) Ú una utility GNU per la cifratura di dati e
|
---|
125 | la creazione di firme digitali. Possiede una gestione avanzata delle
|
---|
126 | chiavi ed Ú conforme allo standard Internet OpenPGP, descritto nella
|
---|
127 | RFC 2440. Non utilizzando algoritmi brevettati, non Ú compatibile con
|
---|
128 | PGP2 (PGP2.x usa solo IDEA, coperto da brevetto mondiale, ed RSA,
|
---|
129 | brevettato negli USA con scadenza 20/09/2000). Questi algoritmi sono
|
---|
130 | utilizzabili da GnuPG tramite moduli esterni.
|
---|
131 |
|
---|
132 | %description -l fr
|
---|
133 | GnuPG est un utilitaire GNU destiné à chiffrer des données et à créer
|
---|
134 | des signatures électroniques. Il a des capacités avancées de gestion de
|
---|
135 | clés et il est conforme à la norme proposée OpenPGP décrite dans la
|
---|
136 | RFC2440. Comme GnuPG n'utilise pas d'algorithme breveté, il n'est
|
---|
137 | compatible avec aucune version de PGP2 (PGP2.x ne sait utiliser que
|
---|
138 | l'IDEA breveté dans le monde entier et RSA, breveté aux Ãtats-Unis
|
---|
139 | jusqu'au 20 septembre 2000).
|
---|
140 |
|
---|
141 | %description -l cs
|
---|
142 | GnuPG je GNU nástroj pro bezpeÚnou komunikaci a ukládánà dat. MùŸe bÜt
|
---|
143 | pouŸit na ¹ifrovánà dat a vytváÞenà digitálnÃch podpisù. Obsahuje
|
---|
144 | funkce pro pokroÚilou správu klÃÚù a vyhovuje navrhovanému OpenPGP
|
---|
145 | Internet standardu podle RFC2440. Byl vytvoÞen jako kompletnÃ
|
---|
146 | náhrada za PGP. ProtoŸe neobsahuje ¹ifrovacà algoritmy IDEA nebo RSA,
|
---|
147 | mùŸe bÃœt pouŸÃván bez omezenÃ.
|
---|
148 | ProtoŸe GnuPG nepouŸÃvá ŸádnÃœ patentovanÃœ algoritmus, nemùŸe bÃœt úplnì
|
---|
149 | kompatibilnà s PGP verze 2. PGP 2.x pouŸÃvá algoritmy IDEA (patentováno
|
---|
150 | celosvìtovì) a RSA (patentováno ve SpojenÃœch státech do 20. záÞÃ
|
---|
151 | 2000). Tyto algoritmy lze zavést do GnuPG pomocà externÃch modulù.
|
---|
152 |
|
---|
153 | %description -l pl
|
---|
154 | GnuPG (GNU Privacy Guard) jest narzÄdziem do szyfrowania danych i tworzenia
|
---|
155 | cyfrowych podpisów. GnuPG posiada zaawansowane moÅŒliwoÅci obsÅugi kluczy
|
---|
156 | i jest zgodne z proponowanym standardem internetowym OpenPGP, opisanym
|
---|
157 | w RFC2440. PoniewaŌ GnuPG nie uŌywa Ōadnych opatentowanych algorytmów,
|
---|
158 | nie jest zgodne z jakÄ
|
---|
159 | kolwiek wersjÄ
|
---|
160 | PGP2 (PGP2.x korzysta jedynie
|
---|
161 | z algorytmów: IDEA, opatentowanego na calym Åwiecie oraz RSA, którego
|
---|
162 | patent na terenie Stanów Zjednoczonych wygasa 20. wrzeÅnia 2000).
|
---|
163 |
|
---|
164 | %prep
|
---|
165 | rm -rf $RPM_BUILD_ROOT
|
---|
166 |
|
---|
167 | %setup
|
---|
168 |
|
---|
169 | %build
|
---|
170 | if test -n "$LINGUAS"; then
|
---|
171 | unset LINGUAS
|
---|
172 | fi
|
---|
173 | %configure --program-prefix=%{?_program_prefix:%{_program_prefix}}
|
---|
174 | make
|
---|
175 |
|
---|
176 | %install
|
---|
177 | %makeinstall
|
---|
178 | %find_lang %{name}
|
---|
179 | rm %{buildroot}%{_datadir}/%{name}/FAQ
|
---|
180 | rm %{buildroot}%{_datadir}/%{name}/faq.html
|
---|
181 | rm -f %{buildroot}%{_infodir}/dir
|
---|
182 |
|
---|
183 | %files -f %{name}.lang
|
---|
184 | %defattr (-,root,root)
|
---|
185 |
|
---|
186 | %doc INSTALL AUTHORS COPYING NEWS README THANKS TODO PROJECTS doc/DETAILS
|
---|
187 | %doc doc/FAQ doc/faq.html doc/HACKING doc/OpenPGP doc/samplekeys.asc
|
---|
188 | %doc %attr (0755,root,root) tools/convert-from-106
|
---|
189 | %config %{_datadir}/%{name}/options.skel
|
---|
190 | %{_mandir}/man1/*
|
---|
191 | %{_mandir}/man7/*
|
---|
192 | %{_infodir}/gnupg1.info*
|
---|
193 | %attr (4755,root,root) %{_bindir}/gpg
|
---|
194 | %attr (0755,root,root) %{_bindir}/gpgv
|
---|
195 | %attr (0755,root,root) %{_bindir}/gpgsplit
|
---|
196 | %attr (0755,root,root) %{_bindir}/gpg-zip
|
---|
197 | %attr (0755,root,root) %{_libexecdir}/gnupg/*
|
---|
198 |
|
---|
199 | %post
|
---|
200 | /sbin/install-info %{_infodir}/gpg.info %{_infodir}/dir 2>/dev/null || :
|
---|
201 | /sbin/install-info %{_infodir}/gpgv.info %{_infodir}/dir 2>/dev/null || :
|
---|
202 |
|
---|
203 | %preun
|
---|
204 | if [ $1 = 0 ]; then
|
---|
205 | /sbin/install-info --delete %{_infodir}/gpg.info \
|
---|
206 | %{_infodir}/dir 2>/dev/null || :
|
---|
207 | /sbin/install-info --delete %{_infodir}/gpgv.info \
|
---|
208 | %{_infodir}/dir 2>/dev/null || :
|
---|
209 | fi
|
---|
210 |
|
---|
211 | %clean
|
---|
212 | rm -rf $RPM_BUILD_ROOT
|
---|
213 | rm -rf $RPM_BUILD_DIR/%{name}-%{version}
|
---|