1 | ## Process this file with automake to generate Makefile.in
|
---|
2 | #
|
---|
3 | # Copyright (C) 2012-2016 Free Software Foundation, Inc.
|
---|
4 | #
|
---|
5 | # This file is free software; you can redistribute it and/or modify
|
---|
6 | # it under the terms of the GNU General Public License as published by
|
---|
7 | # the Free Software Foundation; either version 3 of the License, or
|
---|
8 | # (at your option) any later version.
|
---|
9 | #
|
---|
10 | # This program is distributed in the hope that it will be useful,
|
---|
11 | # but WITHOUT ANY WARRANTY; without even the implied warranty of
|
---|
12 | # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
---|
13 | # GNU General Public License for more details.
|
---|
14 | #
|
---|
15 | # You should have received a copy of the GNU General Public License
|
---|
16 | # along with this program; see the file COPYING3. If not see
|
---|
17 | # <http://www.gnu.org/licenses/>.
|
---|
18 | #
|
---|
19 |
|
---|
20 | AUTOMAKE_OPTIONS = 1.8
|
---|
21 |
|
---|
22 | # What version of the manual you want; "all" includes everything
|
---|
23 | CONFIG=all
|
---|
24 |
|
---|
25 | # Options to extract the man page from as.texinfo
|
---|
26 | MANCONF = -Dman
|
---|
27 |
|
---|
28 | TEXI2POD = perl $(BASEDIR)/etc/texi2pod.pl $(AM_MAKEINFOFLAGS)
|
---|
29 |
|
---|
30 | POD2MAN = pod2man --center="GNU Development Tools" \
|
---|
31 | --release="binutils-$(VERSION)" --section=1
|
---|
32 |
|
---|
33 | man_MANS = as.1
|
---|
34 |
|
---|
35 | info_TEXINFOS = as.texinfo
|
---|
36 | as_TEXINFOS = asconfig.texi $(CPU_DOCS)
|
---|
37 |
|
---|
38 | AM_MAKEINFOFLAGS = -I "$(srcdir)" -I "$(top_srcdir)/../libiberty" \
|
---|
39 | -I "$(top_srcdir)/../bfd/doc" -I ../../bfd/doc
|
---|
40 | TEXI2DVI = texi2dvi -I "$(srcdir)" -I "$(top_srcdir)/../libiberty" \
|
---|
41 | -I "$(top_srcdir)/../bfd/doc" -I ../../bfd/doc
|
---|
42 |
|
---|
43 | asconfig.texi: $(CONFIG).texi
|
---|
44 | rm -f asconfig.texi
|
---|
45 | cp $(srcdir)/$(CONFIG).texi ./asconfig.texi
|
---|
46 | chmod u+w ./asconfig.texi
|
---|
47 |
|
---|
48 | CPU_DOCS = \
|
---|
49 | c-aarch64.texi \
|
---|
50 | c-alpha.texi \
|
---|
51 | c-arc.texi \
|
---|
52 | c-arm.texi \
|
---|
53 | c-avr.texi \
|
---|
54 | c-bfin.texi \
|
---|
55 | c-cr16.texi \
|
---|
56 | c-cris.texi \
|
---|
57 | c-d10v.texi \
|
---|
58 | c-epiphany.texi \
|
---|
59 | c-h8300.texi \
|
---|
60 | c-hppa.texi \
|
---|
61 | c-i370.texi \
|
---|
62 | c-i386.texi \
|
---|
63 | c-i860.texi \
|
---|
64 | c-i960.texi \
|
---|
65 | c-ip2k.texi \
|
---|
66 | c-lm32.texi \
|
---|
67 | c-m32c.texi \
|
---|
68 | c-m32r.texi \
|
---|
69 | c-m68hc11.texi \
|
---|
70 | c-m68k.texi \
|
---|
71 | c-metag.texi \
|
---|
72 | c-microblaze.texi \
|
---|
73 | c-mips.texi \
|
---|
74 | c-mmix.texi \
|
---|
75 | c-mt.texi \
|
---|
76 | c-msp430.texi \
|
---|
77 | c-nios2.texi \
|
---|
78 | c-nds32.texi \
|
---|
79 | c-ns32k.texi \
|
---|
80 | c-pdp11.texi \
|
---|
81 | c-pj.texi \
|
---|
82 | c-ppc.texi \
|
---|
83 | c-rl78.texi \
|
---|
84 | c-rx.texi \
|
---|
85 | c-s390.texi \
|
---|
86 | c-score.texi \
|
---|
87 | c-sh.texi \
|
---|
88 | c-sh64.texi \
|
---|
89 | c-sparc.texi \
|
---|
90 | c-tic54x.texi \
|
---|
91 | c-tic6x.texi \
|
---|
92 | c-tilegx.texi \
|
---|
93 | c-tilepro.texi \
|
---|
94 | c-v850.texi \
|
---|
95 | c-vax.texi \
|
---|
96 | c-visium.texi \
|
---|
97 | c-xgate.texi \
|
---|
98 | c-xstormy16.texi \
|
---|
99 | c-xtensa.texi \
|
---|
100 | c-z80.texi \
|
---|
101 | c-z8k.texi
|
---|
102 |
|
---|
103 | # We want install to imply install-info as per GNU standards, despite the
|
---|
104 | # cygnus option.
|
---|
105 | install-data-local: install-info
|
---|
106 |
|
---|
107 | # This one isn't ready for prime time yet. Not even a little bit.
|
---|
108 |
|
---|
109 | noinst_TEXINFOS = internals.texi
|
---|
110 |
|
---|
111 | MAINTAINERCLEANFILES = asconfig.texi
|
---|
112 |
|
---|
113 | BASEDIR = $(srcdir)/../..
|
---|
114 | BFDDIR = $(BASEDIR)/bfd
|
---|
115 |
|
---|
116 | # Maintenance
|
---|
117 |
|
---|
118 | # We need it for the taz target in ../../Makefile.in.
|
---|
119 | info-local: $(MANS)
|
---|
120 |
|
---|
121 | # Build the man page from the texinfo file
|
---|
122 | # The sed command removes the no-adjust Nroff command so that
|
---|
123 | # the man output looks standard.
|
---|
124 | as.1: $(srcdir)/as.texinfo asconfig.texi $(CPU_DOCS)
|
---|
125 | touch $@
|
---|
126 | -$(TEXI2POD) $(MANCONF) < $(srcdir)/as.texinfo > as.pod
|
---|
127 | -($(POD2MAN) as.pod | \
|
---|
128 | sed -e '/^.if n .na/d' > $@.T$$$$ && \
|
---|
129 | mv -f $@.T$$$$ $@) || \
|
---|
130 | (rm -f $@.T$$$$ && exit 1)
|
---|
131 | rm -f as.pod
|
---|
132 |
|
---|
133 | MAINTAINERCLEANFILES += as.info
|
---|
134 |
|
---|
135 | # Automake 1.9 will only build info files in the objdir if they are
|
---|
136 | # mentioned in DISTCLEANFILES. It doesn't have to be unconditional,
|
---|
137 | # though, so we use a bogus condition.
|
---|
138 | if GENINSRC_NEVER
|
---|
139 | DISTCLEANFILES = as.info
|
---|
140 | endif
|
---|