source: trunk/Lucide/readme_it.txt

Last change on this file was 701, checked in by Gregg Young, 3 years ago

Updated make files and documentation for 1.41 GA

File size: 4.9 KB
Line 
1:: Lucide ::
2
3Lucide e' un visualizzatore di documenti basato su plugin, con supporto per molteplici formati di files.
4
5Fornisce un'architettura plugin basata su SOM che consente a programmatori di terze parti di aggiungere
6facilmente ulteriori plugins.
7
8
9:: Plugins ::
10
11   Estensioni supportate         Caratteristiche supportate
12  --------------------------------------------------------------------------
13         PDF                   Ridimensionamento, Rotazione, Navigazione,
14                               Selezione testo, Ricerca, Rendering asincrono,
15                               Stampa PostScript
16
17         DJVU                  Ridimensionamento, Stampa PostScript
18
19         JPG                   Ridimensionamento
20  --------------------------------------------------------------------------
21
22
23:: Requisiti ::
24
25Lucide richiede i seguenti pacchetti per il suo funzionamento:
26
27  - libc 0.6.6:
28    - http://rpm.netlabs.org/release/00/zip/libc-0_6_6-38_oc00.zip (format zip)
29      or ftp://ftp.netlabs.org/pub/gcc/libc-0_6_6-csd6.wpi (formato WarpIn)
30      or "yum install libc" (from the netlabs-rel repository)
31  - libcx 0.6.3
32    - http://rpm.netlabs.org/release/00/zip/libcx-0_6_4-1_oc00.zip (zip format)
33       or "yum install libcx" (from the netlabs-rel repository)
34  - gcc492.dll:
35    - ftp://ftp.netlabs.org/pub/gcc/gcc4core-1_3_1.wpi (formato WarpIn)
36      or "yum install libgcc1 libgcc-fwd" (from the netlabs-rel repository)
37
38For rendering PDFs, Lucide's plugin requires the following:
39
40    - poppler 0.59.0:
41    - "yum install poppler" (from the netlabs-rel repository)
42   
43For rendering DjVu files, Lucide's plugin requires the following:
44
45    - djvulibre 3.5.27:
46    - "yum install djvulibre" (from the netlabs-rel repository)
47   
48For rendering multiple bitmap format files (GBM), Lucide's plugin
49requires the following:
50
51    - GBMDLL 1.76:
52    - "yum install GBMDLL" (from the netlabs-rel repository)
53    - Installed by default on ArcaOS 5.0.3 and higher
54
55For rendering JPEGs, Lucide's plugin requires the following:
56
57    - libjpeg 8d:
58    - "yum install libjpeg" (from the netlabs-rel repository)
59    - Only needed if you install the JPG plugin GBM provides JPG support
60    - You should not install  JPG and GBM at the same time. (GBM is recommended)
61
62Opzionale: per inserire testo unicode dagli appunti in formato compatibile
63Openoffice.org, e' necessario installare il pacchetto UClip (supporto appunti
64avanzato per OS/2, installato automaticamente in eComStation 2.0 RC1 e successive):
65
66  - http://hobbes.nmsu.edu/cgi-bin/h-search?key=UClip
67
68La stampa PostScript richiede una stampante abilitata alla gestione di dati
69PostScript (pscript.drv).
70
71Per vedere una lista completa di tutte le caratteristiche supportate, consultare
72il servizio TRAC per Lucide all'indirizzo web:
73
74  http://svn.netlabs.org/lucide/
75
76Per segnalare un eventuale bug riscontrato, comunicarlo utilizzando il servizio
77TRAC, vedere:
78
79  http://svn.netlabs.org/lucide/newticket
80
81Assicuratevi di selezionare la versione corretta ed il componente esatto per il
82vostro ticket!.
83
84
85
86:: Problemi conosciuti/limitazioni ::
87
88Generale: stampa pagine pari/dispari non disponibile per stampanti postscript.
89          ( http://svn.netlabs.org/lucide/ticket/87#comment:4 )
90
91
92:: Comandi Pipe ::
93
94La prima istanza di Lucide crea una named pipe chiamata \PIPE\LUCIDE.
95E' possibile inviare i seguenti comandi a tale pipe:
96
97$prev              - vai alla pagina precedente
98$next              - vai alla pagina successiva
99$presentation      - vai a tutto schermo (anche se minimizzato)
100$minimize          - minimizza Lucide (anche se a tutto schermo)
101$rotate            - ruota 90 gradi in senso orario
102$zoomin            - ingrandisci vista
103$zoomout           - riduci vista
104$zoomoriginal      - zoom al livello originale
105
106Questi comandi possono essere utili per il controllo remoto di una
107presentazione.
108
109
110:: Licenza fino alla versione 1.21 ::
111
112La licenza di Lucide 1.21 e precedenti ne consente l'utilizzo solo con eComStation.
113Non e' consentita la distribuzione del prodotto su servers Internet aperti al
114pubblico o tramite analogo altro sistema disponibile.
115
116
117:: Licenza dalla versione 1.3.0 e successive ::
118
119A partire dalla versione 1.3.0, Mensys BV e Serenity Systems International
120hanno acconsentito a pubblicare Lucide sotto licenza opensource, pur continuando
121ad investire nel prodotto.
122Netlabs.org esprime gratitudine a Mensys BV and Serenity Systems International.
123
124Lucide dalla versione 1.3.0 e' rilasciato e distribuito con licenza CDDL/LGPL.
125
126
127:: Licenza plugin ::
128
129Le estensioni sono rilasciate sotto licenza CDDL/LGPL o GPL, a seconda del plugin.
130Vedere http://svn.netlabs.org/lucide/ per ulteriori informazioni e per ottenere
131il codice sorgente.
132
133
134:: Links ::
135
136http://www.netlabs.org
137http://www.ecomstation.com
138
139
140:: Copyright ::
141
142(c) 2006-2007 by Eugene Romanenko, netlabs.org
143(c) 2010-2011 by Dmitriy Kuminov, netlabs.org
144    in cooperazione con Serenity Systems International
145(c) 2016-2019 by netlabs.org
146    in co-operation with Arca Noae, LLC
147
Note: See TracBrowser for help on using the repository browser.