1 | %define initdir %{_sysconfdir}/rc.d/init.d
|
---|
2 | %define auth %(test -f /etc/pam.d/system-auth && echo /etc/pam.d/system-auth || echo)
|
---|
3 |
|
---|
4 | Summary: Samba SMB client and server
|
---|
5 | Vendor: Samba Team
|
---|
6 | Packager: Samba Team <samba@samba.org>
|
---|
7 | Name: samba
|
---|
8 | Version: 3.5.4
|
---|
9 | Release: 1GITHASH
|
---|
10 | Epoch: 0
|
---|
11 | License: GNU GPL version 3
|
---|
12 | Group: System Environment/Daemons
|
---|
13 | URL: http://www.samba.org/
|
---|
14 |
|
---|
15 | Source: samba-%{version}.tar.bz2
|
---|
16 |
|
---|
17 | # Don't depend on Net::LDAP
|
---|
18 | Source997: docs.tar.bz2
|
---|
19 | Source998: filter-requires-samba.sh
|
---|
20 | Source999: setup.tar.bz2
|
---|
21 |
|
---|
22 | Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
|
---|
23 | Prereq: fileutils sed /etc/init.d
|
---|
24 |
|
---|
25 | Requires: pam >= 0.64 %{auth}
|
---|
26 | Requires: samba-common = %{version}-%{release}
|
---|
27 | Requires: logrotate >= 3.4 initscripts >= 5.54-1
|
---|
28 | Provides: samba = %{version}
|
---|
29 |
|
---|
30 | Prefix: /usr
|
---|
31 | BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
---|
32 | BuildRequires: pam-devel, readline-devel, fileutils, libacl-devel, openldap-devel, krb5-devel, cups-devel, ctdb, e2fsprogs-devel
|
---|
33 |
|
---|
34 | # Working around perl dependency problem from docs
|
---|
35 | %define __perl_requires %{SOURCE998}
|
---|
36 |
|
---|
37 | # rpm screws up the arch lib dir when using --target on RHEL5
|
---|
38 | %ifarch i386 i486 i586 i686 ppc s390
|
---|
39 | %define _libarch lib
|
---|
40 | %else
|
---|
41 | %define _libarch %_lib
|
---|
42 | %endif
|
---|
43 |
|
---|
44 | %define _libarchdir /usr/%{_libarch}
|
---|
45 |
|
---|
46 | %define numcpu %(grep "^processor" /proc/cpuinfo |wc -l | sed -e 's/^0$/1/')
|
---|
47 |
|
---|
48 | %description
|
---|
49 | Samba is the protocol by which a lot of PC-related machines share
|
---|
50 | files, printers, and other information (such as lists of available
|
---|
51 | files and printers). The Windows NT, OS/2, and Linux operating systems
|
---|
52 | support this natively, and add-on packages can enable the same thing
|
---|
53 | for DOS, Windows, VMS, UNIX of all kinds, MVS, and more. This package
|
---|
54 | provides an SMB server that can be used to provide network services to
|
---|
55 | SMB (sometimes called "Lan Manager") clients. Samba uses NetBIOS over
|
---|
56 | TCP/IP (NetBT) protocols and does NOT need the NetBEUI (Microsoft Raw
|
---|
57 | NetBIOS frame) protocol.
|
---|
58 |
|
---|
59 |
|
---|
60 | ######################################################################
|
---|
61 | %package client
|
---|
62 | Summary: Samba (SMB) client programs.
|
---|
63 | Group: Applications/System
|
---|
64 | Requires: samba-common = %{version}-%{release}
|
---|
65 | Obsoletes: smbfs
|
---|
66 | Provides: samba-client = %{version}-%{release}
|
---|
67 |
|
---|
68 | %description client
|
---|
69 | The samba-client package provides some SMB clients to compliment the
|
---|
70 | built-in SMB filesystem in Linux. These clients allow access of SMB
|
---|
71 | shares and printing to SMB printers.
|
---|
72 |
|
---|
73 |
|
---|
74 | #######################################################################
|
---|
75 | %package common
|
---|
76 | Summary: Files used by both Samba servers and clients.
|
---|
77 | Group: Applications/System
|
---|
78 | Provides: samba-common = %{version}-%{release}
|
---|
79 |
|
---|
80 | %description common
|
---|
81 | Samba-common provides files necessary for both the server and client
|
---|
82 | packages of Samba.
|
---|
83 |
|
---|
84 |
|
---|
85 | #######################################################################
|
---|
86 | %package swat
|
---|
87 | Summary: The Samba SMB server configuration program.
|
---|
88 | Group: Applications/System
|
---|
89 | Requires: samba = %{version} xinetd
|
---|
90 | Provides: samba-swat = %{version}-%{release}
|
---|
91 |
|
---|
92 | %description swat
|
---|
93 | The samba-swat package includes the new SWAT (Samba Web Administration
|
---|
94 | Tool), for remotely managing Samba's smb.conf file using your favorite
|
---|
95 | Web browser.
|
---|
96 |
|
---|
97 | %ifarch x86_64 ppc64
|
---|
98 | %package winbind-32bit
|
---|
99 | Summary: Samba winbind compatibility package for 32bit apps on 64bit archs
|
---|
100 | Group: Applications/System
|
---|
101 |
|
---|
102 | %description winbind-32bit
|
---|
103 | Compatibility package for 32 bit apps on 64 bit architecures
|
---|
104 | %endif
|
---|
105 |
|
---|
106 |
|
---|
107 | #######################################################################
|
---|
108 | %package doc
|
---|
109 | Summary: Samba Documentation
|
---|
110 | Group: Documentation/Other
|
---|
111 | Provides: samba-doc = %{version}-%{release}
|
---|
112 | Prereq: /usr/bin/find /bin/rm /usr/bin/xargs
|
---|
113 |
|
---|
114 | %description doc
|
---|
115 | The samba-doc package includes the HTML versions of the Samba manpages
|
---|
116 | utilized by SWAT as well as the HTML and PDF version of "Using Samba",
|
---|
117 | "Samba By Example", and "The Official Samba HOWTO and Reference Guide".
|
---|
118 |
|
---|
119 |
|
---|
120 | #######################################################################
|
---|
121 |
|
---|
122 | %prep
|
---|
123 | %setup -q
|
---|
124 |
|
---|
125 | # setup the vendor files (init scripts, etc...)
|
---|
126 | %setup -T -D -a 999 -n samba-%{version} -q
|
---|
127 | %setup -T -D -a 997 -n samba-%{version} -q
|
---|
128 |
|
---|
129 | %build
|
---|
130 |
|
---|
131 | /bin/cp setup/filter-requires-samba.sh %{SOURCE998}
|
---|
132 |
|
---|
133 | cd source3
|
---|
134 | # RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64"
|
---|
135 |
|
---|
136 | ## check for ccache
|
---|
137 | if ccache -h >/dev/null 2>&1 ; then
|
---|
138 | CC="ccache gcc"
|
---|
139 | else
|
---|
140 | CC="gcc"
|
---|
141 | fi
|
---|
142 |
|
---|
143 | export CC
|
---|
144 |
|
---|
145 | ## always run autogen.sh
|
---|
146 | ./autogen.sh
|
---|
147 |
|
---|
148 |
|
---|
149 | ##
|
---|
150 | ## build the files for the winbind-32bit compat package
|
---|
151 | ## and copy them to a safe location
|
---|
152 | ##
|
---|
153 | %ifarch x86_64 ppc64
|
---|
154 |
|
---|
155 | # a directory to store the 32bit compatibility modules for later install
|
---|
156 | %define _32bit_tmp_dir %{_tmppath}/%{name}-%{version}-32bit
|
---|
157 |
|
---|
158 | CC_SAVE="$CC"
|
---|
159 | CC="$CC -m32"
|
---|
160 |
|
---|
161 | CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -m32" ./configure \
|
---|
162 | --prefix=%{_prefix} \
|
---|
163 | --localstatedir=/var \
|
---|
164 | --with-configdir=%{_sysconfdir}/samba \
|
---|
165 | --with-libdir=/usr/lib/samba \
|
---|
166 | --with-pammodulesdir=/lib/security \
|
---|
167 | --with-lockdir=/var/lib/samba \
|
---|
168 | --with-logfilebase=/var/log/samba \
|
---|
169 | --with-mandir=%{_mandir} \
|
---|
170 | --with-piddir=/var/run \
|
---|
171 | --with-privatedir=%{_sysconfdir}/samba \
|
---|
172 | --disable-cups \
|
---|
173 | --with-acl-support \
|
---|
174 | --with-ads \
|
---|
175 | --with-automount \
|
---|
176 | --with-fhs \
|
---|
177 | --with-pam_smbpass \
|
---|
178 | --with-libsmbclient \
|
---|
179 | --with-libsmbsharemodes \
|
---|
180 | --without-smbwrapper \
|
---|
181 | --with-pam \
|
---|
182 | --with-quotas \
|
---|
183 | --with-syslog \
|
---|
184 | --with-utmp \
|
---|
185 | --with-cluster-support \
|
---|
186 | --with-ctdb=/usr/include \
|
---|
187 | --without-ldb \
|
---|
188 | --without-dnsupdate \
|
---|
189 | --with-aio-support \
|
---|
190 | --disable-merged-build
|
---|
191 |
|
---|
192 | make showlayout
|
---|
193 |
|
---|
194 | ## check for gcc 3.4 or later
|
---|
195 | CC_VERSION=`${CC} --version | head -1 | awk '{print $3}'`
|
---|
196 | CC_MAJOR=`echo ${CC_VERSION} | cut -d. -f 1`
|
---|
197 | CC_MINOR=`echo ${CC_VERSION} | cut -d. -f 2`
|
---|
198 | if [ ${CC_MAJOR} -ge 3 ]; then
|
---|
199 | if [ ${CC_MAJOR} -gt 3 -o ${CC_MINOR} -ge 4 ]; then
|
---|
200 | make pch
|
---|
201 | fi
|
---|
202 | fi
|
---|
203 |
|
---|
204 | make -j%{numcpu} %{?_smp_mflags} \
|
---|
205 | nss_modules pam_modules
|
---|
206 |
|
---|
207 | rm -rf %{_32bit_tmp_dir}
|
---|
208 | mkdir %{_32bit_tmp_dir}
|
---|
209 |
|
---|
210 | mv ../nsswitch/libnss_winbind.so %{_32bit_tmp_dir}/
|
---|
211 | mv bin/pam_winbind.so %{_32bit_tmp_dir}/
|
---|
212 | mv bin/libtalloc.so* %{_32bit_tmp_dir}/
|
---|
213 | mv bin/libtdb.so* %{_32bit_tmp_dir}/
|
---|
214 | mv bin/libwbclient.so* %{_32bit_tmp_dir}/
|
---|
215 |
|
---|
216 | make clean
|
---|
217 |
|
---|
218 | CC="$CC_SAVE"
|
---|
219 |
|
---|
220 | %endif
|
---|
221 |
|
---|
222 | CFLAGS="$RPM_OPT_FLAGS $EXTRA -D_GNU_SOURCE" ./configure \
|
---|
223 | --prefix=%{_prefix} \
|
---|
224 | --localstatedir=/var \
|
---|
225 | --with-configdir=%{_sysconfdir}/samba \
|
---|
226 | --libdir=%{_libarchdir} \
|
---|
227 | --with-modulesdir=%{_libarchdir}/samba \
|
---|
228 | --with-pammodulesdir=%{_libarch}/security \
|
---|
229 | --with-lockdir=/var/lib/samba \
|
---|
230 | --with-logfilebase=/var/log/samba \
|
---|
231 | --with-mandir=%{_mandir} \
|
---|
232 | --with-piddir=/var/run \
|
---|
233 | --with-privatedir=%{_sysconfdir}/samba \
|
---|
234 | --with-sambabook=%{_datadir}/swat/using_samba \
|
---|
235 | --with-swatdir=%{_datadir}/swat \
|
---|
236 | --disable-cups \
|
---|
237 | --with-acl-support \
|
---|
238 | --with-ads \
|
---|
239 | --with-automount \
|
---|
240 | --with-fhs \
|
---|
241 | --with-pam_smbpass \
|
---|
242 | --with-libsmbclient \
|
---|
243 | --with-libsmbsharemodes \
|
---|
244 | --without-smbwrapper \
|
---|
245 | --with-pam \
|
---|
246 | --with-quotas \
|
---|
247 | --with-shared-modules=idmap_rid,idmap_ad,idmap_tdb2,vfs_gpfs \
|
---|
248 | --with-syslog \
|
---|
249 | --with-utmp \
|
---|
250 | --with-cluster-support \
|
---|
251 | --with-ctdb=/usr/include \
|
---|
252 | --without-ldb \
|
---|
253 | --without-dnsupdate \
|
---|
254 | --with-aio-support\
|
---|
255 | --disable-merged-build
|
---|
256 |
|
---|
257 | make showlayout
|
---|
258 |
|
---|
259 | ## check for gcc 3.4 or later
|
---|
260 | CC_VERSION=`${CC} --version | head -1 | awk '{print $3}'`
|
---|
261 | CC_MAJOR=`echo ${CC_VERSION} | cut -d. -f 1`
|
---|
262 | CC_MINOR=`echo ${CC_VERSION} | cut -d. -f 2`
|
---|
263 | if [ ${CC_MAJOR} -ge 3 ]; then
|
---|
264 | if [ ${CC_MAJOR} -gt 3 -o ${CC_MINOR} -ge 4 ]; then
|
---|
265 | make pch
|
---|
266 | fi
|
---|
267 | fi
|
---|
268 |
|
---|
269 |
|
---|
270 | make -j %{numcpu} %{?_smp_mflags} \
|
---|
271 | everything modules pam_smbpass
|
---|
272 |
|
---|
273 | # check that desired suppor has been compiled into smbd:
|
---|
274 | export LD_LIBRARY_PATH=./bin
|
---|
275 | for test in HAVE_POSIX_ACLS HAVE_LDAP HAVE_KRB5 HAVE_GPFS CLUSTER_SUPPORT
|
---|
276 | do
|
---|
277 | if ! $(./bin/smbd -b | grep -q $test ) ; then
|
---|
278 | echo "ERROR: '$test' is not in smbd. Build stopped."
|
---|
279 | exit 1;
|
---|
280 | fi
|
---|
281 | done
|
---|
282 |
|
---|
283 | # Remove some permission bits to avoid to many dependencies
|
---|
284 | cd ..
|
---|
285 | find examples docs -type f | xargs -r chmod -x
|
---|
286 |
|
---|
287 | %install
|
---|
288 | # Clean up in case there is trash left from a previous build
|
---|
289 | rm -rf $RPM_BUILD_ROOT
|
---|
290 |
|
---|
291 | # Create the target build directory hierarchy
|
---|
292 | mkdir -p $RPM_BUILD_ROOT%{_datadir}/swat/{help,include,using_samba/{figs,gifsa}}
|
---|
293 | mkdir -p $RPM_BUILD_ROOT%{_includedir}
|
---|
294 | mkdir -p $RPM_BUILD_ROOT%{_initrddir}
|
---|
295 | mkdir -p $RPM_BUILD_ROOT{%{_libarchdir},%{_includedir}}
|
---|
296 | mkdir -p $RPM_BUILD_ROOT%{_libarchdir}/samba/{auth,charset,idmap,vfs,pdb}
|
---|
297 | mkdir -p $RPM_BUILD_ROOT/%{_libarch}/security
|
---|
298 | mkdir -p $RPM_BUILD_ROOT/lib/security
|
---|
299 | mkdir -p $RPM_BUILD_ROOT%{_mandir}
|
---|
300 | mkdir -p $RPM_BUILD_ROOT%{_prefix}/{bin,sbin}
|
---|
301 | mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib
|
---|
302 | mkdir -p $RPM_BUILD_ROOT/sbin
|
---|
303 | mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{logrotate.d,pam.d,samba}
|
---|
304 | mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{pam.d,logrotate.d}
|
---|
305 | mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
|
---|
306 | mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{samba,sysconfig}
|
---|
307 | mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/xinetd.d
|
---|
308 | mkdir -p $RPM_BUILD_ROOT/var/lib/samba/winbindd_privileged
|
---|
309 | mkdir -p $RPM_BUILD_ROOT/var/{log,run/winbindd,spool}/samba
|
---|
310 | mkdir -p $RPM_BUILD_ROOT/%{_libarchdir}/krb5/plugins/libkrb5
|
---|
311 |
|
---|
312 | cd source3
|
---|
313 | make DESTDIR=$RPM_BUILD_ROOT \
|
---|
314 | install
|
---|
315 |
|
---|
316 | make DESTDIR=$RPM_BUILD_ROOT \
|
---|
317 | install-dbwrap_tool install-dbwrap_torture
|
---|
318 | cd ..
|
---|
319 |
|
---|
320 | # NSS winbind support
|
---|
321 | install -m 755 nsswitch/libnss_winbind.so $RPM_BUILD_ROOT/%{_libarch}/libnss_winbind.so.2
|
---|
322 | ( cd $RPM_BUILD_ROOT/%{_libarch};
|
---|
323 | ln -sf libnss_winbind.so.2 libnss_winbind.so )
|
---|
324 | #
|
---|
325 | # do not install libnss_wins.so in order to reduce dependencies
|
---|
326 | # (we do not need it for the samba-ctdb scenario)
|
---|
327 | #
|
---|
328 | #install -m 755 nsswitch/libnss_wins.so $RPM_BUILD_ROOT/%{_libarch}/libnss_wins.so
|
---|
329 | # ( cd $RPM_BUILD_ROOT/%{_libarch}; ln -sf libnss_wins.so libnss_wins.so.2 )
|
---|
330 |
|
---|
331 | cp -p source3/bin/winbind_krb5_locator.so ${RPM_BUILD_ROOT}/%{_libarchdir}/krb5/plugins/libkrb5
|
---|
332 |
|
---|
333 | # install files for winbind-32bit package
|
---|
334 | %ifarch x86_64 ppc64
|
---|
335 |
|
---|
336 | install -m 755 %{_32bit_tmp_dir}/libnss_winbind.so ${RPM_BUILD_ROOT}/lib/libnss_winbind.so.2
|
---|
337 | ( cd ${RPM_BUILD_ROOT}/lib; ln -sf libnss_winbind.so.2 libnss_winbind.so )
|
---|
338 |
|
---|
339 | mv %{_32bit_tmp_dir}/libtalloc* ${RPM_BUILD_ROOT}/usr/lib
|
---|
340 | mv %{_32bit_tmp_dir}/libtdb* ${RPM_BUILD_ROOT}/usr/lib
|
---|
341 | mv %{_32bit_tmp_dir}/libwbclient* ${RPM_BUILD_ROOT}/usr/lib
|
---|
342 | mv %{_32bit_tmp_dir}/pam_winbind.so ${RPM_BUILD_ROOT}/lib/security
|
---|
343 |
|
---|
344 | rm -rf %{_32bit_tmp_dir}
|
---|
345 |
|
---|
346 | %endif
|
---|
347 |
|
---|
348 | ## cleanup
|
---|
349 | /bin/rm -rf $RPM_BUILD_ROOT/usr/lib*/samba/security
|
---|
350 |
|
---|
351 | # Install the miscellany
|
---|
352 | echo 127.0.0.1 localhost > $RPM_BUILD_ROOT%{_sysconfdir}/samba/lmhosts
|
---|
353 |
|
---|
354 | install -m644 setup/samba.log $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/samba
|
---|
355 | install -m644 setup/swat $RPM_BUILD_ROOT%{_sysconfdir}/xinetd.d/swat
|
---|
356 | install -m644 setup/samba.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/samba
|
---|
357 | install -m755 setup/smb.init $RPM_BUILD_ROOT%{initdir}/smb
|
---|
358 | install -m755 setup/winbind.init $RPM_BUILD_ROOT%{initdir}/winbind
|
---|
359 | install -m644 setup/samba.pamd $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/samba
|
---|
360 | install -m755 setup/smbprint $RPM_BUILD_ROOT%{_bindir}
|
---|
361 | install -m644 setup/smbusers $RPM_BUILD_ROOT%{_sysconfdir}/samba/smbusers
|
---|
362 | install -m644 setup/smb.conf $RPM_BUILD_ROOT%{_sysconfdir}/samba/smb.conf
|
---|
363 | install -m755 source3/bin/mount.cifs $RPM_BUILD_ROOT/sbin/mount.cifs
|
---|
364 | install -m755 source3/bin/umount.cifs $RPM_BUILD_ROOT/sbin/umount.cifs
|
---|
365 | install -m755 source3/script/mksmbpasswd.sh $RPM_BUILD_ROOT%{_bindir}
|
---|
366 |
|
---|
367 | /bin/rm $RPM_BUILD_ROOT%{_sbindir}/*mount.cifs
|
---|
368 |
|
---|
369 | ln -s ../..%{initdir}/smb $RPM_BUILD_ROOT%{_sbindir}/samba
|
---|
370 | ln -s ../..%{initdir}/winbind $RPM_BUILD_ROOT%{_sbindir}/winbind
|
---|
371 |
|
---|
372 | # Remove "*.old" files
|
---|
373 | find $RPM_BUILD_ROOT -name "*.old" -exec rm -f {} \;
|
---|
374 |
|
---|
375 | ## don't duplicate the docs. These are installed by/with SWAT
|
---|
376 | rm -rf docs/htmldocs
|
---|
377 | rm -rf docs/manpages
|
---|
378 | ( cd docs; ln -s %{_prefix}/share/swat/help htmldocs )
|
---|
379 |
|
---|
380 | ##
|
---|
381 | ## Clean out man pages for tools not installed here
|
---|
382 | ##
|
---|
383 | rm -f $RPM_BUILD_ROOT%{_mandir}/man1/log2pcap.1*
|
---|
384 | rm -f $RPM_BUILD_ROOT%{_mandir}/man1/smbsh.1*
|
---|
385 | rm -f $RPM_BUILD_ROOT%{_mandir}/man5/vfstest.1*
|
---|
386 |
|
---|
387 |
|
---|
388 | %clean
|
---|
389 | rm -rf $RPM_BUILD_ROOT
|
---|
390 |
|
---|
391 | %post
|
---|
392 | ## deal with an upgrade from a broken 3.0.21b RPM
|
---|
393 | if [ "$1" -eq "2" ]; then
|
---|
394 | if [ -d /var/cache/samba ]; then
|
---|
395 | for file in `ls /var/cache/samba/*tdb`; do
|
---|
396 | /bin/cp -up $file /var/lib/samba/`basename $file`
|
---|
397 | done
|
---|
398 | mkdir -p /var/lib/samba/eventlog
|
---|
399 | for file in `ls /var/cache/samba/eventlog/*tdb`; do
|
---|
400 | /bin/cp -up $file /var/lib/samba/eventlog/`basename $file`
|
---|
401 | done
|
---|
402 | /bin/mv /var/cache/samba /var/cache/samba.moved
|
---|
403 | fi
|
---|
404 | fi
|
---|
405 |
|
---|
406 | if [ "$1" -ge "1" ]; then
|
---|
407 | /sbin/service smb condrestart >/dev/null 2>&1 || :
|
---|
408 | fi
|
---|
409 |
|
---|
410 | %preun
|
---|
411 | if [ $1 = 0 ] ; then
|
---|
412 | /sbin/service smb stop >/dev/null 2>&1 || :
|
---|
413 | /sbin/chkconfig --del smb
|
---|
414 | # rm -rf /var/log/samba/* /var/lib/samba/*
|
---|
415 | fi
|
---|
416 | exit 0
|
---|
417 |
|
---|
418 | #%postun
|
---|
419 |
|
---|
420 | %post swat
|
---|
421 | # Add swat entry to /etc/services if not already there.
|
---|
422 | if [ ! "`grep ^\s**swat /etc/services`" ]; then
|
---|
423 | echo 'swat 901/tcp # Add swat service used via inetd' >> /etc/services
|
---|
424 | fi
|
---|
425 |
|
---|
426 | %post common
|
---|
427 | /sbin/ldconfig
|
---|
428 |
|
---|
429 | if [ "$1" -ge "1" ]; then
|
---|
430 | /sbin/service winbind condrestart >/dev/null 2>&1 || :
|
---|
431 | fi
|
---|
432 |
|
---|
433 | %preun common
|
---|
434 | if [ $1 = 0 ] ; then
|
---|
435 | /sbin/service winbind stop >/dev/null 2>&1 || :
|
---|
436 | /sbin/chkconfig --del winbind
|
---|
437 | fi
|
---|
438 | exit 0
|
---|
439 |
|
---|
440 | %postun common
|
---|
441 | /sbin/ldconfig
|
---|
442 |
|
---|
443 | #######################################################################
|
---|
444 | ## Files section ##
|
---|
445 | #######################################################################
|
---|
446 |
|
---|
447 | %files
|
---|
448 | %defattr(-,root,root)
|
---|
449 |
|
---|
450 | %config(noreplace) %{_sysconfdir}/sysconfig/samba
|
---|
451 | %config(noreplace) %{_sysconfdir}/samba/smbusers
|
---|
452 | %attr(755,root,root) %config %{initdir}/smb
|
---|
453 | %config(noreplace) %{_sysconfdir}/logrotate.d/samba
|
---|
454 | %config(noreplace) %{_sysconfdir}/pam.d/samba
|
---|
455 |
|
---|
456 | %attr(0755,root,root) %dir /var/log/samba
|
---|
457 | %attr(0755,root,root) %dir /var/lib/samba
|
---|
458 | %attr(1777,root,root) %dir /var/spool/samba
|
---|
459 |
|
---|
460 | %{_sbindir}/samba
|
---|
461 |
|
---|
462 | %{_sbindir}/smbd
|
---|
463 | %{_sbindir}/nmbd
|
---|
464 |
|
---|
465 | %{_bindir}/mksmbpasswd.sh
|
---|
466 | %{_bindir}/smbcontrol
|
---|
467 | %{_bindir}/smbstatus
|
---|
468 | %{_bindir}/tdbbackup
|
---|
469 | %{_bindir}/tdbtool
|
---|
470 | %{_bindir}/tdbdump
|
---|
471 | %{_bindir}/eventlogadm
|
---|
472 |
|
---|
473 | %{_libarchdir}/samba/auth/script.so
|
---|
474 | %{_libarchdir}/samba/vfs/acl_tdb.so
|
---|
475 | %{_libarchdir}/samba/vfs/acl_xattr.so
|
---|
476 | %{_libarchdir}/samba/vfs/aio_fork.so
|
---|
477 | %{_libarchdir}/samba/vfs/audit.so
|
---|
478 | %{_libarchdir}/samba/vfs/cap.so
|
---|
479 | %{_libarchdir}/samba/vfs/default_quota.so
|
---|
480 | %{_libarchdir}/samba/vfs/dirsort.so
|
---|
481 | %{_libarchdir}/samba/vfs/expand_msdfs.so
|
---|
482 | %{_libarchdir}/samba/vfs/extd_audit.so
|
---|
483 | %{_libarchdir}/samba/vfs/fake_perms.so
|
---|
484 | %{_libarchdir}/samba/vfs/fileid.so
|
---|
485 | %{_libarchdir}/samba/vfs/full_audit.so
|
---|
486 | %{_libarchdir}/samba/vfs/gpfs.so
|
---|
487 | %{_libarchdir}/samba/vfs/netatalk.so
|
---|
488 | %{_libarchdir}/samba/vfs/preopen.so
|
---|
489 | %{_libarchdir}/samba/vfs/readahead.so
|
---|
490 | %{_libarchdir}/samba/vfs/readonly.so
|
---|
491 | %{_libarchdir}/samba/vfs/recycle.so
|
---|
492 | %{_libarchdir}/samba/vfs/shadow_copy.so
|
---|
493 | %{_libarchdir}/samba/vfs/shadow_copy2.so
|
---|
494 | %{_libarchdir}/samba/vfs/smb_traffic_analyzer.so
|
---|
495 | %{_libarchdir}/samba/vfs/streams_depot.so
|
---|
496 | %{_libarchdir}/samba/vfs/streams_xattr.so
|
---|
497 | %{_libarchdir}/samba/vfs/syncops.so
|
---|
498 | %{_libarchdir}/samba/vfs/tsmsm.so
|
---|
499 | %{_libarchdir}/samba/vfs/xattr_tdb.so
|
---|
500 |
|
---|
501 |
|
---|
502 | %{_mandir}/man1/smbcontrol.1*
|
---|
503 | %{_mandir}/man1/smbstatus.1*
|
---|
504 | %{_mandir}/man1/vfstest.1*
|
---|
505 | %{_mandir}/man5/smbpasswd.5*
|
---|
506 | %{_mandir}/man7/samba.7*
|
---|
507 | %{_mandir}/man8/nmbd.8*
|
---|
508 | %{_mandir}/man8/pdbedit.8*
|
---|
509 | %{_mandir}/man8/smbd.8*
|
---|
510 | %{_mandir}/man8/tdbbackup.8*
|
---|
511 | %{_mandir}/man8/tdbdump.8*
|
---|
512 | %{_mandir}/man8/tdbtool.8*
|
---|
513 | %{_mandir}/man8/eventlogadm.8*
|
---|
514 | %{_mandir}/man8/vfs_*.8*
|
---|
515 |
|
---|
516 |
|
---|
517 | ##########
|
---|
518 |
|
---|
519 | %files doc
|
---|
520 | %defattr(-,root,root)
|
---|
521 | %doc README COPYING Manifest
|
---|
522 | %doc WHATSNEW.txt Roadmap
|
---|
523 | %doc docs
|
---|
524 | %doc examples/autofs examples/LDAP examples/libsmbclient examples/misc examples/printer-accounting
|
---|
525 | %doc examples/printing
|
---|
526 |
|
---|
527 | ##########
|
---|
528 |
|
---|
529 | %files swat
|
---|
530 | %defattr(-,root,root)
|
---|
531 | %config(noreplace) %{_sysconfdir}/xinetd.d/swat
|
---|
532 | %dir %{_datadir}/swat
|
---|
533 | %{_datadir}/swat/*
|
---|
534 | %{_sbindir}/swat
|
---|
535 | %{_mandir}/man8/swat.8*
|
---|
536 | %attr(755,root,root) %{_libarchdir}/samba/*.msg
|
---|
537 |
|
---|
538 | ##########
|
---|
539 |
|
---|
540 | %files client
|
---|
541 | %defattr(-,root,root)
|
---|
542 | /sbin/mount.cifs
|
---|
543 | /sbin/umount.cifs
|
---|
544 |
|
---|
545 | %{_sbindir}/cifs.upcall
|
---|
546 |
|
---|
547 | %{_bindir}/rpcclient
|
---|
548 | %{_bindir}/smbcacls
|
---|
549 | %{_bindir}/findsmb
|
---|
550 | %{_bindir}/nmblookup
|
---|
551 | %{_bindir}/smbget
|
---|
552 | %{_bindir}/smbclient
|
---|
553 | %{_bindir}/smbprint
|
---|
554 | %{_bindir}/smbspool
|
---|
555 | %{_bindir}/smbtar
|
---|
556 | %{_bindir}/smbtree
|
---|
557 | %{_bindir}/sharesec
|
---|
558 |
|
---|
559 | %{_mandir}/man8/mount.cifs.8.*
|
---|
560 | %{_mandir}/man8/umount.cifs.8.*
|
---|
561 | %{_mandir}/man8/cifs.upcall.8*
|
---|
562 | %{_mandir}/man8/smbspool.8*
|
---|
563 | %{_mandir}/man1/smbget.1*
|
---|
564 | %{_mandir}/man5/smbgetrc.5*
|
---|
565 | %{_mandir}/man1/findsmb.1*
|
---|
566 | %{_mandir}/man1/nmblookup.1*
|
---|
567 | %{_mandir}/man1/rpcclient.1*
|
---|
568 | %{_mandir}/man1/smbcacls.1*
|
---|
569 | %{_mandir}/man1/smbclient.1*
|
---|
570 | %{_mandir}/man1/smbtar.1*
|
---|
571 | %{_mandir}/man1/smbtree.1*
|
---|
572 | %{_mandir}/man1/sharesec.1*
|
---|
573 |
|
---|
574 | ##########
|
---|
575 |
|
---|
576 | %files common
|
---|
577 | %defattr(-,root,root)
|
---|
578 | %dir %{_sysconfdir}/samba
|
---|
579 | %dir %{_libarchdir}/samba
|
---|
580 | %dir %{_libarchdir}/samba/charset
|
---|
581 | %config(noreplace) %{_sysconfdir}/samba/smb.conf
|
---|
582 | %config(noreplace) %{_sysconfdir}/samba/lmhosts
|
---|
583 | %attr(755,root,root) %config %{initdir}/winbind
|
---|
584 |
|
---|
585 | %attr(755,root,root) /%{_libarch}/libnss_winbind.so
|
---|
586 | %attr(755,root,root) /%{_libarch}/libnss_winbind.so.2
|
---|
587 | %attr(755,root,root) /%{_libarch}/security/pam_winbind.so
|
---|
588 | %attr(755,root,root) /%{_libarch}/security/pam_smbpass.so
|
---|
589 | /usr/share/locale/*/LC_MESSAGES/pam_winbind.mo
|
---|
590 |
|
---|
591 | %{_libarchdir}/samba/charset/CP437.so
|
---|
592 | %{_libarchdir}/samba/charset/CP850.so
|
---|
593 | %{_libarchdir}/samba/idmap/ad.so
|
---|
594 | %{_libarchdir}/samba/idmap/rid.so
|
---|
595 | %{_libarchdir}/samba/idmap/tdb2.so
|
---|
596 | %{_libarchdir}/samba/lowcase.dat
|
---|
597 | %{_libarchdir}/samba/nss_info/rfc2307.so
|
---|
598 | %{_libarchdir}/samba/nss_info/sfu.so
|
---|
599 | %{_libarchdir}/samba/nss_info/sfu20.so
|
---|
600 | %{_libarchdir}/samba/upcase.dat
|
---|
601 | %{_libarchdir}/samba/valid.dat
|
---|
602 |
|
---|
603 | %{_includedir}/libsmbclient.h
|
---|
604 | %{_libarchdir}/libsmbclient.*
|
---|
605 | %{_includedir}/smb_share_modes.h
|
---|
606 | %{_libarchdir}/libsmbsharemodes.so
|
---|
607 | %{_libarchdir}/libsmbsharemodes.so.0
|
---|
608 |
|
---|
609 | %{_includedir}/netapi.h
|
---|
610 | %{_includedir}/wbclient.h
|
---|
611 | %{_includedir}/talloc.h
|
---|
612 | %{_includedir}/tdb.h
|
---|
613 | %{_libarchdir}/libnetapi.so
|
---|
614 | %{_libarchdir}/libnetapi.so.0
|
---|
615 | %{_libarchdir}/libtalloc.so
|
---|
616 | %{_libarchdir}/libtalloc.so.1
|
---|
617 | %{_libarchdir}/libtdb.so
|
---|
618 | %{_libarchdir}/libtdb.so.1
|
---|
619 | %{_libarchdir}/libwbclient.so
|
---|
620 | %{_libarchdir}/libwbclient.so.0
|
---|
621 |
|
---|
622 | %{_libarchdir}/krb5/plugins/libkrb5/winbind_krb5_locator.so
|
---|
623 |
|
---|
624 | %{_sbindir}/winbind
|
---|
625 |
|
---|
626 | %{_sbindir}/winbindd
|
---|
627 | %{_bindir}/testparm
|
---|
628 | %{_bindir}/smbpasswd
|
---|
629 | %{_bindir}/profiles
|
---|
630 | %{_bindir}/net
|
---|
631 | %{_bindir}/ldbadd
|
---|
632 | %{_bindir}/ldbdel
|
---|
633 | %{_bindir}/ldbedit
|
---|
634 | %{_bindir}/ldbmodify
|
---|
635 | %{_bindir}/ldbsearch
|
---|
636 | %{_bindir}/ldbrename
|
---|
637 | %{_bindir}/wbinfo
|
---|
638 | %{_bindir}/ntlm_auth
|
---|
639 | %{_bindir}/pdbedit
|
---|
640 | %{_bindir}/smbcquotas
|
---|
641 | %{_bindir}/dbwrap_tool
|
---|
642 | %{_bindir}/dbwrap_torture
|
---|
643 |
|
---|
644 | %{_mandir}/man1/ntlm_auth.1*
|
---|
645 | %{_mandir}/man1/profiles.1*
|
---|
646 | %{_mandir}/man1/smbcquotas.1*
|
---|
647 | %{_mandir}/man1/testparm.1*
|
---|
648 | %{_mandir}/man5/smb.conf.5*
|
---|
649 | %{_mandir}/man5/lmhosts.5*
|
---|
650 | %{_mandir}/man8/smbpasswd.8*
|
---|
651 | %{_mandir}/man1/wbinfo.1*
|
---|
652 | %{_mandir}/man8/winbindd.8*
|
---|
653 | %{_mandir}/man8/net.8*
|
---|
654 | %{_mandir}/man8/pam_winbind.8*
|
---|
655 | %{_mandir}/man7/libsmbclient.7*
|
---|
656 | %{_mandir}/man1/ldbadd.1*
|
---|
657 | %{_mandir}/man1/ldbdel.1*
|
---|
658 | %{_mandir}/man1/ldbedit.1*
|
---|
659 | %{_mandir}/man1/ldbmodify.1*
|
---|
660 | %{_mandir}/man1/ldbsearch.1*
|
---|
661 | %{_mandir}/man1/ldbrename.1*
|
---|
662 | %{_mandir}/man7/winbind_krb5_locator.7*
|
---|
663 | %{_mandir}/man8/idmap_*.8*
|
---|
664 |
|
---|
665 | %ifarch x86_64 ppc64
|
---|
666 | %files winbind-32bit
|
---|
667 | %attr(755,root,root) /lib/libnss_winbind.so
|
---|
668 | %attr(755,root,root) /lib/libnss_winbind.so.2
|
---|
669 | %attr(755,root,root) /usr/lib/libtalloc.so
|
---|
670 | %attr(755,root,root) /usr/lib/libtalloc.so.1
|
---|
671 | %attr(755,root,root) /usr/lib/libtdb.so
|
---|
672 | %attr(755,root,root) /usr/lib/libtdb.so.1
|
---|
673 | %attr(755,root,root) /usr/lib/libwbclient.so
|
---|
674 | %attr(755,root,root) /usr/lib/libwbclient.so.0
|
---|
675 | %attr(755,root,root) /lib/security/pam_winbind.so
|
---|
676 | %endif
|
---|
677 |
|
---|
678 |
|
---|
679 |
|
---|
680 | %changelog
|
---|
681 | * Fri Jan 16 2004 Gerald (Jerry) Carter <jerry@samba,org>
|
---|
682 | - Removed ChangeLog entries since they are kept in CVS
|
---|
683 |
|
---|
684 |
|
---|
685 |
|
---|