Opened 8 years ago

Closed 8 years ago

#262 closed defect (wontfix)

qt4-linguist package should have dependency to qt assistant

Reported by: andib Owned by:
Priority: trivial Milestone: Qt Enhanced
Component: rpm package Version: 4.7.3
Severity: low Keywords:
Cc:

Description

qt linguist help does not work when qt assistant is not installed. When installing linguist, assistant should be installed automatically too.

Change History (1)

comment:1 Changed 8 years ago by dmik

  • Resolution set to wontfix
  • Status changed from new to closed

Not fully correct. In order to view Qt Linguist help you need to install both Qt Docs and Qt Assistant. And this is true for any other Qt tool that has the official documentation.

In other words, enabling what you are asking for means that Qt Docs and Qt Assistant should be always installed which beats the idea of their separation -- Qt Docs is quite big (74M) and not everybody needs it. The general rule is that the documentation packages are not automatically installed.

We may review/change this rule in the future, however. I.e. when the GUI ready, we can add an preference to automatically install documentation for each package that has it.

Version 0, edited 8 years ago by dmik (next)
Note: See TracTickets for help on using tickets.