Custom Query (272 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (1 - 3 of 272)

1 2 3 4 5 6 7 8 9 10 11
Ticket Resolution Summary Owner Reporter
#293 wontfix Inconsistent left mouse button behavior in all Qt apps with SNAP and animated pointers Lewisr Lewisr
Description

This one has been a thorn in my side for some time. I thought I opened a bug about it a while back. I'll look at this myself, as it's probably just a conflict, but this will document the issue in case anyone else sees it.

eCS 2.1 IBM Single Mouse driver 10.163 (TouchPad? disabled in BIOS) SNAP Build 505 (formerly saw this same behavior under SNAP Pro) ThinkPad? T43 / ATI X300 SXGA video (also on ThinkPad? T43p / ATI X600 SXGA+ video) Warp Overlay (possible issue?) XWorkplace 1.0.9 (hook enabled) Christian Langanke's Animated Mouse Pointer 1.01

Mouse object settings:

TrackPoint? Enabled [x] (I see this same issue with a PS/2 mouse connected to the dock) Auto Disable TrackPoint? [ ] Scrolling and Magnifying Glass: Neither Choose Function Method: Press Center Button, then use pointing device Scrolling Speed: Normal Scrolling Type: Use PM Scroll Enable Press-to-Select: [ ] Sensitivity: Light Touch (maximum) Setup: Right-handed Mappings:

Displaying Window List: Buttons 1 and 2 Dragging objects: Button 2 Displaying pop-up menus: Button 2 / Single-click Editing title text: Button 1 / Single-click / Alt

Additional mappings:

Allow show window list everywhere

Timing:

Double-click rate: 75-80% Tracking speed: 100%

Comet Cursor On

Color: DarkGray? Border Color: Gray Trail Length: Long Circle Size: Large Activation Speed: Slow

Movement:

Sliding focus not enabled Sliding menu selection enabled (this we see under Qt)

Submenu delay: 500ms Conditioinal cascade sensitivity [x]

Auto-hide mouse pointer not enabled Auto-move mouse pointer to dialog button enabled

Delay: 100ms Animation [x]

All mouse options off for Styler/2

SNAP settings from CONFIG.SYS:

REM *** SciTech SNAP Professional ***
DEVINFO=SCR,VGA,C:\OS2\BOOT\VIOTBL.DCP
SET VIDEO_DEVICES=VIO_SVGA
SET VIO_SVGA=DEVICE(BVHVGA,BVHSVGA)
DEVICE=C:\OS2\MDOS\VSVGA.SYS
SET GRADD_CHAINS=C1
DEVICE=C:\OS2\GRADD.SYS
DEVICE=C:\OS2\MDOS\VMANWIN.SYS
SET GREEXT=SDDGREXT
REM SET C1=SDDGRADD
SET C1=SDDGRADD,WOVERLAY
DEVICE=C:\OS2\SDDHELP.SYS /Q
SET SNAP_MAXVRAM_32MB=Y
SET SDDFONTSIZE=small
SET SDDFONTDPI=96
SET SDDICONS=small
SET VCFG_NO_DDC=TRUE
REM *** SciTech SNAP Professional ***

Symptom:

Mouse hover works as expected. Middle and right buttons work as expected. Most of the time, however, selecting and activating anything with the left mouse button fails (the button press is registered on screen, but not passed to the underlying program). It is possible to hover the mouse to highlight a selection and then press <Enter> to activate it, or in the case of checkboxes or radio buttons, <Enter> or <Spacebar> will select.

It is possible to select a variety of checkboxes in a particular dialog (QPassGen is an example), and have none of them actually register in the application, though going back, deselecting, and then pressing <Spacebar> to select works.

Switch mouse pointer set to a non-animated set (default black, for example), and the left mouse button behaves as desired.

I do not see this exact symptom with Java applications, though the mouse can behave badly there, too (and when the memory corruption is experienced per http://trac.netlabs.org/java/ticket/65, I do see that the animated pointer reverts to the default black pointer. In all cases when that occurs, I know that INI files will not properly save and the system needs to be rebooted.

More on this as I narrow it down. It may be an issue with the Animated Pointer package, though Christian stated to me via email 2011-08-02:

I am sorry to say that WPAMPTR has absolutely nothing to do with displaying the pointers! It only tells the system which one would to be used, and does that every some milliseconds. Therefore the only one to blame is the graphic driver, as this implements the interface that the system uses for displaying the pointer.

The last thing which might possibly impact timing and memory here is that I have Comet Cursor enabled.

#1 fixed Port qmake diver diver
Description

Tracker for general discussion about the milestone.

#2 fixed Port all important basic classes from src/corelib diver diver
Description

Tracker for general discussion about the milestone.

1 2 3 4 5 6 7 8 9 10 11
Note: See TracQuery for help on using queries.