Changes between Version 78 and Version 79 of WikiStart


Ignore:
Timestamp:
Apr 1, 2020, 6:14:02 PM (2 months ago)
Author:
Lewis Rosenthal
Comment:

Added warning about legacy package installations being required when updating poppler. See https://mantis.arcanoae.com/view.php?id=2808.

Legend:

Unmodified
Added
Removed
Modified
  • WikiStart

    v78 v79  
    1717
    1818== Additional software prerequisites ==
    19 It is strongly recommended to install from RPM, though WPI is still supported for most prerequisites:
     19It is strongly recommended to install from RPM (using YUM or Arca Noae Package Manager), though zipped packages may be available for some prerequisites.
    2020
    2121If you use RPM, you should install the following with the single command for versions up through '''1.3.5''':
     
    4545To have Japanese fonts working in '''1.5.0''' you need the poppler-data package. This is listed above. If you do not wish to add such support, you may omit it from the Quick install list. Libcx is not required for version 1.4.0.
    4646
     47=== Notes about RPM/YUM updates ===
     48From time to time, updates to various RPMs may break compatibility with some Lucide components. This is particularly true of the PDF plugin, which depends upon the poppler library, which may require a "legacy" package to be installed to satisfy its dependency. As of Lucide 1.5.0, the PDF plugin requires poppler 0.59.0. If updating poppler beyond 0.59.0, be sure to select the latest poppler-legacy-<version>-0.59.0-<release> for your platform (e.g., poppler-legacy-70-0.59.0-3.oc00.L) to satisfy the PDF plugin's dependency.
     49
     50Newer legacy versions do not replace older ones, but merely provide additional backward compatibility. Thus, poppler-legacy-70-0.59.0-3.oc00.L may be installed alongside poppler-legacy-66-0.52.0-1.oc00.L as they provide different compatibilities (the "70-0.59.0" package does not update, upgrade, obsolete, or replace the "66-0.52.0" legacy package; they do different things).
    4751
    4852== Latest Versions ==
     
    8286Anonymous access to the ticket system has been restricted due to multiple spam attacks. In order to create a new ticket or comment on an existing one, you will need to log in with your Netlabs login id. If you do not have a login id, you may request one [http://www.netlabs.org/en/site/member/member.xml here].
    8387
    84 Due to the inclusion of a forwarder in recent poppler builds, issues experienced before where the installation of a new poppler build would result in Lucide's PDF plugin not being loaded have essentially been resolved. The Lucide Project extends great thanks to the porting team for their consideration and work in this regard.
     88Due to the inclusion of a forwarder in recent poppler builds, issues experienced before where the installation of a new poppler build would result in Lucide's PDF plugin not being loaded have essentially been resolved. The Lucide Project extends great thanks to the porting team for their consideration and work in this regard. (See updating notes above for cautions which still apply.)
    8589
    8690